Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Unity for Python 3.7 status

Discussion in 'Formats & External Tools Previews' started by bjornsyse, Nov 1, 2021.

  1. bjornsyse

    bjornsyse

    Joined:
    Mar 28, 2017
    Posts:
    76
    Hi

    I was about to try using Python for Unity to hook up to an Ouster Lidar, which expose a python api. However, they only support Python 3.6 or later. So now I'm in a limbo where Python for Unity requires an older version but Ouster api a later.

    What's the status on the development to support Python 3.6 or later? @Matjio

    Best regards

    Björn
     
  2. markvi

    markvi

    Unity Technologies

    Joined:
    Oct 31, 2016
    Posts:
    117
    Hi Bjorn, sorry for the late reply, I just saw this now. We have released Python as a pre-release package (using Python 3.7.9). You can find installation instructions here.