Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Unity Error message when integrating ARCore Extensions/Google.IOSResolver.dll' will not be loaded

Discussion in 'AR' started by unity_89AF7699584C13937232, Sep 18, 2023.

  1. unity_89AF7699584C13937232

    unity_89AF7699584C13937232

    Joined:
    Sep 18, 2023
    Posts:
    1
    Hello dear community,

    I would like to integrate the ARCore Extensions Packet into Unity:
    Link: Getting started with ARCore Extensions for AR Foundation | Google for Developers
    But I always get the same error message:
    "Assembly 'Packages/com.google.ar.core.arfoundation.extensions/Editor/ExternalDependencyManager/Editor/Google.IOSResolver.dll' will not be loaded due to errors:
    Unable to resolve reference 'UnityEditor.iOS.Extensions.Xcode'. Is the assembly missing or incompatible with the current platform?

    I have tested some suggested solutions and integrated different package versions, but the error message remains. I tested the following suggested solutions, which didn't work:
    Link: Google.IOSResolver will not be loaded in 2021.1.11f1 and later - Unity Forum
    Link: [BUG] Unable to resolve reference 'UnityEditor.iOS.Extensions.Xcode' on Windows · Issue #412 · googlesamples/unity-jar-resolver · GitHub

    Does anyone have a solution for me that I could test?

    Thank you,
    Andreas Binder

     
  2. andyb-unity

    andyb-unity

    Unity Technologies

    Joined:
    Feb 10, 2022
    Posts:
    956