Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Question Unity Editor Very slow and unusable on Debian (testing)

Discussion in 'Linux' started by dreamos1982, Jun 8, 2023.

  1. dreamos1982

    dreamos1982

    Joined:
    Jan 27, 2020
    Posts:
    8
    I recently installed unity editor on a debian linux machine.

    But it is totally unusable, very slow and laggy, as can be seen from the video


    The menus take ages to close, as well as windows, switching between tabs has more or less the same issue.

    My laptop configuration is:
    • Lenovo ThinkPad T480S
    • Intel(R) Core(TM) i5-8350U CPU @ 1.70GHz
    • 23.2 GiB of RAM
    • Mesa Intel® UHD Graphics 620
    I tried to tweak the quality settings, switchet from ultra to medium, but apparently nothing has changed.

    Also when unity is started, the overall machine performance is pretty degraded. Any idea?

    Any idea on how to improve the situation?
    I have it installed on fedora and is working decently.
     
  2. ChiwTheNeko

    ChiwTheNeko

    Joined:
    Mar 24, 2022
    Posts:
    150
    Quality settings will not affect the performances of the editor.

    Looks like you're on KDE. First check that the compositor is enabled, search for it in KDE's settings.

    On Unity's side try switching to Vulkan in project settings and try tweaking the Interaction Mode in Preferences.
     
    salah-rashad and tylerinthezoo like this.
  3. dreamos1982

    dreamos1982

    Joined:
    Jan 27, 2020
    Posts:
    8
    Thanks enabling the compositor make things much more smoother.
     
    salah-rashad and tylerinthezoo like this.
  4. sandilyasg

    sandilyasg

    Joined:
    Oct 10, 2023
    Posts:
    3
    How do you switch to Vulkan in project settings? I see a number of tabs in there like Editor and Graphics but could not find where to switch to Vulkan.

    EDIT: I found this: "Navigate to Project Settings > Player > Other Settings. Choose OpenGLES2 , OpenGLES3 , or Vulkan , or any combination of them in Graphics APIs. "

    I switched to Vulkan but had the same problem. However, doing going to NVIDIA X Server Settings -> OpenGL Settings -> Unchecked "Sync to VBlank", then restarting the system worked, as I learned from this issue.
     
    Last edited: Nov 6, 2023
  5. chibiskuld2

    chibiskuld2

    Joined:
    Nov 11, 2022
    Posts:
    11
    I'm having this problem sadly still with Xubuntu 23.10 (X=XFCE).
     
  6. chibiskuld2

    chibiskuld2

    Joined:
    Nov 11, 2022
    Posts:
    11
    Never Mind my last post!

    I found out it was the fault of my shader. It was having issues under Linux with it's shadow caster. For some reason the broken shadow caster was grinding Unity to a near halt. Seems to break for both OGL and Vulkan. The fix was just removing it and using a fallback to Standard. TBF there's no reason to write a custom shadow caster unless you're doing weird effects anyways.