Search Unity

Unity editor slow

Discussion in 'Editor & General Support' started by SSL7, Aug 1, 2017.

  1. SSL7

    SSL7

    Joined:
    Mar 23, 2016
    Posts:
    296
    Dear All,

    I have a problem with Unity Editor with my 3D project. So basically is very slow when Scene window is open, Hierarchy lagging, the scene window almost can't move etc.

    I m having a large map with thousands of objects which you would say it makes sense to lag the whole editor but I have some argument here.

    My main PC is a Ryzen 1700x (8 cores/16 threads) with 16 gigs of fast ram and Nvidia 1070 and a m.2 SSD drive (around 3000 read/write speed).
    My Laptop is a 3-4 years old laptop with a 3rd generation Intel, 16gigs of ram and a crappy GTX 750m.
    both Unity 5.6.2f1

    Now the same project lags hard on laptop and PC (in the editor), but it's fine in Play Mode (more FPS on the PC of course).

    The weird part is that when I check the resources of my PC (CPU/RAM/GPU), when in the editor and trying to edit my project, it hardly uses more than 10% of CPU, and 50% of RAM and GPU is running chilled. So I can't really understand why I have almost the same hard time editing my project on my main PC as my Laptop?

    What I did:

    Updated all drivers, everything
    Tried some -opengl and -nosinglethread etc. (doesn't really work, my project is dx11)
    Wiped everything reinstalled

    What it works, of course, is when I disable most of my map's objects, but that is counter productive and again, it doesn't make sense to lag when Unity doesn't utilize even the 1/3 of my system's power.

    Any thoughts?

    tl;dr: How can I make unity use my PC's power and not being so slow when in edit mode.
     
    Last edited: Aug 1, 2017
  2. Dreamwriter

    Dreamwriter

    Joined:
    Jul 22, 2011
    Posts:
    472
    I have the same problem, when first loading my complex scene into the Editor. For me, what fixes that is to run the game, or wait around 15 minutes. For some reason pressing play, then stopping the game once it’s done loading, fixes Unity’s responsiveness, so I always have to do that when opening the scene in the Editor. I once ran the profiler on the Editor during the slowdown, it was doing some sort of Ambient Illumination calculations (though my game doesn’t bake lighting or AI)
     
  3. marcossi

    marcossi

    Joined:
    Apr 5, 2017
    Posts:
    1
    I worked with "3D unity" for a long time and never had problems. I bought an oculus rift, install the SDK and no problems too.

    Then, I formatted my computer, installed my Oculus (but not the SDK) and Unity began to behave as you write in this post. Searching the internet I found a person who said that the problem came from the service of the Oculus Rift. Disable the Oculus service and then Unity worked correctly.

    I hope it helps you
     
  4. Dreamback

    Dreamback

    Joined:
    Jul 29, 2016
    Posts:
    185
    For me the problem was definitely realtime Ambient Illumination, if I disable that in the Lighting window, the problem goes away (but then I lose that feature). Since it’s realtime, I dunno why Unity is baking something - I seem to remember Unity previously having options to either bake or precalculate it, or just run it realtime, but they seem to have removed the option and just force you to use precalculation if you have realtime AI enabled.
     
  5. jeromeWork

    jeromeWork

    Joined:
    Sep 1, 2015
    Posts:
    319
    Did that work out for you as a solution?

    Having the same problem here. Unfortunately some of my problematic projects are for VR so disabling the Oculus service is not ideal, but might be the only solution while I work. Currently the editor is so slow that it's unusable.
     
  6. Fab4

    Fab4

    Joined:
    Sep 30, 2012
    Posts:
    114
    I almost have the same system and see similar problems in 2018.2
    I found my answer in the lighting window.

    I deactivated "Fog" and "Auto Generate" lighting. Than I activated Fog again and generated the Lighting with the click on the button. Everything runs smooth now.
     
  7. King-Klong

    King-Klong

    Joined:
    Dec 4, 2015
    Posts:
    4
    I also have Oculus installed for our project. My only issue in the editor is that when I hit play, Unity locks up for 1-3 minutes, then runs normally. My coworker can get it to run in under 10 seconds consistantly, and I have a faster computer than him.
     
  8. FlightFight

    FlightFight

    Joined:
    May 29, 2017
    Posts:
    3
    For me it was opening a folder with big 16bit 48kHz .wav files in the project folder.
    Once I closed the folder everything was fine but I couldn't work like that so I converted them into .ogg files.
    Edit: Changing the audio file import settings from "compress on load" to "streaming" did the trick. It didn't have anything to do with the file format.
     
    Last edited: Dec 17, 2018