Search Unity

  1. Get all the Unite Berlin 2018 news on the blog.
    Dismiss Notice
  2. Unity 2018.2 has arrived! Read about it here.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  4. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  5. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  6. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Unity Editor Really slow

Discussion in 'Editor & General Support' started by tonsleegers, Jan 18, 2012.

  1. tonsleegers

    tonsleegers

    Joined:
    Nov 17, 2010
    Posts:
    7
    Hello,
    I got a relatively new desktop pc but the unity editor is really slow. I take around half a second te respond to any clicks and de graphic stats show a frame rate of around 3-5 fps in the game view. This also occurs with a empty scene. I also tried switching from Unity 3.4.1 to the 3.5 beta but nothing changed. All other programs I run don't have this problem.

    Specs of my pc:
    Intel core i7 2600k
    16gb of memory (4 x Kingston 4GB, DDR3, PC10666, CL9)
    Intel DH67CL B3 iH67
    Asus GeForce GTX580 DCII 1.5GB
    OCX Vertex 3 120 gb
    Samsung HD204UI 2TB
    Corsair TX850 V2 850W
    Windows 7 proffesional

    Anyone has an idea what may cause the performance issue?

    Screenshot: http://i43.tinypic.com/2a6wbgo.png
     
  2. Swearsoft

    Swearsoft

    Joined:
    Mar 19, 2009
    Posts:
    1,561
    What else is running?
     
  3. Stardog

    Stardog

    Joined:
    Jun 28, 2010
    Posts:
    1,074
    Try disabling any forced antialiasing settings (and anything else that's being forced) in your GTX control panel.
     
  4. tonsleegers

    tonsleegers

    Joined:
    Nov 17, 2010
    Posts:
    7
    Only Chrome with a couple of sites open.

    Everything was set to let the Application choose, disable everything but nothing changed.
     
  5. bluntgames

    bluntgames

    Joined:
    Jan 18, 2012
    Posts:
    22
    Any luck with this issue? I recently upgraded to a new PC and Unity is running really really badly... un-usable.
    spec :

    asus gtx 580
    core i7 3930 3.2ghz
    ocz revodrive3X2
    16Gb RAM
    Win 7 pro x64

    it's a fresh windows install, updated to latest drivers for everything and all latest windows updates too.

    starting to get frustrated :'(

    update: happens in the angry bots demo too. runs at an awesome framerate but has constant lag spikes that dont actually show up in the stats or profile view.
    Also, the update of all the editor windows seems to really lag behind any input.
    If I select 'maximise' on the game window then the problem goes away. Bringing any other windows back brings back the stuttering....

    update:
    seems to be linked to the heirachy window. whenever that is visible everything goes to hell...

    ideas?
     
    Last edited: Feb 15, 2012
  6. tonsleegers

    tonsleegers

    Joined:
    Nov 17, 2010
    Posts:
    7
    Only worked om my laptop lately so didn't find a solution.
     
  7. bluntgames

    bluntgames

    Joined:
    Jan 18, 2012
    Posts:
    22
    I might have to try a different video card.... it's really annoying to pull it out though. Uggh
     
  8. bluntgames

    bluntgames

    Joined:
    Jan 18, 2012
    Posts:
    22
    Progress!

    I killed all processes except essentials and disabled the nvidia / amd services that were running (why an amd service was running is unknown). And now unity is responsive again yay.

    Now I'll need to nail down exactly which program was causing the problem.
     
  9. cvet

    cvet

    Joined:
    Feb 21, 2012
    Posts:
    3
    I have same problem. Respond after any input is too big (1-2 second).
    After killing most processes is works better, but not good at all (respond ~0.5 second).
    But Edtor works good on MacOSX in VMware and WindowsXP in VirtualBox on current machine, without that lags.
    Tested on versions 3.4.2 and 3.5.

    System:
    Windows7 x64
    CPU Intel i5-2500
    RAM Kingston 12Gb (4*3)
    Video Asus GeForce GTX 560Ti 1Gb
    HDD Intel SSD 320 Series
     
    Last edited: Feb 22, 2012
  10. cvet

    cvet

    Joined:
    Feb 21, 2012
    Posts:
    3
    I found reason why it happens - if whole memory consumption (for all running processes, not only Editor) is not greater approx 2GB then all works good, but if memory grows higher then Editor slow down.
    Tested on two separate machines with Windows7 x64, on first 12Gb RAM, on second 4Gb.
    Memory consumption get from field Commit/Physical memory in ProcessExplorer.
     
  11. cvet

    cvet

    Joined:
    Feb 21, 2012
    Posts:
    3
    Workaround what worked for me - start Editor with command line option "-force-opengl".
    Btw I use latest stable NVIDIA drivers (but trying latest beta too) and latest DirectX.
     
    nohmask, rsheffield and Setmaster like this.
  12. bluntgames

    bluntgames

    Joined:
    Jan 18, 2012
    Posts:
    22
    I love you.
    :D

    This fixed my issues...awesome that you found it. I was getting tired of killing everything bar unity!

     
  13. ShannonB

    ShannonB

    Joined:
    Jul 16, 2012
    Posts:
    1
    Ok, same problem. Using "-force-opengl" fixed it. I can actually work in the editor now, was making me want to smash stuff before.

    So anyone know WHY this is happening and if there's a more permanent solution?
     
  14. DarkPlayer

    DarkPlayer

    Joined:
    Jul 20, 2012
    Posts:
    2
    I just got started with Unity and i ran into the same problem.
    Luckily "-force-opengl" fixed it for me,

    thank you cvet :)
     
  15. AlfredB

    AlfredB

    Joined:
    Jul 27, 2012
    Posts:
    7
    well i fixed it by going in to my terrain and lowering the detail distance to 0.
    I just increase it when i build/run my project :)
     
  16. CG-DJ

    CG-DJ

    Joined:
    Jan 28, 2012
    Posts:
    73
    FIXED IT!!!!!
    Uninstall ASUS GamerOSD. and then restart computer. For some reason it was clogging alot of things up: Arkham Asylum, Unity, UDK...
    (Thanks Chrisso in the unity forums)
     
  17. fuzzysmurf

    fuzzysmurf

    Joined:
    Aug 21, 2011
    Posts:
    81
    Hi,

    I did the same thing, and uninstalled ASUS GamerOSD, then out of no where everything is efficient now.
    My PC starts up a few seconds faster now.

    I dont know why that was an issue to begin with, or what it does.
     
  18. bloomingdedalus

    bloomingdedalus

    Joined:
    Aug 13, 2012
    Posts:
    139
    Forcing DX11 might work as well... I had to force that on the 555m to make the editor even usable - but my problem was way worse than it just being slow.
     
  19. NonGamingCoder

    NonGamingCoder

    Joined:
    Aug 28, 2013
    Posts:
    14
    I would *really* love to know what it is that causes Unity to slow down. My machine was purpose built for Unity, albeit we used consumer accessible equipment.

    8 Cores, 4.2GHz, 32gb of RAM, 2x ATI 7970 3gb, 4 solid state drives (1x for OS, 1x for swap, 1x for data and 1x for unity on a dedicated controller) and a ram disk for temp files. Apparently that's not enough for Unity?

    It's running Windows 8.1 and has no problems running the entire adobe suite simultaneously.

    I'd avoid using features which make Unity slow, if I just knew what they were. How about some algorithmic efficiency? Pretty please?
     
  20. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    31,748
    Obviously it's much more than enough; it's not "features that make Unity slow", it's some kind of bug, likely with the OS, given the number of times I've seen "fine on Windows 7, not fine on Windows 8.1". For example, the issue with slowdowns on OS X when using Mavericks, which turned out to be a bug in the graphics drivers. Just because the Adobe suite runs OK doesn't mean there's not some problem in the OS which is triggered by Unity.

    --Eric
     
  21. oneslyfox

    oneslyfox

    Joined:
    Sep 4, 2012
    Posts:
    71
    I tried all the above suggestions, but nothing worked--only minute improvements. Disabling all the Nvidia background processes in Services running "msconfig" fixed it. I went from 15 FPS to 170 FPS in the title screen of the game. 8-15 FPS in-game to 50-80 FPS.
     
  22. mkovac

    mkovac

    Joined:
    Oct 12, 2012
    Posts:
    1
    Sometimes, the editor is brought to halt (response time in several seconds), when changing transform of complex object with mesh colliders pre-generated upon import.
     
  23. TwisterK

    TwisterK

    Joined:
    Oct 26, 2010
    Posts:
    110
    For those who encounter the same problem.

    Platform : Windows 8.1
    Plugin that used with Unity Inspector : "Heavy Duty plugin"
    Graphic Card : GTX 970M
    Ram : 8 GB

    Unity's inspector was very laggy and start Editor with "force-opengl" actually solved my problem.

    Thanks!
     
  24. Envy789

    Envy789

    Joined:
    Nov 7, 2012
    Posts:
    1
    Thanks this fix the problem for me too, in unity 5.3

    Platform : Windows 10
    Processor: 5820k @ 4.0Ghz
    Graphic Card : GTX 980ti
    Ram : 8 GB
     
  25. Thebeatboxer

    Thebeatboxer

    Joined:
    Dec 10, 2014
    Posts:
    4
    Thank you very much man!
    You saved me! :))
     
  26. rsheffield

    rsheffield

    Joined:
    Jan 4, 2016
    Posts:
    1
    There is clearly an issue w/ Unity here, as opening the IDE forcing opengl resolved this incredibly annoying issue for me as well. Having to wait 4-5sec to open a contextual dialog to add assets is ridiculous.

    Unity 5.3.1
    Windows 10 Pro
    5960X
    32GB RAM
    TitanX
    OS on PCIE SSD
    Unity installed & all assets located on 1TB SATA SSD.

    Big thanks to @cvet for listing the -force-opengl workaround NEARLY 4YRS AGO.
     
    nohmask likes this.
  27. alex4unity

    alex4unity

    Joined:
    Apr 28, 2013
    Posts:
    26
    hey I got this problem, too and opengl fixed it as well but it says its deprecated... That always means its old and outdated and some features may not work as expected! So could you please find out what it is?

    Edit: Just did a clean video card driver installation (Driver Cleaner by GURU3d and Fresh Install of the newest nvidia driver) and this somehow fixed the issue for me, it even fixed spikes while navigation through my level quickly... maybe its worth a try guys?!
     
    Last edited: Jan 6, 2016
    mdotstrange likes this.
  28. zhuchun

    zhuchun

    Joined:
    Aug 11, 2012
    Posts:
    292
    Hey guys, I met this problem before, if solutions above can't help you, here's a new direction for you.
    Check your asset, especially for those assets who focus on interact with your Editor itself. They may slow down your editor and makes it take seconds to respond. Create a new project, import assets one by one, then try to hit ctrl+shift+n(Create Empty) and see if it's slow.
     
    mdotstrange likes this.
  29. kingzope

    kingzope

    Joined:
    Apr 27, 2016
    Posts:
    2
    I installed both the beta and non beta version of Unity and I'm running into the same problem with bad input lag. I did tons of troubleshooting and then found this thread. I've now tried everything on here and still have the issue. I'm not sure where to go from here but Unity is absolutely unusable for me with the input lag.
     
  30. zhuchun

    zhuchun

    Joined:
    Aug 11, 2012
    Posts:
    292
    Hi, if you have this trouble with an empty project in Editor, you probably meet some bug of Unity, that's a headache. Otherwise, it could related to assets, you may use my way to find out what asset it is and remove it.
     
  31. Flurgle

    Flurgle

    Joined:
    May 16, 2016
    Posts:
    260
  32. alex4unity

    alex4unity

    Joined:
    Apr 28, 2013
    Posts:
    26
    nice to help you out with that... but I had some issues again after I did this and it was due to the g-sync option! I dont know anymore what I did, either turning it completly off or just running fullscreen only! I have fullscreen only by now and all runs smooth. I also had problems with power consumption when turned on fullscreen and window mode. Nvidia may have fixed that with the latest driver updated, IDK. Make sure you always check on clean installation when you update via experience.

    so long...
     
  33. Flurgle

    Flurgle

    Joined:
    May 16, 2016
    Posts:
    260
    Yeah i am having the issues come back again :( not sure why. I don't even have a g-sync setting in my nvidia control panel.
     
  34. Flurgle

    Flurgle

    Joined:
    May 16, 2016
    Posts:
    260
    Ok just restarted Unity, and it seems fixed. I messed with a few nvidia control panel settings. Also closed DS4Windows, Nvidia experience, and EVGA precision... not sure what did it!
     
  35. VitexHD

    VitexHD

    Joined:
    Jun 24, 2017
    Posts:
    1
    How to do the command line arguments:
    Step 1:
    Open cmd and locate your editor folder in unity, mine is: C:\Program Files\Unity\Editor\

    Step 2:
    In quotes, put in your directory to the editor folder and then to the exe, mine is: "C:\Program Files\Unity\Editor\Unity.exe"

    Step 3 - Last:
    After the quotes, do -force-opengl, like this:"C:\Program Files\Unity\Editor\Unity.exe" -force-opengl
     
  36. BananaAcid

    BananaAcid

    Joined:
    Aug 9, 2017
    Posts:
    2
    forcing OpenGL and closing all nvidia tasks (some do restart) did not help me :/
     
  37. Trinli

    Trinli

    Joined:
    Aug 11, 2017
    Posts:
    4
    Same here, problem started out of the blue one day, and no trick I've tried has made any difference.
     
  38. henkjan

    henkjan

    Joined:
    Aug 1, 2013
    Posts:
    102
    Same for me. Al suggested options don't help. The strange thing is that when I reboot my laptop after a while the problem is gone and it works fine for the day but the next day I have the same problem again! :-(

    UPDATE: My problem was Oculus software. When I turned off the OVRService service that comes with the Oculus Rift the problem was gone.
     
    Last edited: Aug 30, 2017
    ph4nt0ma5ter and ModSobWolf like this.
  39. Fletcher-Studios

    Fletcher-Studios

    Joined:
    Sep 25, 2014
    Posts:
    4
    henkjan - got the same, OVR Service slowed Unity to a crawl. Ever get a better solution than stopping the service every time you start Unity?
     
  40. henkjan

    henkjan

    Joined:
    Aug 1, 2013
    Posts:
    102
    I eventual uninstalled the Oculus software because I didn't need it (we also use a Vive). But now I'm reinstalling it again. Let's see if the problems appear again....
     
  41. Zaclo_Games

    Zaclo_Games

    Joined:
    May 14, 2017
    Posts:
    3
    Edit > Project Settings > Quality > [Select the level of quality, lower quality means that the editor will run smoother]
     
  42. Knaple

    Knaple

    Joined:
    Aug 26, 2013
    Posts:
    1
    Had this issue after trying to upgrade to Unity 2017.2.1f1.

    I fixed it by Uninstalling Unity and then going into C:\ProgramData and deleting the Unity folder. Then I just reinstalled Unity.

    Hope this helps someone out there.
     
  43. Hrrsn

    Hrrsn

    Joined:
    Jul 17, 2013
    Posts:
    2
    My framerate just tanked seemingly out of the blue, turns out i had Auto-generate lighting baking off and something must've tripped. Turning that back on fixed it instantly for me.
     
  44. chummscrubber

    chummscrubber

    Joined:
    Jul 7, 2013
    Posts:
    2
    Hi guys,

    I found that disabling the nvidia overlay fixed the issue for me, now I only get a little bit of stuttering when I first load the scene and lighting is being computed.
     
  45. rnxotjd123

    rnxotjd123

    Joined:
    Jan 26, 2018
    Posts:
    1
    Same , this works with me too Thanks
     
  46. htdreams

    htdreams

    Joined:
    Mar 29, 2014
    Posts:
    7
    Thank you so much! i was having several lag problems in the editor, and have tried everything above in this page... until this solution... now i can work in the editor with "normal" DX11 mode :)
     
  47. DaniKonter

    DaniKonter

    Joined:
    Nov 14, 2016
    Posts:
    1
    It works for me!