Search Unity

  1. Check out the Unite LA keynote for updates on the Visual Effect Editor, the FPS Sample, ECS, Unity for Film and more! Watch it now!
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Unity Editor performance under Mojave (10.14) is less than half of 10.13.x versions of MacOS

Discussion in 'Editor & General Support' started by Deeeds, Sep 9, 2018.

  1. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    This is most noticeable and a real problem when editing animations. They don't run even close to 60fps, even when they're relatively simple transforms like sprite scaling.

    Get two Macs, same hardware, with these two different versions of OS to see the difference.

    It's immediately obvious.

    The problem is probably related to how the fonts are rendered in Mojave compounding the longstanding issues with Unity Editor UI rendering.

    But it could also be many other issues, as the Editor is generally painfully slower in Mojave.

    latest model MacBook Pro. Bug report submitted for one of the crashes that might be associated.

    Case 1079409
     
    TSLoire likes this.
  2. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    The slowness is definitely something in the editor. I've made a test to play the animations in gameplay mode. When "maximise on play" hides the majority of the editor, the animations run smoothly.

    When that's not the case, when some editor is visible, the animation is far below 30fps, let alone 60fps.

    Stats in the game window report 4ms per frame and 200+ frames per second. Complete fiction.
     
  3. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    Closing the Inspector showing the information of the object being animated does not help solve the problem. Releasing the object prior to playing the game does help.

    So I take it back, it's not ALL down to the rendering of the UI. Some of it is the background updating of the elements of the selected object(s).

    As I say, releasing all objects and hitting play solves much of the performance problem. But makes editing animations impossibly, as an object needs to be selected in order to edit its animations, or its timeline locked.

    Locking the timeline, releasing the object and then playing only the animation still has less than 30fps rendering of the animation. The timeline rendering seems to be somewhat of a problem.
     
  4. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    ROLLING back.

    I cannot suggest using Mojave (macOS 10.14) for Mac.

    This likely won't change after the beta cycle, as there are fundamental ways the text rendering has changed that's not good for coders. Quite bad, in fact.

    Something about this also makes Unity Editor performance horrible. It's bad on a Mac, anyway. It's far worse under Mojave.

    And if you like the trackpad, you're much better off with 10.13.6, as there's no way to have both triple finger drag and tap to drag work under Mojave, even with the old Terminal hacks.

    UPDATE:
    Batching also broken in Mojave. Twice as many batches.

    Like for like hardware, the Unity performance is massively different between them.
     
    Last edited: Sep 9, 2018
  5. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    This is terrible, just updated Mojave yesterday and My Mac Book air late 2015, is also running at half the speed in the editor, whether if it's in play mode or not. :S if you are a DEV DO NOT UPDATE TO MOJAVE
     
    Deeeds likes this.
  6. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    Downgrade. Backup everything.

    Go to Mac Appstore and download Mac High Sierra Installer. it's about 4.8GB. Is a complete, fresh install.

    Lot of work. But worth it.
     
    JayFiraja likes this.
  7. Rich0

    Rich0

    Joined:
    Aug 9, 2013
    Posts:
    43
  8. Skyler_Hawkins

    Skyler_Hawkins

    Joined:
    Aug 18, 2016
    Posts:
    19
    I'm curious too, I was just about to update to the new macOS but decided to check out the forums first.

    20182.9f1 Fixes said-
    (1074400) - Editor: Fixed Metal Editor performance regression when running on macOS Mojave with Metal API Validation checkbox enabled

    Anything tried to see these is all that's needed?
     
    UNSH likes this.
  9. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    These problems are inherent to all versions of Unity I've tried, from 2018.1 betas through to 2018.3 betas.
     
  10. monofreely

    monofreely

    Joined:
    Dec 27, 2016
    Posts:
    1
    Unity 2017.4.12f1 is Release today.
    Fixed Mojave performance problem.
     
    tonimarquez84 likes this.
  11. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    I'm using the latest 2018.2 on one machine and the latest 2018.3 beta on another. Both are staying at 10.13.6, I'm not going near Mojave.

    Mostly because it's impossible to do pixel perfect font rendering on Mojave. Ironic. This makes it full circle, from Macs being for Designers... to no longer giving a S*** about them and their concerns, at all.
     
  12. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    I don't understand this comment, could you clarify it a bit? Also, have you tried 2017.4.12f1 as monofreely has suggested?
     
  13. creativewax

    creativewax

    Joined:
    Jan 28, 2015
    Posts:
    15
    hi guys, i have updated to Mojave and hit the same problem, i have projects on older versions of Unity that i can't move to newer versions so really updating software is not an option, a project i am doing that renders at around 12k 60fps and i normally preview in the editor at 4k 60fps it was running at around 10fps in Mojave, after a bit of messing just unchecking the Metal Api Validation button in the player settings has gave me a massive performance increase?! no idea why, its stuttering a bit for 5 seconds when starting and then goes back to around 40-50fps, so not perfect but worth noting as it might cure your problems too?
     
    JayFiraja likes this.
  14. creativewax

    creativewax

    Joined:
    Jan 28, 2015
    Posts:
    15
    also i think this is an Apple problem, i have had issues like this with previous OS updates, and most of my apps are now running terrible, Rider totally stops all the time mid typing now, its getting hard working coding at all now :(
     
    Deeeds likes this.
  15. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    Disabling the Metal API checkbox on the player settings made my Unity 2017 editor run at nromal speed again, tunring that thing on when making a build just in case
     
    Acctubi likes this.
  16. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    damn you beat me to it and yeah I can confirm the fps is back to normal or at least 90% back to normal, no need to update to newest Unity versions nor reinstall High sierra or older MAC OS to fix this.
     
  17. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    Can you post a screenshot of "Metal API checkbox" or describe where it is? I'm not seeing it.
     
  18. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    sure, Edit/Project Settings / Player
    and then on the Inspector Tab, the settings will display,
    there it is on the "Other Settings" section, under rendering. :)

    note* make sure you are checking the Settings for PC, Mac, & Linux Standalone Settings
     
    Last edited: Sep 28, 2018
  19. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    I do not see any checkbox called Metal API.
     
  20. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    Which Unity version are you using?
     
  21. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    2017.4.4
     
  22. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    Make sure you are checking the standalone options, here is the screenshot
     

    Attached Files:

  23. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    I checked the Standalone section, it's not there. Mine says Metal Restricted Backbuffer Use instead.
     
  24. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    try toggling that one then and see if it fixes it
     
  25. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    I haven't upgraded to Mojave yet. It's just weird how we seem to have different settings.
     
  26. JayFiraja

    JayFiraja

    Joined:
    Oct 1, 2013
    Posts:
    12
    I am using Unity 2017.1.3p1
     
  27. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    Sorry. I should have also mentioned this.

    Rider (and all text editors) really suffer unbelievably badly under Mojave. This is due to the "new" font rendering techniques in Mojave, which are a blend of lazy ways of achieving the dark theme propagating to how all fonts are rendered regardless of theme, and the changes made to make Marzipan work (iOS apps in macOS).

    Essentially, they've gone from a CG (Core Graphics) focused rendering technique and technologies to a blend of it and CALayer rendering.

    CALayer is always dynamic if there's any changes to the text, causing a much greater overhead. I think.

    Plus CALayer font rendering is UGLY!!

    And there's no way to entirely turn off the different types of anti-aliasing of CALayer, which is vastly inferior to that of how CG font rendering does it.

    All ironic, because Steve Jobs went to ENORMOUS trouble to ensure all his Mac technologies had the best font rendering available, from way back in the days of Lisa.
     
  28. Deeeds

    Deeeds

    Joined:
    Mar 15, 2018
    Posts:
    739
    Disabling Metal puts you back to OpenGL.

    You'll get a speed up, but not nearly as much as you would have had under proper, fully functioning Metal of the pre Mojave days.

    This is another strong reason to avoid Mojave.
     
  29. _Daniel_

    _Daniel_

    Joined:
    Feb 28, 2007
    Posts:
    2,614
    Will do. Until I get official confirmation from Unity of proper Mojave support.
     
  30. creativewax

    creativewax

    Joined:
    Jan 28, 2015
    Posts:
    15
    I am not talking about disabling Metal, basically I have the same issue in 5.6, 2017 and 2018, what I had to do is go to player settings, click Metal Editor Support, but uncheck the Metal API Validation tick box, and this gave Unity most of its performance back. Rider is still a mess though sadly, so hoping maybe an update to the OS sorts that out?!
     
  31. bottomer

    bottomer

    Joined:
    Sep 29, 2014
    Posts:
    1
    Got the same problem on 5.6.4 and 2018. It's really tooooooo slow, but Cpu is Low, Mem is Los.... After disable Collab, switch Graphics API Metal to OpenGL, may speed up a little.
    Hope a Official Deep Solution.

    @creativewax , Thanks a lot for your tip. Unchecking the Metal API Validation made it faster.
     
    Last edited: Oct 10, 2018
  32. CarlosLlongo

    CarlosLlongo

    Joined:
    May 11, 2014
    Posts:
    1
    Just updated to Mojave the other day. Same performance problem as everyone else. Disabling the Metal API Validation was a huge improvement, thanks for that!

    Rider seems to be working fine. I've found no notizable difference there.
     
  33. virgilcwyile

    virgilcwyile

    Joined:
    Jan 31, 2016
    Posts:
    22
    Had a big time lag in Unity. Just updated to 2018 2.14 . And way better performance now. No glitches and no performance lag. Also to my surprise Project importing was faster too! Thanks
     
    wetcircuit likes this.
  34. Skyler_Hawkins

    Skyler_Hawkins

    Joined:
    Aug 18, 2016
    Posts:
    19
    It seems like maybe things are starting to turn around with the Mojave update? I still haven't update to the new OS because of the fear of Unity not working well with it, I want to hear more feedback before I take the dive.

    For everyone that had problem at first, where are you at now? is disabling the Metal API Validation all we really need to do? Is Mojave even really worth the update with the offsite of unity running slower? Am I just worrying to much?
     
  35. francois85

    francois85

    Joined:
    Aug 11, 2015
    Posts:
    267
    My projects will not open at all. Emulator is not working, im crying myself to sleep. I regret upgrading to Mojave
     
  36. Thrawn75

    Thrawn75

    Joined:
    Nov 16, 2014
    Posts:
    1,941
    Last edited: Nov 5, 2018
  37. francois85

    francois85

    Joined:
    Aug 11, 2015
    Posts:
    267
    Ok got my project running but indeed it's much slower. Is there an official issue that I can vote on or any official word from Unity on what could be causing this.
     
  38. TSLoire

    TSLoire

    Joined:
    Oct 21, 2011
    Posts:
    32
    I am also having this problem. Was quite happy Mac was getting a dark mode so I upgraded. If I had known it would do this to Unity I would not have bothered with it. Is there any chance of a statement from a Unity Dev on this please and if there will be a fix any time soon?
     
  39. Skyler_Hawkins

    Skyler_Hawkins

    Joined:
    Aug 18, 2016
    Posts:
    19
    It would be wonderful just to hear them say,"We are aware of the problem, and are working on a solution." But there hasn't been anything.
     
  40. Acctubi

    Acctubi

    Joined:
    Jan 26, 2016
    Posts:
    31