Search Unity

  1. The 2021.2 beta is now available. To find out what's new, have a look at our 2021.2 beta blog post.
    Dismiss Notice
  2. How can our website serve you better? Give us your feedback. Take our survey and let us know.
    Dismiss Notice

Bug Unity editor is too dark/unreadable only on Universal render pipeline template

Discussion in 'Linux Editor' started by MrGio, Apr 23, 2020.

  1. MrGio

    MrGio

    Joined:
    Apr 18, 2020
    Posts:
    2
    OS: Ubuntu 19.10
    Unity version: 2019.3.10f1, 2020.1.0b5, (only tested those)

    When I create new project using Universal render pipeline template, editor just gets dark, to the point it's hard to read anything.

    plus text becomes pixelated, for reference I will attach the screenshots (they somehow smoothed out text and looks more readable in then it really is).

    Universal render pipeline template
    Screenshot from 2020-04-20 02-40-25.png

    Other options looks like this
    Screenshot from 2020-04-20 02-43-49.png

    This happens on both, xorg and wayland, don't know if it matters. and to be clear it happens only when i create project using universal render pipeline template, all the other options are fine.
     
    mpartel likes this.
  2. phileon58

    phileon58

    Joined:
    Apr 7, 2020
    Posts:
    2
    I have the same problem and I search a solution too, please anyone can resolve this problem?
     
  3. senkal_

    senkal_

    Joined:
    May 22, 2018
    Posts:
    82
    I had similar issues but triggered by different thing(need to create an issue).
    My question, do you use Intel graphics card?
    With my dual graphics card laptop it made a difference.
    Intel -> really dark, NVidia -> no issues.
     
  4. senkal_

    senkal_

    Joined:
    May 22, 2018
    Posts:
    82
    Just to add, the difference for my is combination of:
    Intel graphics card plus "Project Settings" -> "Player" -> "Other settings" -> "Rendering" -> "Color Space" and selecting "Linear".
    Maybe Universal Pipeline uses Linear by default when other use Gamma?
     
  5. phileon58

    phileon58

    Joined:
    Apr 7, 2020
    Posts:
    2
    Thank you senkal_, and sorry for the late of my answer!
    Your solution is the good way! But for me, by default it was set to Linear, and I had to change "Linear" to "Gamma" to resolve my problem. Thank you again!
     
  6. senkal_

    senkal_

    Joined:
    May 22, 2018
    Posts:
    82
    Happy it worked for you @phileon58
    I need to submit a bug for this.
    To double check, do you use Intel graphics card?
     
  7. senkal_

    senkal_

    Joined:
    May 22, 2018
    Posts:
    82
    Case 1256413.
    We will see how it goes.
     
  8. senkal_

    senkal_

    Joined:
    May 22, 2018
    Posts:
    82
    Just an update.
    My bug was closed because the issue only happens when using Intel drivers on Linux, which is not officially supported.
    When I switched to Geforce and official Nvidia drivers - no issues.
    I am afraid Intel and Unity on Linux is just "I hope it will work" game, I am not going to use it with Unity.
     
unityunity