Search Unity

Unity Editor in MacBook Pro too slow

Discussion in 'Editor & General Support' started by cmrabet, Sep 12, 2016.

  1. cmrabet

    cmrabet

    Joined:
    Sep 12, 2016
    Posts:
    6
    I've just started evaluating Unity and sadly I had to stop because using the editor is painful. All actions are laggy, when clicking on any option, it takes 2-3 seconds for the editor to respond. This is even with an empty project with no objects in the scene.

    I've opened the Activity Monitor and noticed that each time I do something in the editor, even as simple as selecting something in the trees, the CPU consumption goes up beyond 90%.

    My MacBook Pro's specs are as follows:

    MacBook Pro (13-inch, Mid 2012)
    2.9 GHz Intel Core i7
    8 GB 1600 MHz DDR3
    Intel HD Graphics 4000 1536 MB
    OS X El Capitan, v10.11.5


    Is my machine too slow?

    Thanks.
     
  2. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Cannot confirm but been using Mac all the time, and its way slower compared to Windows Unity.
    Just got live with it all, hope they improve for future, even Metal for Mac I doubt will help
     
  3. twilightZone

    twilightZone

    Joined:
    Oct 10, 2014
    Posts:
    29
    Hello all,
    I have
    Unity 5.5
    Nom du modèle :MacBook Pro
    Identifiant du modèle :MacBookPro8,2
    Intel Core i7
    Vitesse du processeur :2,4 GHz
    Nombre de processeurs :1
    Version du système :OS X 10.11.6

    In MonoDevelop, I have 10 file open at the time. Some files contains 5000 lines of code and all works well with no latency.
     
  4. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    The problem is not MonoDevelop, its Unity, it increase CPU usage more than normal, without looking at anything on PC i know because the Mac Fans start running full speed.
     
  5. greg-harding

    greg-harding

    Joined:
    Apr 11, 2013
    Posts:
    373
  6. cmrabet

    cmrabet

    Joined:
    Sep 12, 2016
    Posts:
    6
    I don't have an option to turn off retina support on the "Get Info" panel that shows up when right clicking on the app's icon. I believe this is because my MacBook Pro doesn't have a retina display, it's from 2012...
     
  7. cmrabet

    cmrabet

    Joined:
    Sep 12, 2016
    Posts:
    6
    Thanks but I don't think I can live with this, it's unusable in my opinion.. inserting a plane takes literally 10 seconds for the editor to show it the first time.. when I try to rotate it it takes 5 or 6 seconds to update. I have been using Google Sketch for years in this Mac with very heavy CADs and I've never seen it behaving this bad.
     
  8. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    Might just be the older Mac? Maybe that Intel 4000?

    I don't have any issues on a modern MacBook:


    MacBook Pro (Retina, 15-inch, Mid 2015)
    2.5 GHz Intel Core i7
    16 GB 1600 MHz DDR3
    AMD Radeon R9 M370X 2048 MB
     
  9. cmrabet

    cmrabet

    Joined:
    Sep 12, 2016
    Posts:
    6
    Even with a just created project? I have an empty scene with no objects! I would understand that it's a machine hardware related issue if my project was growing and the editor's response was slowing down, but just after installing the Unity engine and started the editor to learn Unity?
     
  10. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    Never noticed any problems, but I guess the real test of whether or not the MacBook is slower would be to compare to an equivalent Windows version.

    That graphics card of yours was the only thing that jumped out as a possible issue to me.
     
  11. cmrabet

    cmrabet

    Joined:
    Sep 12, 2016
    Posts:
    6
    OK, thanks. Looking now in Amazon graphic cards for MacBook Pros and memory upgrades. Your specs are almost the same except the video card and the memory. As a matter of fact, my processor seems to be faster.
     
  12. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,110
    Unity actions are instant here (Mac Pro); there is no lag, and CPU usage is typically 10% or less. Your GPU is OK, and wouldn't matter for the interface, just whatever you have going on in the scene and game views. So no, your machine isn't too slow and should be fine; I've run Unity on much slower Macs without issues. Something's quite wrong and slowness like you describe isn't at all normal, and it's not something you should have to live with, but I have no idea what the problem is, sorry. :/ Maybe try disabling app nap to start with, even though that shouldn't make a difference.

    --Eric
     
  13. greg-harding

    greg-harding

    Joined:
    Apr 11, 2013
    Posts:
    373
    Ok then - worth a try :) I'm on a 2012 15" Retina MacBook Pro (16gig ram, Nvidia 650M, OS X 10.10.5) and Unity 5.4 is pretty much unusable running on the laptop screen unless I force low-resolution via the app's info popup. Running on an external Thunderbolt display (which is non-retina) is fine though. I think 5.5 has some updates coming to make the scene and/or game window run in low-resolution which will be handy.

    Generally the 5.x Editor still runs well on this older 2012 MacBook Pro but it's not even in the race vs. our new Windows PC testing/VR rig (Skylake i7 6700K, Nvidia GTX 1070). It's another world of performance...
     
  14. cmrabet

    cmrabet

    Joined:
    Sep 12, 2016
    Posts:
    6
    Guys it's working now well, what did I do? I always have Virtual Box open with windows 7 and Outlook 2013 (we are using an Exchange server setup for email heavily based on public folders, which are not supported by any MacOS email client). I've noticed that when I kill Outlook, Unity Editor starts working with no lag.. The thing is I have the virtual machine configured to use only 2GB of my resources (8GB total) with a CPU execution cap set to 50%, so in theory the demands of this machine should affect the host one..

    I will try killing Virtual Box entirely and see the results.

    Thanks all for your support.
     
  15. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    4,637
    Hmm. Even using my 2011 Macbook Pro, unity is very snappy. There was a version of Unity (5.3) where they switched the default OpenGL driver, and it was buggy and slow. If that's the case, go into your player settings, and force it to use the old OpenGL driver (this effects the editor as well as the player). Should be fixed on 5.4 though.
     
  16. Olly

    Olly

    Joined:
    Jun 19, 2014
    Posts:
    20
    I have 3 MacBooks to test with (2 at work, one is a CI server)
    Seems the editor is really smooth Nvidia 650m and the intel 7th gen integrated GPU.
    My home machine which has a M370X is almost unusable on an empty project. Real shame.

    Most likely a driver issue.
     
  17. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712