Search Unity

Unity Editor and PrecisionX: Editor renderered useless because of FPS lag

Discussion in 'Editor & General Support' started by Bruce_GMC, Aug 20, 2015.

  1. Bruce_GMC

    Bruce_GMC

    Joined:
    Oct 23, 2014
    Posts:
    65
    Choppy, slow, laggy editor problems have been popping up around my office recently and after 3 days of my chief engineer pulling his hair out and leaving early everyday to work from home, I narrowed the problem down to EVGA's Precision X 16 software which we use for nothing more than the fan controller software.

    This software contains monitoring servers to display data to the user while in game.

    These servers were absolutely WRECKING Unity, but only when the game window was not set to 'maximize on play.' While maximized the editors FPS would shoot up from 2-5FPS to 200FPS. We thought it might be the motherboard, the GPU, the video drivers, DirectX.. We switched to forcing DX9 and it worked besides none of our shaders rendering.. I closed the Hierarchy window and the frame rate became usable... Nothing was making sense and nothing was working.

    I searched for answers for soo long until I came upon a similar issue someone was having with Unreal Engine 4. I am posting this for people like me, who can't afford to spend this much time on such a stupid problem. And even after finding this post, no one involved knew how to definitely fix the problem.

    Well here's the fix:
    some people say to disable OSB and all of the monitoring categories to keep the server from starting. This did nothing for us, the server still started and Unity still could not play an empty scene with a game manager, camera and playercontroller at 680x400. Some people said to rename the files Precisionx_Server and precisionx_server_64. Dont do that, these files are worthless. Just delete them and enjoy your fan software. Cheers
     
  2. l1qu1d

    l1qu1d

    Joined:
    Aug 27, 2015
    Posts:
    1
    Thank you so much Bruce_GMC this fixed my home issue where I had extreme lag within the editor! I initially closed the Precision software, but the server was still running in the background. I'm on a high performance gaming machine with Windows 10 using Unity 5 version 5.1.2f1. I hope other people will find this and help them as well!

     
    Bruce_GMC likes this.
  3. Bruce_GMC

    Bruce_GMC

    Joined:
    Oct 23, 2014
    Posts:
    65
    I knew it would help someone! Glad to be of some help ;)
     
  4. OncaLupe

    OncaLupe

    Joined:
    Oct 17, 2014
    Posts:
    4
    You get another thanks from me for finding the fix. I was getting the lag once in a while, and rebooting usually cleared it up. Finally decided to look into it after I got the lag right after first starting for the day. I disabled all the monitoring statistics (for anyone seeing this later and trying, don't forget the dropdown in the corner) and it instantly improved the editor performance. If it returns I'll remove the server files. Hopefully this also fixed the intermittent typing lag in Monodevelop.
     
    Bruce_GMC likes this.
  5. leschmic000

    leschmic000

    Joined:
    Oct 3, 2015
    Posts:
    1
    Oh my god, THANK YOU! I have been going crazy trying to fix my choppy framerate issue and this was the solution! I can finally use Unity at home!
    I was getting lag spikes once every second which made working in the editor nothing less than torture. Now it's smooth as butter :"D
     
    Bruce_GMC likes this.
  6. Bruce_GMC

    Bruce_GMC

    Joined:
    Oct 23, 2014
    Posts:
    65
    Good Moods successfully created xD
     
  7. HelloMeow

    HelloMeow

    Joined:
    May 11, 2014
    Posts:
    214
    This was driving me crazy. Unity 4 was working fine, but Unity 5 was a mess. I can remember Afterburner doing something similar.
     
    Bruce_GMC likes this.
  8. Tyrant117

    Tyrant117

    Joined:
    Aug 25, 2014
    Posts:
    5
    Sadly, I am still getting the issue. It worked for about a day (deleting the server software). The editor was running smooth like I would expect from my machine. Then the next day its gone to S*** again. Massive gfx.waitforupdate editor lag.

    970, 32gb ram, i7 6700k, win 10. If anyone figures anything else out let me know.

    Looks like the issue is dx11, ran unity in dx9 and it runs like it should. If anyone has a way to get dx11 working normally, let me know.
     
    Last edited: Dec 20, 2015
  9. SpaceCoder

    SpaceCoder

    Joined:
    Aug 21, 2014
    Posts:
    1
    fix worked for me thanks :D
     
    Bruce_GMC likes this.
  10. Bruce_GMC

    Bruce_GMC

    Joined:
    Oct 23, 2014
    Posts:
    65
    Sounds like your issue is caused by a similar scenario as the profiler marked the same process for me when I was dealing with this problem.

    Think-- what software do you have installed that monitors other processes. Some critical thinking can save you a lot of time before reading my reply any further. In any case, troubleshooting steps for an intermittent software issue to an A+ certified technician begin with a procedure called a clean boot.

    Open msconfig and disable all startup programs and services that aren't attributed to Microsoft. Restart your computer and see if the problem goes away. Then, procedurally re-enable processes first, rebooting after each pass. You can use some thought to make the process go faster. Again think-- what among the list of startup options can be deemed absolutely, without a doubt, not causing the problem? I would make your first pass at the startup list consist of your best guesses. That way when you reboot to test your changes, you have a big chunk out of the way whether the test confirms or denies your initial choices. If the problem comes back after rebooting, you know that the process that is causing your problem is in the list that you selected to start; on the flip side, if the problem does not come back, reopen msconfig and start enabling startup processes one at a time, rebooting after each selection, to test the problem again once the system is back up. This should narrow down the startup options until you're left with the culprit.

    Additionally I would like to add that recently EVGA started installing the PrecisionX software in to a completely different directory within Program Files. If you are a supporter of EVGA you might have two installations of the server software running; one located in a folder called EVGA and another in a folder called EVGA PrecisionX. I hope this helps, and I'm elated to know that I have helped so many people through this issue. I'm still scared to this day from the week of stress it caused me. Thinking back I should have just done the clean boot procedure, though it is a lot of work and waiting if you don't have an ssd installed.

    Cheers and happy editing
     
  11. Tyrant117

    Tyrant117

    Joined:
    Aug 25, 2014
    Posts:
    5
    Yep, FINALLY found it. It was the Asus Audio Sonic Sound that comes with new Asus Mobos. Insanely weird issue, but that fixed it so I won't begrudge it. You're post actually helped a lot. Thanks!
     
    JHNB and Bruce_GMC like this.
  12. JHNB

    JHNB

    Joined:
    Apr 28, 2015
    Posts:
    1
    Just a me too! Asus Sonic Studio caused my Unity to lag like crazy. Closing the software and restarting Unity and all is fine. Very strange but works, thanks Tyrant117 and all others!

    -Johan

     
    Bruce_GMC likes this.
  13. P0lT10n

    P0lT10n

    Joined:
    Jul 5, 2013
    Posts:
    1
    Man, thank you so much for this !!!! I closed EVGA Precision X (5.3.10) and I hit play again and from 30 fps or less I go to 2200 (without vsync)... THANK YOU SO MUCH !!!! THE EDITOR IS NOW WORKABLE AGAIN !
     
    Bruce_GMC likes this.
  14. Jean_Paul2016

    Jean_Paul2016

    Joined:
    Mar 24, 2016
    Posts:
    8
    Yesss, thank you so much! I closed the server and it went back to playing smoothly. Awesome. Coincidentally I thought it was my updating to unity 5.3.4. Glad it's not that.
     
    Bruce_GMC likes this.
  15. Rozx

    Rozx

    Joined:
    Mar 24, 2015
    Posts:
    7
    Yesss thank you! I found out the same problem happened to me!
     
    Bruce_GMC likes this.
  16. PachowStudios

    PachowStudios

    Joined:
    Sep 18, 2016
    Posts:
    1
    Thank you so much! This has been driving me crazy for the past week!
     
    Bruce_GMC likes this.
  17. kophax

    kophax

    Joined:
    Jul 19, 2014
    Posts:
    19
    OMG thank you. This haunted me for like a year! -force-opengl was the only workaround I had until I noticed this thing about Asus Sonic Studio. Turning that off finally worked.

    Appears to be related to DX 11 + Asus Sonic Studio + (possibly EVGA?)
     
  18. Zoidy

    Zoidy

    Joined:
    Jul 18, 2014
    Posts:
    4
    Wow, thank you so much! Asus Sonic Studio was the issue for me too!
     
  19. Durins-Bane

    Durins-Bane

    Joined:
    Sep 21, 2012
    Posts:
    175
    About to reboot after removing precision x wish me luck!

    Edit: IT WORKED, never would have gotten this myself

    TYVM!
     
    Last edited: May 27, 2017
  20. Ghastendee

    Ghastendee

    Joined:
    Sep 10, 2015
    Posts:
    1
    Where can i find the Precisionx_Server files?

    EDIT: seems that i dont have that on my computer even... i still get the annoying Gfx.WaitForPresent lags making my game S*** even with almost nothing to render. Anyone got another sollution?
     
unityunity