Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Bug Unity Editor 2022.3.22f1 crashes upon opening new project

Discussion in 'Editor & General Support' started by mathewwang, Apr 9, 2024.

  1. mathewwang

    mathewwang

    Joined:
    Apr 9, 2024
    Posts:
    4
    - Connect to Unity Cloud and Use Unity Version Control both deselected
    - 3D (Built-in) project type used

    - Apple MacBook Pro "Core i7" 2.5 15" Mid-2015 <- MJLT2LL/A
    - macOS Sanoma 14.4.1 (23E224) <- I'm using OpenCore Legacy Patcher

    - already tried: rebooting, reinstalling Unity Editor + Unity Hub, deleting:

    /Applications/Unity
    ~/Library/Application Support/Unity
    ~/Library/Caches/com.unity3d.*
    ~/Library/Logs/Unity
    ~/Library/Preferences/Unity
    ~/Library/Preferences/com.unity3d.*
    ~/Library/Unity
    ~/Library/Preferences/com.OverTheEdge.BugReporter.plist
    ~/Library/Preferences/dk.Otee.*
    /Library/Application Support/Unity
    /Library/Application Support/PACE Anti-Piracy

    and reinstalling... still no dice
     

    Attached Files:

    Last edited: Apr 9, 2024
  2. mathewwang

    mathewwang

    Joined:
    Apr 9, 2024
    Posts:
    4
    Here's a video of me running into the error:


    In the video, I'm using 2022.3.23f1, not 2022.3.22f1, but the same thing happens for 2022.3.22f1.
     
    Last edited: Apr 11, 2024
  3. mathewwang

    mathewwang

    Joined:
    Apr 9, 2024
    Posts:
    4
    Hey bumping this... Any ideas anyone?
     
    Last edited: Apr 10, 2024
  4. mathewwang

    mathewwang

    Joined:
    Apr 9, 2024
    Posts:
    4
    Bumping this another time... Any advice?
     
  5. MagicModsLtd

    MagicModsLtd

    Joined:
    Oct 23, 2014
    Posts:
    3
    have a look here
    I beleive it is because Opencore legacy patcher does not fully support Metal API

    The only way i managed to get unity to load (any version) was to force OpenGL

    /Applications/Unity/Hub/Editor/[YourUnityVersion]/Unity.app/Contents/MacOS/Unity -force-glcore