Search Unity

Unity does not open any projects.

Discussion in 'Package Manager' started by unity_KaQ5vR-UoBl93Q, Feb 25, 2020.

  1. unity_KaQ5vR-UoBl93Q

    unity_KaQ5vR-UoBl93Q

    Joined:
    Jan 13, 2020
    Posts:
    2
    Hello,

    I work on Linux (ArchLinux), I installed my version of Unity (2019.2.xxf1) from Unity Hub 2.2.2 (the package uses the official Appimage). I have been using Unity for a month and have had no problems so far.
    But since yesterday, when I want to launch a project (with the 2019.2.21f1), Unity Package Manager loads up to Starting Server, and then nothing starts.
    I tried to create a new project ... same problem.
    I completely uninstall Unity and Unity Hub (also .config files), reinstall everything ... same problem.
    I uninstall Unity Hub, and download Unity Editor (2019.2.17f1) without going through Unity Hub ... same problem.
    I install Unity Hub, and install Unity 2019.3.2f1, I launch a project (or create a project) ... Ah! There's a change, Unity Package Manager fully charges! But nothing starts, again ...

    When I open Unity from the command line, I have the same problem and I get this.
    2019.2.21f1
    $ Unity/Hub/Editor/2019.2.21f1/Editor/Unity
    [1] 9682 segmentation fault (core dumped) Unity/Hub/Editor/2019.2.21f1/Editor/Unity
    [Unity Package Manager (Upm)]
    Parent process [9682] was terminated

    2019.3.2f1
    $ Unity/Hub/Editor/2019.3.2f1/Editor/Unity
    [1] 10594 segmentation fault (core dumped) Unity/Hub/Editor/2019.3.2f1/Editor/Unity


    I can't find any solution, please, someone would help me?
    Thank you in advance !
     
    Last edited: Feb 25, 2020
  2. manu73

    manu73

    Unity Technologies

    Joined:
    Aug 22, 2014
    Posts:
    59
  3. unity_KaQ5vR-UoBl93Q

    unity_KaQ5vR-UoBl93Q

    Joined:
    Jan 13, 2020
    Posts:
    2
  4. databeaver

    databeaver

    Joined:
    Apr 10, 2019
    Posts:
    2
    I'm possibly hit with the same problem since I updated my Debian Unstable during the weekend (it had gone without updates for a while). Log files attached. If I run Unity in gdb and take a backtrace, I get this:

    Thread 1 "Unity" received signal SIGSEGV, Segmentation fault.
    0x0000555558a3a528 in AtomicStack::pop ()
    (gdb) bt
    #0 0x0000555558a3a528 in AtomicStack::pop() ()
    #1 0x0000555557ba8c62 in BucketAllocator::Allocate(unsigned long, int) ()
    #2 0x0000555557bb40c3 in DualThreadAllocator<DynamicHeapAllocator<LowLevelAllocator> >::Allocate(unsigned long, int) ()
    #3 0x0000555557bb98bc in MemoryManager::Allocate(unsigned long, unsigned long, MemLabelId const&, AllocateOptions, char const*, int) ()
    #4 0x0000555557bb9d70 in malloc_internal(unsigned long, unsigned long, MemLabelId const&, AllocateOptions, char const*, int) ()
    #5 0x00005555563fdec3 in FMODMemoryAlloc(unsigned int, unsigned int, char const*) ()
    #6 0x0000555559f66d35 in FMOD::MemPool::alloc(int, char const*, int, unsigned int, bool) ()
    #7 0x0000555559f86c6b in FMOD::OutputALSA::addALSADriver(char const*) ()
    #8 0x0000555559f86fbe in FMOD::OutputALSA::getALSANameHintDrivers() ()
    #9 0x0000555559f87138 in FMOD::OutputALSA::enumerate() ()
    #10 0x0000555559f872d4 in FMOD::OutputALSA::init(int, unsigned int, int*, int, FMOD_SOUND_FORMAT*, int, int, void*) ()
    #11 0x0000555559f7e2b8 in FMOD::SystemI::init(int, unsigned int, void*) ()
    #12 0x0000555559f7366e in FMOD::System::init(int, unsigned int, void*) ()
    #13 0x000055555641200d in AudioManager::InitNormal(bool, FMOD_OUTPUTTYPE) ()
    #14 0x0000555556412646 in AudioManager::InitFMOD(FMOD_OUTPUTTYPE) ()
    #15 0x0000555556413667 in AudioManager::AwakeFromLoad(AwakeFromLoadMode) ()
    #16 0x00005555572276e4 in AwakeFromLoadQueue::InvokePersistentManagerAwake(AwakeFromLoadQueue::Item*, unsigned int, AwakeFromLoadMode) ()
    #17 0x00005555572352ee in AwakeFromLoadQueue::persistentManagerAwakeFromLoad(int, AwakeFromLoadMode) ()
    #18 0x00005555572353e2 in AwakeFromLoadQueue::persistentManagerAwakeFromLoad() ()
    #19 0x00005555571a01ad in PersistentManager::IntegrateAllThreadedObjects() ()
    #20 0x00005555571c8c14 in PersistentManager::LoadAndIntegrateAllPreallocatedObjects(PersistentManager::LockFlags) ()
    #21 0x00005555571c928d in PersistentManager::ReadObject(int, AwakeFromLoadMode) ()
    #22 0x0000555555bd80ff in PPtr<Object>::eek:perator Object*() const ()
    #23 0x000055555730143c in AssetDatabase::ReloadSingletonAssets() ()
    #24 0x0000555557378e35 in AssetInterface::LoadAssetDatabase(bool) ()
    #25 0x0000555557379414 in AssetInterface::Initialize(bool, bool, int*) ()
    #26 0x00005555572ec76f in AssetDatabase::InitializeAssetDatabase(bool, bool, int*) ()
    #27 0x000055555684daf5 in Application::InitializeProject() ()
    #28 0x000055555729f22c in InitializeUnity() ()
    #29 0x00007fffeba87054 in () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    #30 0x00007fffeba864de in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    #31 0x00007fffeba86890 in () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    #32 0x00007fffeba86b63 in g_main_loop_run () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
    #33 0x00007fffec2afce5 in gtk_main () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
    #34 0x0000555555afc719 in main() ()
     

    Attached Files:

  5. databeaver

    databeaver

    Joined:
    Apr 10, 2019
    Posts:
    2
    I tried downgrading all packages with libraries Unity uses, and that allowed it to start again. I then re-upgraded the packges a few at a time and checked when Unity stops working. It turns out that upgrading libasound2 from 1.2.1.2 to 1.2.2 was the problem. After upgrading everything else and leaving only libasound2 at the old version Unity continues to work.
     
  6. atuqhs

    atuqhs

    Joined:
    Mar 26, 2020
    Posts:
    2
    Hi! I have a similar problem, how do you know what versions of packages or libraries Unity uses in Archlinux? In aur there is a list of dependencies without specific versions. :(
    glxinfo | grep OpenGL
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2)
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.2
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 20.0.2
    OpenGL shading language version string: 1.30

    Thank you in advance !

     
  7. atuqhs

    atuqhs

    Joined:
    Mar 26, 2020
    Posts:
    2
    I downgraded package alsa-libs to 1.2.1.2 and work!! :)
    Thanks for your post.
     
unityunity