Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Unity does not occlude dynamically automatically (bug or by design?)

Discussion in 'Editor & General Support' started by FernandoMK, Dec 27, 2020.

  1. FernandoMK

    FernandoMK

    Joined:
    Feb 21, 2017
    Posts:
    172
    I'm not sure I'm on the right forum, but come on.:)

    I was trying to get all the dynamic objects in my scene to get dynamic occlusion, but it wasn't working as expected, That's when I realized the problem
    the dynamic occlusion mode only works if at least one object in the scene (regardless of size or location) is marked with the static ocludee propertyo_O

    Why does it work like that?

    I think this is a bug, it doesn't make sense to have at least one object marked as static so that the dynamic mode is unlocked for all other dynamic objects in the scene

    And yes, it is only activated after you bake this single initial object...

    And the documentation itself says that dynamic occlusion is enabled by default, but it was never really ... it only activates if you bake at least 1 object in the scene,

    So I wonder if this is really a bug or not? (Or if it was always like this, and I never realized:p)
     
  2. Kurt-Dekker

    Kurt-Dekker

    Joined:
    Mar 16, 2013
    Posts:
    32,250
    Smells like a bug, doesn't it? Not sure if there is a better place to ask it... perhaps over in the Graphics group?