Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Unity Developer Network is live!

Discussion in 'Announcements' started by AngryAnt, Jul 2, 2012.

  1. longisle

    longisle

    Joined:
    Oct 3, 2010
    Posts:
    29
    Oh, ok thanks, i feel even sillier now. :blush:
     
  2. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Heh! It's not that obvious either way.

    Who knows. When we get Unity Developer Network stable (which would be great - all sites on one login) maybe we should find a way to include the wiki. I think it's still just an issue of a series of different technologies all trying to be put into sync.
     
  3. longisle

    longisle

    Joined:
    Oct 3, 2010
    Posts:
    29
    After reading some criticism i now see that my question can be read as whining - while it really came out of pure ignorance. I must say that it was bit confusing at first but the surprise was really a pleasant one (for me anyway). I had little trouble claiming my accounts and i couldn't understand at once which of my email addresses ended up being used, but it's all clear now. I reckon UDN is brilliant and nothing less. Any issues it might have are minor or purely cosmetic. I use Firefox and haven't had any issues so far anyway. So yeah, that's pretty much it. Cheers.
     
  4. kersk

    kersk

    Joined:
    Jan 2, 2012
    Posts:
    56
    The merging of the different accounts was a positive change and most of the initial rough edges have been fixed up -- ie, the UDN banner is thinner and isn't floating at the top of the page anymore, etc. My current gripe right now is the quality and usability of the forum search results. They seem to be returning a page full of different posts in the same thread and just generally not giving me what I was looking for, as compared to the previous search functionality which worked fine. Also the search interface feels a little clunkier, such as modifying my initial search query to +'ing the different search terms and printing out spaces as %20's, etc.
     
    Last edited: Jul 8, 2012
  5. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Until the details of searching can be ironed out, don't forget the google custom search engine (link in my .sig)!
     
  6. kurylo3d

    kurylo3d

    Joined:
    Nov 7, 2009
    Posts:
    1,123
    I had commented that "Attached Images " dont appear for me. But I have recently realized they do not appear on my work computer, but do just fine on my home computer. Is there some sort of reason on your end for this? Because it seems dumb if certain people wont be able to view images in my posts and therefore not be able to help me... unless of course i upload the images to my website and link people following it.
     
  7. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    Hm, "New Posts" just lists postings that are not older than one hour. I need to log out and use "Today`s Posts" to reach the older posts.
     
  8. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,401
    Sometimes "new posts" does that to me too, but then sometimes I click on "mark forums read" and the next time I visit I get posts up to several hours old, including the ones I supposedly marked as read. So basically the workingness factor for new posts overall is approaching zero.

    --Eric
     
  9. scarpelius

    scarpelius

    Joined:
    Aug 19, 2007
    Posts:
    966
    I have just one question: could we expect to get back the full functionality of vBulletin forum software?
     
  10. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    The new posts thing seems intermittent for some reason. I've found often that I only have a few "new" posts when I login, but this morning I found this:

     
  11. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,401
    Now I'm getting "you must be signed in to use this content" when using "new posts". Even though I am, obviously, signed in....

    --Eric
     
  12. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    That`s a special moderator login =)
     
  13. Per

    Per

    Joined:
    Jun 25, 2009
    Posts:
    460
    So how do you change your username back to your original forum name now that I've been forced to make a brand new set of accounts to access this site's content just for the sake of unity answers (which I've never once used and have no intention of using)?
     
  14. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    asdfg: You should not have been forced to create a new account just for the sake of answers. If you feel you have, you've done something wrong.

    Have you been able to successfully claim your original forum account? With a post count of 1 it looks like you have not claimed your forum account correctly.

    If you have not created an answers account, but simply want to claim your forum account, you need to login to Unity Developer Network with your Unity Developer Network details, follow the instructions to claim your forum account, and follow the instructions to "continue" if you don't have an answers account. If you follow the instructions, a new answers account will be created for you as part of your Unity Developer Network claim process.

    Eventually, you will be able to change your Unity Developer Network name when the "Unity Developer Network Profile Page" is ready for release.

    What was your original account name?
     
  15. Per

    Per

    Joined:
    Jun 25, 2009
    Posts:
    460
    I was forced to for the sake of answers. I could claim my forum account, but then i could go no further as it would force me to try and claim an answers account (there was no "continue" option), while still showing only the "claim answers" and "claim forum account" buttons even though i had already successfully claimed my forum account.

    At that point i could not make a new answers account, i could not go on from the page and even see any forum or other page, i had to restart the entire process and tell it that i had no accounts and make a new one simply in order to be able to even view the forum.

    My original account name was Per.
     
  16. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Well, Per/asdfg, it looks like you have not successfully claimed your forum account. I can see Per, with the same email address as asdfg, on the list of forum users. I recognize the avatar (HI!). I'm not sure what went wrong, but it seems that the forum account wasn't claimed. I did a test with a series of Unity Developer Network accounts (unofficially) using some different email addresses and some created alts. I created an alt on the forum that had no answers account - and with the exception of some ambiguous dialog, I was able to claim the forum account and continue without an answers account. I also captured the major steps.

    For the sake of others reading this, here is what I saw...

    Trying to login with your Unity Developer Network account that has no associated accounts should lead you to this:

    If you have a forum account, you can try to claim either answers or forum. If you have no answers account, you should try to claim the forum.

    Once you have claimed your forum account, you should come to this:

    If you have an answers account, try to claim it, if not continue by choosing "Select username". Now, I will admit that the text here is a bit ambiguous as it could imply that if you don't have an answers account you need to choose a username for your new answers account. This is a possible interpretation. I have suggested new text content along the lines of If you do not have an Answers account, click on "Select username" to continue and confirm the username for your new Unity Developer Network account. ... which I believe is more descriptive.

    Which leads finally here:

    The important part about his page is to actually read the instructions. People who misinterpret the previous page often blast thru this one without reading it. Having made the assumption that they need to select a user name for answers, they don't read this page, and they create a new bogus name for what they think is their new answers account... and set the name for their entire Unity Developer Network identity to something wrong... because they didn't read the instructions.

    In your case Per/asdfg, you seem to have been unable to claim your forum account in the first place. I'm not sure what went wrong or what the best fix is. As a forum admin, I can "merge" both your original Per account and the new asdfg account. If I merge Per into asdfg, asdfg will definitely be your name. I'm unclear what will happen to Unity Developer Network if I try to merge asdfg into Per, as asdfg is now your Unity Developer Network account as far as I can tell.

    You could start over and try to create a new Unity Developer Network account with a new email address, but this could seriously mess up any licenses you have associated with your Unity Developer Network account, so I really would not recommend doing this.

    This may be a job for udn@unity3d.com and have the big boys sort it out, as I have yet to gain access to the umbrella Unity Developer Network mechanics.
     
  17. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    So the trap stays sharp, and you simply send all trapped users to a individual cure? Hm, I would simply remove the trap. When somebody sucessfully claims his forum account, and does not have a Unity Answers account, then the forum account should be the UDN account name. And Unity Answers and Unity Feedback should be under this hood then. Problem solved :)
     
  18. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Well, it would be and can be - the Forum name being the Unity Developer Network name.

    In your case Tiles/Arunderan, I'm unclear how you were unable to claim "Tiles" as a name.

    I have not been able to recreate that step.

    In theory, you claim your accounts if you have them, then you create a Unity Developer Network name that could/should/would be the name of your forum account. In all of my cases, if I claims a forum account, the suggested Unity Developer Network name was my forum name, and all I had to do was confirm.

    I tried (unofficial) tests with my own and a few alt accounts. I tried claiming forum and answers, forum only and creating a Unity Developer Network account with no accounts and was able to make all three as expected. What was causing people who were trying to claim accounts to be blocked from using their own name that they just claimed confuses me, but some people have had issues with multiple forum accounts with the same email and pass combination - perhaps this was confusing the Unity Developer Network claim process?

    The volume of people having issues is statistically 1% of all claimed accounts, but this shouldn't mean we dismiss that 1% in any way.

    Personally, I felt that the text in the second step was very ambiguous to people with no Answers account.

    Luckily, for most people, it will simply be an issue of waiting until the Unity Developer Network Profile Page is ready.
     
  19. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    9,566
    forum is very slow.. (and if you open multiple tabs, whole browser hangs for a while)

    see the waiting times when it tries to open some images..?
     

    Attached Files:

  20. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Hmm... That problem has been reported. Seems some things are still pointing to an internal server and then timing out.

    I'll chase the report with this data.
     
  21. the_motionblur

    the_motionblur

    Joined:
    Mar 4, 2008
    Posts:
    1,774
    Great ... I thought I would be changeing my answers name only but I managed to change my username from "motionblur" to "the_motionblur" for the whole UDN.
    How can I claim my old name back?
     
  22. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    "Soon" the Profile Page will be available on Unity Developer Network for customizing your Unity Developer Network accounts, but this has yet to be rolled out. Until then, it's "sit tight" or email "udn@untiy3d.com" and explain the details. Just be aware that this particular address is under pressure due to the changes, so "the wait time may be unusually high".
     
  23. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,401
    The "new posts" thing seems to be back to normal, anyway.

    --Eric
     
  24. Per

    Per

    Joined:
    Jun 25, 2009
    Posts:
    460
    I followed all of this originally, entered my correct name, it told me that my forum name was now mine, and then dumped me back on the first page (your first screenshot), only without the text link at the bottom, so I could then either repeat the process on the forum account and again be back there or click the claim answers account, which left me in a situation where I couldn't claim an account nor make a new one, and also couldn't get any further to even view the forums or any community content that might have had some hints from other users. I've been in contact with support for a full week explaining this exact situation and going in circles. :/
     
  25. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    Yes, it`s a trap. But just 1% is affected. Lucky us :)
     
  26. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    There might be a little bug here. Not sure ... :)

    What i did was to mark all forums read, then quickly click at the New Posts button.

    Oh, and in the image manager the system fails to create a thumbnail for my attached image here it seems.
     

    Attached Files:

  27. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Yes, Aruneran, I've started to see this as well. It seems that Unity Developer Network feels you are properly signed in, but the forum does not.

    I have talked about this internally, but (on the other hand), you might want to submit a bug report through the Unity Bug reporter and include that image as an explanation.
     
  28. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    Hm, a forum bug feels wrong for me to submit it through the Unity bug reporter. Especially because all bug reports without proper attachments gets ignored. And i doubt that a jpeg will count as proper attachment. But i`ll do as adviced now. As a workaround, shall i attach an empty Unity project too? :)
     
  29. Per

    Per

    Joined:
    Jun 25, 2009
    Posts:
    460
    OK, got my nick fixed (thanks).

    Is there any way to make it so that threads you've viewed or posted in are marked as read without going to the global forum actions to mark all as read?

    edit- Scratch that, apparently it is working now, it wasn't earlier, perhaps a cookie problem.
     
  30. Acumen

    Acumen

    Joined:
    Nov 20, 2010
    Posts:
    1,041
    I miss my report button.
    The only use I see now, is that there are much more signed in users on the forums. Almost feels like cheating :)
    Me personally, I kinda drifted away completely from the forums with the merge (problems)
    I'll try my best to rekindle:)
     
  31. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    The report button is still there, Acumen, it's just invisible... (>_<)

    If you hover your pointer over the appropriate location, you can find it:


    "rough edges"
     
  32. pivotraze

    pivotraze

    Joined:
    Feb 4, 2012
    Posts:
    593
    Is anybody noticing the missing Multi-Quote Icon?
     
  33. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,401
    Most of the buttons are missing, or at least invisible. You can click on them if you try....

    --Eric
     
  34. pivotraze

    pivotraze

    Joined:
    Feb 4, 2012
    Posts:
    593
    And the reply with quote icon is missing :p I can still click the buttons as you said though :p
     
  35. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    9,566
  36. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Yes, that is correct. It seems that some buttons are pointing towards an incorrect and inaccessible location.
     
  37. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    So why does nobody fix it then?
     
  38. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    I think it's a volume of labour issue. I believe there are more critical issues to be worked on, and then, like so many things software related, these fixes are bundled up, tested and then pushed live in batches.
     
  39. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    With all respect, what can be more critical than a not proper working UI? Especially when it`s a pretty fast fix when there`s just a URL for the icons to change?
     
  40. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Seems like it's not that easy, as the forum, its contents and changes are held in a versioning package. It seems there is come error in the way the templates are created and cached, so it's more complicated than a simple fix. The web team is trying to track down why these links are being generated incorrectly and need to find what the bug is on that level.
     
  41. Graham-Dunnett

    Graham-Dunnett

    Administrator

    Joined:
    Jun 2, 2009
    Posts:
    4,287
    Um, users not able to claim their accounts? Users stuck in infinite claim loop? Security? Performance? And yes, fixing some URLs does sound trivial, and any one of us could edit the links directly to fix them. But the correct solution is to understand why they are not correct, and fix the forum template publishing.
     
  42. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    Point taken. Question is, where does this chaos come from. Has nobody tested the stuff before the UDN move ?
     
  43. kenshin

    kenshin

    Joined:
    Apr 21, 2010
    Posts:
    940
    After this update the forum is really slow ... is really frustrating :(
     
  44. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Button Images are BACK!

    You may need to force reload a page displaying a thread to update the local CSS, but I can see the buttons now.
     
  45. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,481
    YAY! *dance* :D

    Thanks :)
     
  46. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    32,401
    It doesn't seem to be any different speed here.

    --Eric
     
  47. kenshin

    kenshin

    Joined:
    Apr 21, 2010
    Posts:
    940
    Onestly today also here speed is good :)
    ...but in past days I have experienced slowness here.
     
  48. zumwalt

    zumwalt

    Joined:
    Apr 18, 2007
    Posts:
    2,287
    I'm in at last, in at last, thank goodness me I am in at last!
    Thanks to all the hard work and help from the support team to figure out the goofy problem with my accounts and joining them issue.
    So far I think this is faster but I am using Firefox and it is smoother to me, maybe the slowness is an internet explorer issue, but ya, much faster, much much faster.
     
  49. Adam-Buckner

    Adam-Buckner

    Joined:
    Jun 27, 2007
    Posts:
    5,664
    Yay! Welcome back!
     
  50. CodeCody

    CodeCody

    Joined:
    Apr 27, 2010
    Posts:
    440
    Still can not view unity answers when logged in. I can just log out and go directly to unity answers. Anyone else also having this problem?:




    Edit:
    Oh and eagerly waiting the ability to change my name, feel like I am a fish. -_-