Search Unity

Question Unity create project not working

Discussion in 'Getting Started' started by tonebag, Sep 11, 2023.

  1. tonebag

    tonebag

    Joined:
    Sep 11, 2023
    Posts:
    2
    I am new to Unity and am having trouble creating a new project. I have created a Unity ID and downloaded the Unity Hub, and the editor installation works fine (I currently have 2021.3.30f1 but have also had this problem on more recent versions). When I go to new project and select a template, it says that it was downloaded, and the project appears under the projects tab in the hub, but the project does not appear in my finder. When I try and open the project, I get an error saying 'Project failed to open. Please check the logs'. The log files are very long, but the repeated error is:

    {"timestamp":"2023-09-11T17:00:43.853Z","level":"error","moduleName":"LocalProjectService","message":"[ 'Error while opening project: {\"code\":400,\"error\":{\"errorCode\":\"ERROR.PROJECT.PATH_NOT_FOUND\",\"projectName\":\"Test\",\"projectVersion\":\"2021.3.30f1\",\"projectArchitecture\":\"x86_64\",\"projectPath\":\"/Users/Anthony/Unity/Test\"}}' ]"}

    As far as I can see, something is stopping the Unity Hub from creating a project on my disk even though it says it is created in the hub. I have tried reinstalling and uninstalling the editor, different editor versions, and the unity hub but nothing worked. I have also tried changing the access permissions for the unity hub. I am using a Mac with an intel core.
     
  2. eco3r

    eco3r

    Joined:
    Sep 18, 2023
    Posts:
    1
    …I have the same issue, did you manage to figure it out?