Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Question Unity build does not work in Android 13 (api 33)

Discussion in 'Getting Started' started by Alidsf, Sep 5, 2022.

  1. Alidsf

    Alidsf

    Joined:
    Sep 24, 2020
    Posts:
    4
    When I got the build from the project, the game worked fine on all Androids. But the game crashes on Android 13! And it says that the program has stopped.
    First, I said that the problem might be with the SDKs. I downloaded all the new SDKs, but the problem was not solved.
    Then I said that maybe the project had a problem, and I created a new project and got the same build, but the problem was still not solved.
    Then I said that maybe the problem was due to the Unity version, so I downloaded the latest version of Unity and made a build with it, but the game crashed again.
    Then I said that maybe Unity couldn't build correctly, so I exported the project and built it in Android Studio. First, the apk size increased, but the game crashed again!
    The project builds without errors, only when I enter the player settings and other settings; in the part that wants to load the maximum API and target, it says "getting API level..." When the API is loaded, several warnings are given in Unity! I think this could be the problem, but I haven't found any way to fix these warnings. I am posting here the screenshot of these warnings and the downloaded SDKs.
    I would be grateful if someone could help me to solve this problem.
    I am using Unity 2021.3.8.

    Warning.PNG
    SDK.1.PNG
    SDK.2.PNG
     
    Last edited: Sep 7, 2022
  2. RichAllen2023

    RichAllen2023

    Joined:
    Jul 19, 2016
    Posts:
    820
    I would contact Unity support about this (and I don't mean just PM Jeff)