Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Bug Unity Android Build Error 2022.3.23f1

Discussion in 'Editor & General Support' started by JustFamous, Apr 8, 2024.

  1. JustFamous

    JustFamous

    Joined:
    Aug 23, 2017
    Posts:
    12
    Hello I want to build my game for Android but I get this error 2 times when it builds: Library\PackageCache\com.unity.collections@2.1.4\Unity.Collections\NativeList.cs(837,24): error CS7036: There is no argument given that corresponds to the required formal parameter 'safety' of 'NativeArray<T>.ReadOnly.ReadOnly(void, int, ref AtomicSafetyHandle)' Library\PackageCache\com.unity.collections@2.1.4\Unity.Collections\NativeList.cs(851,24): error CS7036: There is no argument given that corresponds to the required formal parameter 'safety' of 'NativeArray<T>.ReadOnly.ReadOnly(void, int, ref AtomicSafetyHandle)' And If I press on them, they point me here
    What can I do about it? I tried some fixes that I have found online but they don't work.. I have IL2CPP installed from Unity hub...
     
  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    7,019
    Try upgrading the collections package, 2.4.0 is the current version.
     
    JustFamous likes this.
  3. JustFamous

    JustFamous

    Joined:
    Aug 23, 2017
    Posts:
    12
    upload_2024-4-9_13-19-6.png
    Unity doesn't let me upgrade it to 2.4.0 using Unity 2023.3.23f1
     
    Sam-N likes this.
  4. JustFamous

    JustFamous

    Joined:
    Aug 23, 2017
    Posts:
    12
    upload_2024-4-9_13-28-18.png
    Updated it from package manager using by name, but it still won't work.
     
  5. Sam-N

    Sam-N

    Joined:
    Mar 4, 2015
    Posts:
    6
    I'm encountering this when building for iOS from Mac in 2023.3.23f1 (Silicon) as well. Manually updating the Collections via name to 2.4.0 (2.1.4 is recommended for 2023.3.23f1, but that doesn't work either) did not help, same issue. Lots of bugs with 2023.3.23f1...
     
  6. JustFamous

    JustFamous

    Joined:
    Aug 23, 2017
    Posts:
    12
    I managed to build my game using Unity 2021 (latest LTS), 2022 its broken for me on Android at least.
    UPDATE: It doesn't work even in 2021 now...
     
    Last edited: Apr 10, 2024