Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question Unity Ads 4.0.1 not supported for 2018.4?

Discussion in 'Editor & General Support' started by gchris1994, Jan 9, 2024.

  1. gchris1994


    Oct 10, 2019
    I am trying to update an old app of mine to use unity ads and google states they need version 4.0.1 or higher.
    I am trying to do this update using Unity 2018.4.10f since this is the version in which the app was created. When I try to install this version I get an error " An error occurred while resolving packages: Package has invalid dependencies: com.unity.ugui: Package [com.unity.ugui@1.0.0] cannot be found".
    Should I understand that this version of the advertisement is not compatible with this unity version? Or is there some way to fix this?

  2. CodeSmile


    Apr 10, 2014
    Locate the package.json and open it. Inside you will find which version of the Unity editor it requires, as well as any packages it depends on for which you can do the same.

    It seems com.unity.ui requires Unity 2019.2 so it will not be available in / compatible with 2018.4:

    Since it's only one major version it should be that difficult to update the project to 2019.2 and if that works fine, you should bring it up to 2019.4 at a minimum and then further up the LTS versions for as long as you don't run into big issues.

    Caution: don't do it in your production branch, make a copy, test it thoroughly before you commit to an upgrade - downgrading editor versions is unsupported.

    The thing is, if you plan on publishing to mobile, you need to be on a certain SDK version and I believe 2018 is already too old respectively the SDK version that its bundled with. You may want to research which version is the minimum by comparing which SDK/NDK version Google requires and which is bundled with a specific Unity version.