Search Unity

  1. Megacity Metro Demo now available. Download now.
    Dismiss Notice

Question Unity Accelerator stuck in loop on 1st import

Discussion in 'Unity Accelerator' started by LinkoVitch, Dec 13, 2023.

  1. LinkoVitch

    LinkoVitch

    Joined:
    May 14, 2015
    Posts:
    18
    Hi,
    I am using Unity Accelerator to help speed up our build pipeline, however, we are seeing a situation that when a new build is triggered on a fresh version of the project the Unity editor process seems to sit in a loop of connecting and disconnecting from the Accelerator and not actually doing anything. This seems to never end (have left it sat there for over 50 minutes doing nothing).

    If I stop and re-run the same build in the same folder with no changes, it picks up and runs to completion with no issue. The output from Unity is the following :


    Code (CSharp):
    1. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    2. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    3. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    4. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    5. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    6. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    7. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    8. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    9. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    10. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    11. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    12. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    13. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    14. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    15. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    16. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    17. AcceleratorClientConnectionCallback - connected - 10.0.0.202:10080
    18. AcceleratorClientConnectionCallback - disconnected - 10.0.0.202:10080
    Version of Unity in this case is 2020.3.48f1 being built under Windows 10, with the accelerator running on a Windows Server 2019 machine.

    Accelerator reports its version as: v1.0.941+g6b39b61

    Any ideas?

    Thanks