Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Unity 5 doesn't start with firewall (and is very slow)

Discussion in 'Getting Started' started by schlock, Mar 10, 2015.

  1. schlock

    schlock

    Joined:
    Mar 10, 2015
    Posts:
    2
    I just downloaded and installed Unity 5.0.0f4 on Windows 7 (I7 2.4GHz, 8GB RAM, 256GB SSD) and
    1/ it fails to start if the firewall is running
    2/ takes an inordinate amount of time to start (maybe 5 minutes or so)

    Does anyone have any suggestions on how to fix the firewall and/or fix the lack of start-up performance?
     
  2. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    6,244
    Sounds like you should add exceptions to the firewall for Unity. To fix this, assuming you are on Windows, go to the control panel, open the firewall control panel, select "Allow an app or feature through windows firewall", find Unity in the list, and allow both public and private networks. If it isn't in the list, add it with the "Allow another app" button.
     
  3. schlock

    schlock

    Joined:
    Mar 10, 2015
    Posts:
    2
    That didn't work, unfortunately. It seems like a pretty fundamental failure by the devs if it doesn't work with Windows 7 :)
     
  4. Ryiah

    Ryiah

    Joined:
    Oct 11, 2012
    Posts:
    21,701
    Works perfectly for me on Windows 7. I've never had to disable the Windows firewall either.