Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Unity 5 and Visual studio 2012 refreshing problem ( and Unity crashing )

Discussion in 'General Discussion' started by johnpine, Dec 3, 2015.

  1. johnpine

    johnpine

    Joined:
    Sep 19, 2015
    Posts:
    26
    Since Unity 5.2.3f1 the Unity has been crashing a lot, like 10 times per hour when trying to open a source file to Visual Studio.
    The cause for this probably something to do with that Unity is constantly updating the project.sln file and Visual Studio has the dialog open always saying files modified out side, reload ?
    This constant solution file updating was introduced in some Unity 5 version maybe from 5.1.
    This make developement so difficult now, always when double clicking any source in Unity assets does nothing.
    I have to alt-tab to Visual Studio to either click Reaload all or ignore all.
    If I reload all I will loose all undos for my edited sources and possible unsaved files.
    ( have lots some code because of this )
    For me the Unity crashed constantly now when trying to open a source to Visual Studio 2012.
    Editor.log and crash.log last event is always opening <source> to visual studio 2012 stuff.
    This crashing was introduced in 5.2.3f1 so I had to roll back to be able to do anything anymore.
    Each time Unity crashes and I have to restart the project and wait a long time the Play to work again.
    Why is unity constantly updating the .sln file ? Why ? Older versions there was the "sync mono project" which was the only ( and when creating new c# file to the project ) way to sync the actual project files of Visual studio.
    This was so good. Now it constantly wants to update the .sln file and I have to manually alt-tab to VS and click either Ignore or Reload ( the settings in visual studio documents auto ignore or reload does not affect the solution file changes )
    So, please fix the crashing.
    And please stop updating the solution file all the time.

    I have made a fix for this. 2 icons on my desktop.
    The first file is to delete solution file.
    The second file is to set it read only so that unity cant update the file. This work brilliantly !
    Unity is not crashing anymore and i dont loose work.
    So when I want to update the solution file i double click the delete file script, and open a file from Unity and then double click the make it readonly script.
    If anyone else is bugged with this, this is a fix for it.