Search Unity

Unity 5.6.1 editor crashes everytime I open a certain project

Discussion in 'Editor & General Support' started by xmanreturn, Jun 26, 2017.

  1. xmanreturn

    xmanreturn

    Joined:
    Mar 11, 2015
    Posts:
    14
    The project is running normally in previous version 5.5.0, but after I upgrade the unity to 5.6.1, load the project(upgrade the project yes), it starts to crash.

    First time I run the project after the upgrade, unity crashes after a couple of minutes of playing in editor mode.

    Then every time I try to open the project again, unity will crash just after loading the project.

    see the log:

    ========== OUTPUTING STACK TRACE ==================

    0x0000000140BFE1F3 (Unity) RenderTexture::Create
    0x0000000140BFF9C9 (Unity) EnsureRenderTextureIsCreated
    0x000000014095D795 (Unity) Camera::SetRenderTargetAndViewport
    0x0000000140965C3D (Unity) Camera::SetupRender
    0x0000000140968DD8 (Unity) Camera::SetupRender
    0x0000000140973DD7 (Unity) Camera::CustomRender
    0x0000000140975012 (Unity) Camera::Render
    0x0000000140975261 (Unity) Camera::Render
    0x00000001409AA9F5 (Unity) ReflectionProbes::RealtimeReflectionProbeCount
    0x00000001409C90EB (Unity) RenderManager::RenderOffscreenCameras
    0x000000014171B3D7 (Unity) Application::UpdateScene
    0x000000014171CAAF (Unity) Application::UpdateSceneIfNeeded
    0x000000014172532A (Unity) Application::TickTimer
    0x00000001417F0ABC (Unity) CrashCallback
    0x00000001417F2704 (Unity) WinMain
    0x0000000141AD7444 (Unity) strnlen
    0x00007FF888B32774 (KERNEL32) BaseThreadInitThunk
    0x00007FF888D80D61 (ntdll) RtlUserThreadStart

    ========== END OF STACKTRACE ===========

    And here's the log when the "crash" appears:

    - starting compile Library/ScriptAssemblies/Assembly-CSharp-firstpass.dll, for buildtarget 5
    Issue TrimJob to reduce GI Cache size to maximum 10GB at: 'C:/Users/Jimmy/AppData/LocalLow/Unity/Caches/GiCache'
    Setting up 4 worker threads for Enlighten.
    Thread -> id: 2a40 -> priority: 1
    Thread -> id: 3510 -> priority: 1
    Thread -> id: 250c -> priority: 1
    Thread -> id: 4bec -> priority: 1
    Crash!!!

    I post the question in "answer forum" but I am not sure it is the right place, for the previous crash questions are not generally answered :) So I figure it's better to post the question here:) Thanks for any help!
     
  2. xmanreturn

    xmanreturn

    Joined:
    Mar 11, 2015
    Posts:
    14
    I opened error.log, it says:

    Unity Editor [version: Unity 5.6.1f1_2860b30f0b54]

    Unity.exe caused an Access Violation (0xc0000005)
    in module Unity.exe at 0033:40bfe1f3.

    Error occurred at 2017-06-26_233506.
    C:\Program Files\Unity\Editor\Unity.exe, run by Jimmy.
    31% memory in use.
    16287 MB physical memory [11139 MB free].
    18719 MB paging file [12520 MB free].
    134217728 MB user address space [134215513 MB free].
    Read from location ffffffff caused an access violation.

    Context:
    RDI: 0x00000000 RSI: 0x094301e0 RAX: 0x00000001
    RBX: 0x4283cb18 RCX: 0x07e89c70 RDX: 0x00000300
    RIP: 0x40bfe1f3 RBP: 0x005ed5e9 SegCs: 0x00000033
    EFlags: 0x00010206 RSP: 0x005ed540 SegSs: 0x0000002b
    R8: 0x00000000 R9: 0xce52bee0 R10: 0x03d3b7e0
    R11: 0x427ec858 R12: 0x07e89c70 R13: 0x00000000
    R14: 0x00000001 R15: 0x000000c0

    Bytes at CS:EIP:
    41 ff 93 48 01 00 00 49 8b cc e8 de 1d ff ff e9
     
    Seraphic572 likes this.
  3. Shizola

    Shizola

    Joined:
    Jun 29, 2014
    Posts:
    215
    Have you tried deleting your library folder?
     
  4. xmanreturn

    xmanreturn

    Joined:
    Mar 11, 2015
    Posts:
    14
    I tried, but it's not working though.

    However I solved the problem by upgrading unity to 5.6.2f1 :)
     
    Shizola likes this.
  5. unity_4kOyMuPv3EE4DA

    unity_4kOyMuPv3EE4DA

    Joined:
    Feb 27, 2018
    Posts:
    1
    Hello,
    When i try to open a project file it crashes every time! I deleated the Unity and Install it again but it still dosent work!
    It sais Unity Bug Report but even if i send a bug it wouldn't let me in the project! Please help
     
unityunity