Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Unity 5.5 unusable on mobile if using Lightmaps.

Discussion in 'Editor & General Support' started by artysta, Dec 1, 2016.

  1. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124
    I've seen a couple other threads on this issue but I couldn't reply to them so here's another one.
    My light maps when rendered (iOS) are very very dark in the Editor & Game Windows.
    If I build the project, the light maps are used correctly when installed on the mobile devices.
    While this works, this is not an acceptable workaround. Its a terrible waste of time.
    Im very disappointed once again as it seems Unity is back to their push the releases out before major issues are finished. I thought they were going to slow down, which worked for awhile.
    I know Im not alone in this problem, this is a beta type issue, not a release problem.
    I watched this issue for 4 betas and it gets shipped. Wow, why did you release this?
    And yes, it doesn't matter what project I use to test this and with multiple computers.
    Back to 5.4, 5.5 gets trashed. Disappointed.
     
    Hagen likes this.
  2. Amir-Ward

    Amir-Ward

    Joined:
    Jan 26, 2015
    Posts:
    30
    I was just about to start a thread about this problem myself and found yours. I have been wrestling with light baking all morning and can't get it to work. All my scenes now are close to pitch black. I have cleared my GI Cache, turned all my lights up to max; intensity, bounce boost etc but everything is still extremely dark.

    Enlighten is very much broken in 5.5 which is really frustrating.
     
  3. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124
    You can stop there, the light maps are actually being rendered but you have to install the app on your mobile device to see the correct maps, so whats broken is what being rendered or not used in your Editor/Game window. And in my tests, I can see the light maps are there but at something like 10% brightness.
    I also experimented switching to Linear instead of Gamma which someone recondmended and while it worked it worked too much, it blew everything up too much and my UI Canvas graphics were just the opposite as the Gamma issue, they are now way too white.
    So neither were acceptable and I had to return to 5.4

    Since I saw this issue during beta testing Im just so shocked it was released this way. Poor choice.
     
    StaffanEk likes this.
  4. SaraCecilia

    SaraCecilia

    Joined:
    Jul 9, 2014
    Posts:
    675
    Hey, a fix is coming in a patch shortly. Sorry about that, I know it was mentioned during the beta testing but somehow it still made it through to the release! We've added it to the known issues section of the release notes as well.
     
    WagDan, JamesArndt and Amir-Ward like this.
  5. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124
    Thanks for the update, Im still concerned that something this major just gets slipped through especially when it was identified in the betas. Impossible to make and view light maps when your project is set to mobile is not a oops. Its a major breakdown in QA. I feel like we've gone back to the release by calendar issue we just got fixed by slowing down the release schedule. But again, thanks for the update and being told its a real issue now. Im back on 5.4.
     
    StaffanEk, eses and Shizola like this.
  6. i9mobile

    i9mobile

    Joined:
    Aug 8, 2013
    Posts:
    54
    same problem here, waiting for the update.
     
  7. hangheng

    hangheng

    Joined:
    Sep 6, 2016
    Posts:
    5
    same problem..
     
  8. kB11

    kB11

    Joined:
    Jan 24, 2016
    Posts:
    89
    I had this issue with our project which was imported from 5.4.

    I was able to fix it by deleting the local copy of the project and downloading the project again through Collaborate.

    Edit:
    AAnd it's back :rolleyes:
     
    Last edited: Dec 4, 2016
  9. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124

    I did the fresh clean re-install of my project on 2 computers, it doesn't fix the light map bug, its been verified there's an bug by Unity and they are working son it
     
  10. kB11

    kB11

    Joined:
    Jan 24, 2016
    Posts:
    89
    Yes, you are right.

    It worked for me for a while but after a day the lightmaps were suddenly dark again. We'll have to wait until the actual issue is fixed.
     
  11. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124
    I believe this is the official issue added to the know issues on the download page:
    • GI: In Editor, light does reflect off static objects when Baked GI is used with mobile platforms selected. Note that the issue is not present when the project is deployed to a device. Fix expected shortly in a patch release. (849671)
     
  12. Neklan

    Neklan

    Joined:
    May 2, 2014
    Posts:
    6
    I have same problem here. Its annoying, hope for short fix as annouced
     
  13. kB11

    kB11

    Joined:
    Jan 24, 2016
    Posts:
    89
    Indeed, I just tried it and the issue is present when Android is selected as build target, but disappears when switching to Standalone. That might have been why I didn't have the issue for a while. Probably hadn't gotten around to switching the target to Android, yet.
     
  14. Neklan

    Neklan

    Joined:
    May 2, 2014
    Posts:
    6
    Its fixed now! Thanks Unity team!
     
    SaraCecilia likes this.
  15. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124
    It has worked for me as well, but too many editor crashes for me to switch over yet. couple more patches for me.
     
  16. Neklan

    Neklan

    Joined:
    May 2, 2014
    Posts:
    6
    now i have problem with assemblies, mono develop can't see UnityEngine and other unity classes references..
     
  17. artysta

    artysta

    Joined:
    Nov 15, 2009
    Posts:
    124
    Ive had issues with this in the past and my target framework was changed somehow, try looking in your project : assemble-c# options. Make sure you are pointing to a correct framework.
    If that framework is set wrong, Mono doesn't know how to talk to Unity.


     
  18. Neklan

    Neklan

    Joined:
    May 2, 2014
    Posts:
    6
    I tried it and have same target framework, but still nothing. when i create new project, it is ok and settings are same. Don't know how to make it work..
     
  19. Neklan

    Neklan

    Joined:
    May 2, 2014
    Posts:
    6
    Ok, i solved it that i deleted Library folder from my project root and reimport all assets. It seems ok now, but other problem, on my terrain i have some weird shadow artifacts.

    Any idea what to do with it? Its just in locations, where i have terrain
     

    Attached Files:

  20. domonyiv

    domonyiv

    Joined:
    Oct 1, 2016
    Posts:
    75
    same problem here, 5.5.0f3
     
  21. Remster

    Remster

    Joined:
    Feb 18, 2015
    Posts:
    6
    You need to manually download 5.5.0p2 (Patch 2) to get the lightmap darkness fix.
     
    ilmario likes this.