Search Unity

Unity 5.3beta6 IAP error when running the app

Discussion in '5.3 Beta' started by karankk, Nov 18, 2015.

  1. karankk

    karankk

    Joined:
    Sep 17, 2013
    Posts:
    3
    I have implemented Unity IAP in one of my projects for iOS. Tested it on Unity Editor and logs look fine.

    When I build it on my phone, after a couple of seconds or so, the app freezes.

    Here is the Xcode Log:

    2015-11-18 18:05:59.243 wb[11018:2835177] -> registered mono modules 0x1011feba0

    -> applicationDidFinishLaunching()

    -> applicationDidBecomeActive()

    Init: screen size 750x1334

    Initializing Metal device caps

    Initialize engine version: 5.3.0b6 (46b1550107d8)

    error in __connection_block_invoke_2: Connection interrupted

    0.5622189

    HutongGames.PlayMaker.Fsm:UpdateStateChanges()

    HutongGames.PlayMaker.Fsm:Start()


    (Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)


    2015-11-18 18:06:05.968 wb[11018:2835177] UnityPurchasing:RequestProducts:{(

    "com.*****.**.*****.*****"

    )}

    Setting up 1 worker threads for Enlighten.

    Thread -> id: 1121bc000 -> priority: 1

    2015-11-18 18:06:06.576 wb[11018:2835177] UnityPurchasing:Requesting product data...

    After this, nothing shows up and the app remains frozen. Some help sorting this issue would be great :).
     
  2. Banderous

    Banderous

    Joined:
    Dec 25, 2011
    Posts:
    669
    The lockup may not be caused by Unity IAP, the timing of the last logging statement may be coincidental.

    Can you pause the application in the xcode debugger and send a screenshot of the stack trace of the main thread?
     
  3. karankk

    karankk

    Joined:
    Sep 17, 2013
    Posts:
    3
    Thank you for the response. Have attached the screenshot.

    This started happening after incorporating Unity IAP. Strangely, there is no crash as such, just that the app freezes.
     

    Attached Files: