Search Unity

Unity 5.3 Weird... Blurry... Camera..... Thing

Discussion in 'Editor & General Support' started by SteveJ, Dec 10, 2015.

  1. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    Happening in Unity 5.3. I've tried turning off all the camera effects (there's nothing too fancy going on there anyway) but it doesn't help. Any thoughts on this? If I run it in the Editor "un-maximized", and I resize the Game window back and forth the blurry area grows and shrinks. It's weird, man!

     
  2. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
  3. wbwelcomeback

    wbwelcomeback

    Joined:
    Jun 22, 2013
    Posts:
    1
    I have the same weirdness going on. Disabling all camera effects will get rid of it though, but as soon as I turn one of them back on it appears again.
     
  4. Dantus

    Dantus

    Joined:
    Oct 21, 2009
    Posts:
    5,667
    Looks like a too small render texture that is clamped with a little vignette on top of it. Definitely worth a bug report.
     
  5. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,866
    That's... trippy! Bug report is in order!
     
  6. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    I love how every time I upgrade Unity something major breaks for me. Like EVERY time. All the lighting is messed up too - like everything is way too bright now and I have to go back and adjust all the range/intensity settings on my lights again.

    Anyway, yeah - this blurry thing is quite strange. I'm going to play around with it some more over the weekend. It's definitely not affected by whether or not camera effects are enabled or disabled in my case.
     
    MrEsquire likes this.
  7. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    4,817
    I see the same thing - At some point, it goes nuts, and the bad area creeps over, and then all texturing is gone. However, apparently the zbuffer is still there, because SSAO and shadows are still drawn. Very weird.

    I'm assuming you're on a Mac, as this is an artifact of the new OpenGL core. To get past all the new OpenGL Core bugs, you'll have to force unity to run with the old OpenGL. (by running unity from the command line with -force-opengl like this:

    /Applications/Unity/Unity.app/Contents/MacOS/unity -force-opengl

    I keep posting bugs for different issues in OpenGL core - but I haven't posted one for this issue yet. If your project isn't too big, please submit a bug report and post the case number here so we can follow it.

    Thanks!
     
    Dantus likes this.
  8. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    I've tracked this down. So first of all, it only happens under Forward rendering, not Deferred.

    I started playing with the Quality settings though and figured out that I have the problem under "Beautiful" (my default), but it goes away under "Good". So I started turning things off and on, and I've conclusively found that if I turn ON Anti-Aliasing, I do get the problem. If I turn OFF Anti-Aliasing, then I do not get the problem. So... looks to me like Anti-Aliasing is what's causing it.
     
    MrEsquire likes this.
  9. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    I can't reproduce it though in a simple project, so obviously it's the Anti-Aliasing plus... ??? something else, that's causing it.
     
  10. groovounet

    groovounet

    Unity Technologies

    Joined:
    Jul 15, 2013
    Posts:
    16
    Hi SteveJ,

    Could you submit a bug report including your project? To speed up the process, could you reply with your bug number here?

    Thanks!
    Christophe
     
  11. SteveJ

    SteveJ

    Joined:
    Mar 26, 2010
    Posts:
    3,038
    I'm not willing to upload my project and I haven't been able to reproduce it in a test project. If I do manage to, I'll submit a bug report.
     
    MrEsquire likes this.
  12. ArthurT

    ArthurT

    Joined:
    Oct 26, 2014
    Posts:
    73
    It's always advised to disable anti-aliasing because it's been broken for what it feels like forever, since it's also known to cause issues with HDR in deferred to say the least, especially causing all sorts of bugs inside the editor. It's best to use a replacement for it, like SMAA instead.

    I think the lighting issues are due to how Unity 5.3 handles lighting, especially the custom near plane slider for spot light shadow and shadow bias for point lights additions as described in their upgrade guide.
     
  13. daraOke

    daraOke

    Joined:
    May 8, 2015
    Posts:
    7
    So half my screen is still blurry... any fix yet? or do I still have to continue forcing the old OpenGL?
     
  14. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    4,817
    Have you tried p1 yet? I have t had this reoccur once I installed the first patch.
     
  15. daraOke

    daraOke

    Joined:
    May 8, 2015
    Posts:
    7
    no, i haven't. umm... whats P1?
     
  16. Jaimi

    Jaimi

    Joined:
    Jan 10, 2009
    Posts:
    4,817
  17. daraOke

    daraOke

    Joined:
    May 8, 2015
    Posts:
    7