Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Unity 4.7.1 Support for Xcode 7.3

Discussion in 'Announcements' started by P-Jawahar, Feb 25, 2016.

  1. P-Jawahar

    P-Jawahar

    Release Manager Unity Technologies

    Joined:
    May 15, 2014
    Posts:
    225
    We are happy to ship a new Unity 4 release supporting Xcode 7.3. Recall that the last official release was Unity-4.7.0 in December 2015. There is no change in the plan outlined in that blogpost, but we want to help those who would otherwise be left stranded without support for Xcode 7.3. We have also added a couple of minor fixes to this release.

    Changes
    • iOS/IL2CPP: Added support for Xcode 7.3.
    Fixes
    • Android: Fixed crashes on Tegra K1 and Xiaomi devices due to unaligned memory access (712011), (700531).

    • iOS/IL2CPP: Prevent a double allocation for multi-dimensional arrays. (766168).

    • OSX: Fix for standalone player menu pausing execution. (702914).

    Revision: 68064779abd0

    Version: 4.7.1f1

    Download Link: http://unity3d.com/get-unity/download/archive
     
    John3D, bluescr, Noisecrime and 11 others like this.
  2. Mangatome

    Mangatome

    Joined:
    Mar 5, 2014
    Posts:
    13
    I for one am very grateful about this release. Thanks a lot!
     
    John3D, Cromfeli and Aurore like this.
  3. GhulamJewel

    GhulamJewel

    Joined:
    May 23, 2014
    Posts:
    335
    Thank you.
     
  4. Alan_R

    Alan_R

    Joined:
    Mar 23, 2015
    Posts:
    1
    Awesome!! Thank you so much!
     
  5. tgouala-wellfiredLtd

    tgouala-wellfiredLtd

    Joined:
    Jun 8, 2013
    Posts:
    99
    Many thanks ! Always received awesome support from Unity guys. Really appreciate :)
     
  6. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,875
    Heh heh, Unity 4's not lettin' up now! :D
     
  7. adslitw

    adslitw

    Joined:
    Aug 23, 2012
    Posts:
    167
    Thank you - much appreciated!
     
  8. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Thank you for xcode but you left Android with graphics and crash issue on multiple devices which sucks big time. Least you attempted a fix in this version, where was Unity developers months ago.. Fix up Android crashes
     
  9. jesusluvsyooh

    jesusluvsyooh

    Joined:
    Jan 10, 2012
    Posts:
    363
    Thanks, any idea when the old networking system will be fully removed? (Unity 5+)
    I have some popular multiplayer games on many platforms, and i'm starting to convert ONE of them, and its a little overwhelming.
    Wondering how much time i have left before the old RPC's and networkview's are gone >_<
     
  10. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Please can you help with this:

    http://forum.unity3d.com/threads/unity-4-7-1-platform-dependent-compilation-broken.390302/

    It seems to be issue for me 4.7/4.7.1 need to know if its my project or something with Unity.
     
  11. Catacomber

    Catacomber

    Joined:
    Sep 22, 2009
    Posts:
    682
    Can anyone tell me how long Unity will support the 4.x cycle? Is it possible this isn't the end?

    @MrEsquire, I'm reverting to 4.7.1 since there is XCode support so have to remove 5.3.whateverpatchihave and reinstall 4.7.1. I'll let you know if I have a problem. I also have have installed and uninstalled and reinstalled different versions so often recently, am worried there might be file conflicts. Going to try to hunt down all the Unity files and remove them, including any hidden files before installing 4.7.1. I'm also using El Capitan.
     
    Last edited: Mar 9, 2016
  12. Catacomber

    Catacomber

    Joined:
    Sep 22, 2009
    Posts:
    682
    @MrEsquire--is your problem that that code throws an issue when you compile for ios or Mac?

    I don't have any problem with compiling scripts on 4.7.1 in mono and I don't have any problem building an XCode project with Unity 4.7.1.

    I do have some problems with some of my assets where the assets' scripts refer to versions of Unity other than 4.7 but can fix those by just adding || 4.7 where needed. These are all dif/enddifs.

    I don't have any 5.0 version of Unity installed on my macbook anymore.

    If you just comment out the lines that refer to Android would that work on ios? Or am I misunderstanding what your problem is?

    If the problem shows up on Android without commenting out those lines, I'd comment them out and see if everything builds.

    Trying to help.

    Does anyone know how long Unity will continue to support 4.x? I need to let one of the developers of an asset I depend on know.

    Thanks very much.
     
  13. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    8,154
    They stopped supporting it already. 4.7.1 was a bonus.
     
  14. Catacomber

    Catacomber

    Joined:
    Sep 22, 2009
    Posts:
    682
    Thanks. I think that's too bad.
     
  15. MaNiC

    MaNiC

    Joined:
    Feb 18, 2013
    Posts:
    28
    Hi, I am wondering where can I get the WebplayerFull installer of 4.7.1?
     
  16. almo

    almo

    Joined:
    Jul 14, 2010
    Posts:
    83
  17. OZAV

    OZAV

    Joined:
    Aug 9, 2013
    Posts:
    232
    The video ?
    Where is the video, say: "how to setup Player FPS weapons with
    uPI(e) Menu
    " ?
    Any soon ?
     
  18. John3D

    John3D

    Joined:
    Mar 7, 2014
    Posts:
    407
    Thanks for this release. It's awesome!
     
  19. JuJuCoder

    JuJuCoder

    Joined:
    Dec 10, 2013
    Posts:
    30
    Thank you for this release. I am just wondering if Unity would reconsider to extend the support of 4.x series, since Unity 5 is still strongly under development and there might be lot of people who cannot upgrade to 5 due to technical issues (due to bugs in unity 5, e.g. mobile issues, lightmaps), or upgrade just just takes too much work (and is not financially viable).

    I bet that there are a lot of released products out there that are done with unity 4 and their lifecycle support would be much easier without upgrading to unity 5, if that is even an option.
     
    Catacomber likes this.
  20. jesusluvsyooh

    jesusluvsyooh

    Joined:
    Jan 10, 2012
    Posts:
    363
    +1
    I have some pretty darn popular cross platform multiplayer games now (3 million+ downloads for all my games in total) which use Unity 4 and its network system, and various other stuff that is hugely different in 5.
    I'm trying to convert and upgrade but its causing all sorts of problems and taking huge amounts of time for just one game/project XD
    Just a little bit longer for 4 please, mainly for XCode support, as from what i've learned in the past, thats the biggest problem when it comes to upgrades/latest versions >_<
    Thanks, and keep up the good work!
     
    Catacomber likes this.
  21. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    It way to late ask for more unity 4.6 support, where where you guys months ago, no one said anything at the time and now the need to keep it going, im being realistic here, 5.1,5.2,5.3 out and 5.4 beta..i had my fair share of upgrade problems and still do, but i simply think its not going to happen, they may release 4.7.2 but with smAllest change
     
  22. Catacomber

    Catacomber

    Joined:
    Sep 22, 2009
    Posts:
    682
    I'll take any update even with the smallest change to 4.7x. I'm not sure we all realized how many problems 5 would have as it was developd. I was really scared recently reading about new bugs in the forum reported for 5. And sometimes reported by many and no answers from Unity staff.

    I'm looking forward to 5.x one day being as stable as 4 but I think we're far off.

    You're right though more people should have petitioned to keep 4.x going earlier on.
     
  23. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Yes at that time there was not much petition, anyway when 5 came out there where bugs present. What I'm trying to say now is that 5.3.4 latest as advertised by Unity is pretty much solid and I made sure they pushed this with long thread. So not sure which bugs your talking about tbh?

    The only issues one may have is the upgrading process and this is normal, if your game has made a decent amount of revenue from sales then it be logical to upgrade it, if not then leave it be I guess, just my thoughts.
     
  24. JesterMaster

    JesterMaster

    Joined:
    Oct 29, 2014
    Posts:
    34
    My experience was a huge suprise how unfinished unity 5.3 was. After one week of hard work I managed to upgrade to unity 5.3.2. After this there was only option to roll back to 4.7. Unity 5 is just not ready for mobile games.

    Now my hopes are that in the future 5.4 will sort this problems for mobile games. But when I wait for this my only choice is 4.71 and I hope Unity will continiu this support until Unity 5 is ready.
     
  25. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    You can try the beta, and check with a backup project.
    I cannot comment until the final release, then some comparison can be done.
    So no complaints as still in beta.
    So far for me 5.3.4 has been solid, lets forget the initial 5.3 release.
     
  26. UnityLighting

    UnityLighting

    Joined:
    Mar 31, 2015
    Posts:
    3,331
    I use unity 5.3.4 and fog is very heavy performance hit on android device. Can anybody create a game without fog?
    I test it on 5.2.x and work fine and my game work solid.
    Another issue is lightmap. Unity 5 static lightmapping is unusable . an big part of a game is: lighting and fog, and an biggest part of the lighting for mobile is lightmaping. A game engine without usable light mapping means beta and with a beta version I can't create a complete game.
    You can create amazing look game with some cubes and light mapping, like cg, but without lightmaping with best 3d models can't create anything about good looking. .
    I know for next gen games unity 5 is great and I m an mobile game developer.
     
    JesterMaster likes this.
  27. Catacomber

    Catacomber

    Joined:
    Sep 22, 2009
    Posts:
    682
    @MrEsquire --

    Thanks for pushing for things to be better. Thanks for pushing for mobile to be better. I think 5.3.4 is a great improvement but there are still many things to fix. Glad for one thing that I didn't update to latest patch because it has a serious bug which Unity is fixing. If there were a petition to allow 4.7 to live on for awhile I would sign it. :)
     
    jesusluvsyooh and MrEsquire like this.
  28. gecko

    gecko

    Joined:
    Aug 10, 2006
    Posts:
    2,172
    I missed the petition, but I doubt I'm the only one with a project stuck on 4.7 until 5 has mixed mode lighting (far lightmaps and near lightmaps with realtime shadows) working. So I hope UT keeps 4.7 as an option until that day comes.
     
    TooManySugar and Catacomber like this.
  29. JacobVR

    JacobVR

    Joined:
    Feb 2, 2016
    Posts:
    14
    Thank you a lot! This is what I was looking for. Wonderful thread.
     
  30. spacefrog

    spacefrog

    Joined:
    Jun 14, 2009
    Posts:
    648
  31. TooManySugar

    TooManySugar

    Joined:
    Aug 2, 2015
    Posts:
    864
    I'm still on 4.x I really see no reason to move to 5. I would have paid the cost of 5 if 64 bits and the new physycs whre brought to 4.x.
     
    Rusted_Games likes this.
  32. virdys

    virdys

    Joined:
    Nov 12, 2014
    Posts:
    1
    Hi,

    A new version 4.7 for xcode 8 and ios 10 will be planned (to anticipate migration to Unity 5 or not)?

    Best Regards.
     
    Last edited: Jun 21, 2016
  33. schwertfisch

    schwertfisch

    Joined:
    Sep 7, 2010
    Posts:
    126
    thanks, this helps me a lot!!!
     
unityunity