Search Unity

Unity Unity 2020 LTS Is Now Available

Discussion in 'Announcements' started by LeonhardP, Mar 10, 2021.

  1. vertexx

    vertexx

    Joined:
    Mar 18, 2014
    Posts:
    181
    Cannot seem to find this out by other means so I'll ask here...
    Does LongTimeSupport, LTS, apply to LTS versions that are earlier than the final LTS build?
    Or is LTS only apply to the latest updated LTS version.
    I have 2019LTS but there are many, many "updates" of 2019LTS.
    Which one is actually LTS, or are they all supported?
     
  2. Lurking-Ninja

    Lurking-Ninja

    Joined:
    Jan 20, 2015
    Posts:
    7,555
    LTS is for major "year" version. Like Unity 2019. The "many versions" comes from development and bug fixes (in other word: support). You always should choose the latest if you decide to use that.
     
  3. vertexx

    vertexx

    Joined:
    Mar 18, 2014
    Posts:
    181
    Thanks. Sorry for the confusion and probable "off topic" but does it mean the earlier LTS versions are no longer "supported long term"?
    Or to put it this way..does my very early 2019LTS version still have LTS? I'm asking 'cause I read many posters who have updated to newer LTS versions with less than good results and outcomes!
     
  4. Lurking-Ninja

    Lurking-Ninja

    Joined:
    Jan 20, 2015
    Posts:
    7,555
    You can always find the answer on Unity's release page: https://unity.com/releases/2019-lts
    Unity guarantees the two year support for LTS versions, 2019LTS was shipped in early 2020, so it will retire in early 2022. But this doesn't mean everything ends there, only the guaranteed bugfixes will end. You can use it moving forward if you want and can take the chance. And LTS versions are fairly stable at the end of their cycle thanks for the extensive in-house and user tests and continuous bug-fixes.

    You do not have "early LTS" version. 2019LTS. End of story. No late or early. The support means it gets bug fixes with new releases (currently 2019.4.29f1) - the 29 means it got a lot of bug fixes already. 2019.4 is the LTS version of the 2019 line, it gets the support, .29 contains the most bug fixes.

    Timeline.png
     
    Last edited: Aug 27, 2021
    LeonhardP likes this.
  5. vertexx

    vertexx

    Joined:
    Mar 18, 2014
    Posts:
    181
    Many thanks, Lurking-Ninja. Cleared things up.
     
  6. bran76765

    bran76765

    Joined:
    Jul 14, 2018
    Posts:
    22
    It appears that a bug has now been filed for this. If anyone else has this issue, go vote for it! https://issuetracker.unity3d.com/issues/findkernel-doesnt-work-when-player-built-in-server-build
     
  7. cloa513

    cloa513

    Joined:
    Jan 3, 2016
    Posts:
    30
    Why is Unity installer so bloated? If you could install Hub then whatever you need or want after that there would be a lot less problems.
     
  8. RatBytes

    RatBytes

    Joined:
    Nov 10, 2018
    Posts:
    52
    Cannot upgrade from either Unity 2020.3.19 LTS or 2020.3.17 to Unity 2020.3.20.
    It gives error and the project gets corrupted.

    I also tried deleting the library folder and perform the upgrade but the issue persists.
     
  9. DB_Smooth

    DB_Smooth

    Joined:
    Dec 1, 2019
    Posts:
    4
    Wow, they pulled the update from unity hub.
    Another half assed, broken update.

    What a mess dealing with Unity has become
     
  10. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    8,243
    Did they? I still see it.
     
  11. DB_Smooth

    DB_Smooth

    Joined:
    Dec 1, 2019
    Posts:
    4
    I just checked and it is back up now as you said.
    It was not available when I made my post.
     
  12. Alex1980g

    Alex1980g

    Joined:
    Feb 3, 2021
    Posts:
    2
    Good evening. I have a problem. Unity 2020 is not installed.3.20 via Hub 2.4.5. Win7 64bit system
    upload_2021-10-11_22-9-3.png
     

    Attached Files:

  13. Lurking-Ninja

    Lurking-Ninja

    Joined:
    Jan 20, 2015
    Posts:
    7,555
    And do you have the KB2533623 update as the Unity Hub informs you?
     
unityunity