Search Unity

Unity 2019 high-DPI scaling issue - override in compatability settings doesn't work

Discussion in 'Editor & General Support' started by EstragonHelmer, Jul 14, 2019.

  1. EstragonHelmer

    EstragonHelmer

    Joined:
    Oct 26, 2017
    Posts:
    11
    First off, I'm gonna clarify this. This is not a problem IN A GAME I'm making, it's actually the UNITY EDITOR that I'm talking about.

    In Windows I've got the High-DIP scaling set to 125% so that I can actually read the menus and stuff. Most programs are fine with that, and some I use the compatability settings to override it, to bring them back down to the 100% scale, so their UI isn't all big and blurry.

    Apparently Unity developed a problem with this setting in 2018.1, which was then fixed in 2018.2, but clearly it's come back. Normally, I'd just turn on the setting to override the High-DPI scaling, but that doesn't work with Unity any more. It worked fine in my previously used version. (2017.something)

    Has anyone else got this problem? Has anyone fixed it?

    - - - some details for you - - -
    I'm running Windows 10 Home version 1903
    I'm running Unity version 2019.1.10f1 Personal

    The first screenshot here is how it SHOULD appear (I can only get it to look like that by turning the High-DPI scaling back down to 100%, but then I can't read most of the text on my computer, so that's not a solution)

    The second screenshot is how it appears at that 125% scaling.

    Unity 1.jpg Unity 2.jpg
     
    Last edited: Jul 17, 2019
  2. EstragonHelmer

    EstragonHelmer

    Joined:
    Oct 26, 2017
    Posts:
    11
    I've done some research into this problem, and updated the main post with some new info, and a screenshot of the scaling as it should appear.
     
  3. R25th

    R25th

    Joined:
    Oct 3, 2016
    Posts:
    1
    I don't have a lot to contribute to this but I am having the exact same issue and am hoping that some activity on this thread will have Unity take notice. 2018.1.3f1 and earlier, everything looks fine. 2018.3.2f1 and later, all the editor elements are too large with no way to force them 100% DPI scale. At least in Chrome, there's a command line to force DPI scaling (--high-dpi-support=1 --force-device-scale-factor=1). Steam has a whole checkbox to "Scale text and icons to match monitor settings" (switched off, obviously). I'd hate to use my outdated 2018.1 install but if Unity doesn't allow force DPI scaling, I'll have to keep using it. (I've tested 2018.3.2f1 and 2019.2.2f1 and they both have the issue where everything is too big).
     
  4. sabint

    sabint

    Joined:
    Apr 19, 2014
    Posts:
    2
    This fixed it for me. Can you try this? upload_2019-9-14_0-34-7.png
    upload_2019-9-14_0-34-7.png
     
  5. EstragonHelmer

    EstragonHelmer

    Joined:
    Oct 26, 2017
    Posts:
    11
    Tried on 2019.2.4, and it doesn't fix it for me.