Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Unity 2019.1.0a11 and "2D animation" package

Discussion in '2D Experimental Preview' started by drordoit, Dec 14, 2018.

  1. drordoit

    drordoit

    Joined:
    Sep 7, 2013
    Posts:
    35
    After updating to unity 2019.1.0a11 I got errors from the "2d animation" package:

    Code (CSharp):
    1. /Library/PackageCache/com.unity.2d.animation@2.0.0-preview.1/Runtime/SpriteSkin.cs(180,47): error CS1061: Type `UnityEngine.Sprite' does not contain a definition for `GetBoneWeights' and no extension method `GetBoneWeights' of type `UnityEngine.Sprite' could be found. Are you missing an assembly reference?
    Code (CSharp):
    1. /Library/PackageCache/com.unity.2d.animation@2.0.0-preview.1/Runtime/SpriteSkin.cs(189,28): error CS1061: Type `UnityEngine.SpriteRenderer' does not contain a definition for `UpdateDeformableBuffer' and no extension method `UpdateDeformableBuffer' of type `UnityEngine.SpriteRenderer' could be found. Are you missing an assembly reference?
    Code (CSharp):
    1. /Library/PackageCache/com.unity.2d.animation@2.0.0-preview.1/Runtime/SpriteSkinUtility.cs(214,38): error CS1061: Type `UnityEngine.Sprite' does not contain a definition for `GetBoneWeights' and no extension method `GetBoneWeights' of type `UnityEngine.Sprite' could be found. Are you missing an assembly reference?
    I got "2d Animation" ver : 2.0.0 , according to my Package manager it's the latest version.
    Anyone can help ?
     
    Flurgle likes this.
  2. DavidErosa

    DavidErosa

    Joined:
    Aug 30, 2012
    Posts:
    37
    The announcement post says that...

    > Animation V2 is designed to work with 2018.3 and is currently incompatible with any other version (this includes 2019.1).
     
  3. Leo-Yaik

    Leo-Yaik

    Unity Technologies

    Joined:
    Aug 13, 2014
    Posts:
    79
    We are working on the 2019.1 upgrade and will be releasing it very soon. Stay tune!