Search Unity

  1. Get all the Unite Berlin 2018 news on the blog.
    Dismiss Notice
  2. Unity 2018.2 has arrived! Read about it here.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  4. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  5. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  6. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Official Unity 2018.2 is now available

Discussion in 'Announcements' started by Jacob_Unity, Jul 10, 2018 at 1:02 PM.

  1. Jacob_Unity

    Jacob_Unity

    Unity Technologies

    Joined:
    Jan 2, 2017
    Posts:
    183



    Unity 2018.2 is now available on the download page.

    Read the blog post for full details.

    Scriptable Render Pipeline (SRP) improvements
    • SRP batcher
    • Scriptable shader variants stripping
    • Lightweight Render Pipeline
    • High Definition Render Pipeline (Preview)
    Progressive Lightmapper
    • Configurable baked light falloff
    • Instanced albedo and emissives for precomputed lighting
    • Additive scene lighting warnings
    Shader Graph (Preview)
    • High Definition Render Pipeline (HDRP) support
    • Vertex position
    • Master node settings
    • Property reference names and exposed state
    • Editable paths for graphs
    • Is Front Face node
    • Gradient nodes
    • Texture3D and Texture2D Array
    • Texture 2D LOD node
    • Show Generated Code
    Vulkan support for Editor on Windows and Linux (experimental)
    Texture Mipmap Streaming
    C# Animation Jobs
    Particle System improvements


    2D
    • Pixel Perfect Camera (Preview package)
    • 2D Sprite Renderer Sort by Pivot Point
    • 2D Hexagonal Tilemaps
    • SVG Importer (Preview package)
    • New 2D APIs
    Editor - General
    • Support for using .java and .cpp source files as plugins in a Unity project
    • Standard Assets depreciation
    • Unity Hub
    Cinematics
    • Camera Physical Properties
    • Recorder 1.0
    Core Engine
    • Removal of the old RakNet-based networking feature
    • Addressable Asset System
    • High-DPI monitor support
    C# Job System, Entity Component System and Burst Compiler
    • Entity Component System (ECS)
    • Burst Compiler
    IL2CPP-Managed Debugger
    Scripting runtime improvements in Unity 2018.2
    ARM64-bit support for Android
    APK splitting by architecture
    Google Play Instant Games Plugin
    C# Platform Certificate Store Synchronization
    End of support for UnityScript
    Visual Studio Code Debugger Extension


    XR
    • HoloLens Holographic Remoting
    Remember to back up your projects before downloading the latest version of Unity. If you encounter any issues, please let us know by submitting a bug report so it can reach our developers. Future patch releases for fixes will be found here.

    Thanks again to all the users who helped with testing and giving us feedback on 2018.2 while it was in beta! Notice that we’ve locked the 2018.2 beta forum, so please create your new threads in the appropriate sections of the Forum.
     
    Last edited: Jul 10, 2018 at 1:16 PM
  2. ikisarov

    ikisarov

    Joined:
    Mar 17, 2015
    Posts:
    1
    Hello!
    I ran into a problem. Unity 2018.2, working with a laptop, has stopped correctly scaling the editor's interface, now I have all the items increased, because of this it is not convenient to work. In previous versions, everything was fine. Is it possible to somehow adapt the interface manually?
     
  3. Jes28

    Jes28

    Joined:
    Sep 3, 2012
    Posts:
    205
    I have a bug

    .../Unity/cache/packages/packages.unity.com/com.unity.postprocessing@2.0.7-preview/PostProcessing/Runtime/PostProcessLayer.cs(9,39): error CS1070: The type `UnityEngine.XR.XRSettings' has been forwarded to an assembly that is not referenced. Enable the built in package 'VR' in the Package Manager window to fix this error.

    First: I dont install postprocessin into project so it is bug by itself
    Second: PostProcess must not have dependency over vr module so it is bug too
    Third: It must be not possible to disable package that other packages depend upon
    Fourth: Unity 2018.2 bug reporter dont opens so I can not report this bug in correct way.
     
  4. Rennan24

    Rennan24

    Joined:
    Jul 13, 2014
    Posts:
    25
    Here's to another Unity Release! :D Thank you guys for all your hard work at making this one of the best engines out there. There's still some bugs and problems to fix, but I can't wait for the newer versions of Unity to come and some of the new features, such as ECS, Nested Prefabs, Burst, and many more!
     
  5. SevenPointRed

    SevenPointRed

    Joined:
    Feb 3, 2016
    Posts:
    74
    The new processing for PSDs makes everything look awful.
    Please make the removal of the "white matte" optional on the importer.
     
    Rennan24 likes this.
  6. hurleybird

    hurleybird

    Joined:
    Mar 4, 2013
    Posts:
    31
    I've found a bit of an issue with this release.

    Seems like it adds the TMPro package when upgrading a project.

    But this creates issues when a project already has the paid version of TMPro, which is incompatible with the package IIRC (otherwise I would have switched to the package long ago, since the paid version is a constant headache when it comes to moving to newer version of Unity). Having both versions creates compile errors as one would expect.

    Which shouldn't be a big deal. One might think that you could just open up the package manager and remove the TMPro package. One would be wrong. Initial compile errors seemingly need to be resolved before the package manager becomes visible. Since packages can cause compile errors, this seems like a generally unwise implementation.

    Tried manually editing packages/manifest.json to remove TMPro package, but that didn't work either. I'll try removing the paid version, then the package, then placing the paid version again... and hopefully that should work... but in general the package manager should always be available to avoid scenarios like this.

    EDIT: Correction, manually editing packages/manifest.json works.
     
    Last edited: Jul 10, 2018 at 11:02 PM
  7. nepoez

    nepoez

    Joined:
    Sep 11, 2011
    Posts:
    198
    I started getting this error and the game just crashes without proper errors:

    07-10 20:09:40.970 15588 15607 W google-breakpad: ### ### ### ### ### ### ### ### ### ### ### ### ###
    07-10 20:09:40.970 15588 15607 W google-breakpad: Chrome build fingerprint:
    07-10 20:09:40.970 15588 15607 W google-breakpad: 67.0.3396.87
    07-10 20:09:40.970 15588 15607 W google-breakpad: 339608700
    07-10 20:09:40.970 15588 15607 W google-breakpad: ### ### ### ### ### ### ### ### ### ### ### ### ###
    07-10 20:09:40.981 15588 15607 E CRASH : signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000000
    07-10 20:09:40.981 15588 15607 E CRASH : *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
    07-10 20:09:40.981 15588 15607 E CRASH : Build fingerprint: 'lge/lv1_crk_us/lv1:6.0.1/MXB48T/170121646eb68:user/release-keys'
    07-10 20:09:40.981 15588 15607 E CRASH : Revision: '0'
     
  8. SevenPointRed

    SevenPointRed

    Joined:
    Feb 3, 2016
    Posts:
    74
    Remove it from the cache, its somewhere in c:/users/bob/appdata/local etc, i cant remember where but i had this issue and had to manually remove it.
     
  9. Gray_Master

    Gray_Master

    Joined:
    Jun 20, 2010
    Posts:
    97
  10. SpencerPDX

    SpencerPDX

    Joined:
    Jan 3, 2012
    Posts:
    128
    In the beta version of this release I was able to use the Package Manager to remove the new version of TMPro so as to not conflict with my old one, and I believe that Package Manager was available under the Windows menu. I am not seeing it there now. Unity: Has the Package Manager been removed, or is it located somewhere different?

    In the meantime @hurleybird I'll try editing manifest.json, and thanks for the suggestion.
     
  11. MythrilMan51

    MythrilMan51

    Joined:
    Apr 24, 2017
    Posts:
    55
  12. SevenPointRed

    SevenPointRed

    Joined:
    Feb 3, 2016
    Posts:
    74
  13. SpencerPDX

    SpencerPDX

    Joined:
    Jan 3, 2012
    Posts:
    128
    Forgot to look into it, wasn't expecting it, but after updating I happened to hit the spacebar to start a Timeline playing, and what do I hear? Audio track preview!

    THANK YOU. So helpful.
     
  14. hurleybird

    hurleybird

    Joined:
    Mar 4, 2013
    Posts:
    31
    My experience is that preview 12 of the IncrementalCompiler package just doesn't work on 2018.2.0, so I'm guessing that's your issue. Because of the "Can't open package manager before compile errors are resolved" oversight, you'll need to edit package/manifest.json manually. Either to point to a different version of the IncrementalCompiler, or just remove the reference to it and load a different version via the Package Manager if you want. Preview 11 seems to work fine for me.
     
  15. technicat

    technicat

    Joined:
    Nov 22, 2006
    Posts:
    1,220
    Maybe you’ve resolve this already, but I’ve found with a couple of projects after upgrading to 2018.2 that the Package Manager was missing from the Windows menu if there was a compiler error (in my case specifically code that depended on the legacy particle system) but when I exited and restarted the Editor with the same project, the Package Manager option was back.