Search Unity

  1. Engage, network and learn at Unite Austin 2017, Oct 3 - 5. Get your ticket today!
    Dismiss Notice
  2. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  3. Check out all the fixes for 5.6 on the patch releases page.
    Dismiss Notice
  4. Unity 2017.1 is now released.
    Dismiss Notice
  5. Unity 2017.2 beta is now available for download.
    Dismiss Notice

Unity 2017 compatibility

Discussion in 'Vuforia' started by eco_bach, Sep 14, 2017.

  1. eco_bach

    eco_bach

    Joined:
    Jul 8, 2013
    Posts:
    773
    I've had compatibility issues with Vuforia and latest Unity 2017 beta and have had to revert to Unity 5.6

    Have these issues been addressed yet?
     
    Last edited: Sep 14, 2017
  2. Vuforia-Strasza

    Vuforia-Strasza

    Official Vuforia Employee Vuforia

    Joined:
    Jun 13, 2017
    Posts:
    9
    Hi eco_bach,
    Can you be more specific about what sort of compatibility issues you're facing?
    Thanks!
     
  3. vad710

    vad710

    Vuforia

    Joined:
    Dec 22, 2013
    Posts:
    4
    @eco_bach - Vuforia 6.2 is not compatible with 2017.1 - you should use 5.6. If you want to use 2017.x version, you need to use 2017.2 (which is currently beta) which comes with Vuforia built-into unity.

    EDIT: Fixed a typo in the version
     
    Last edited: Sep 14, 2017
  4. eco_bach

    eco_bach

    Joined:
    Jul 8, 2013
    Posts:
    773
    I should clarify, the issue seems to be with the Unity beta, just installed 2017.1.1f1 and the legacy Vuforia package 6.2.10. Works fine.
    For production work involving Vuforia, what is the recommendation? Go with latest Unity beta or?? I've had mixed results with beta versions of Unity in the past.
     
  5. Vuforia-Strasza

    Vuforia-Strasza

    Official Vuforia Employee Vuforia

    Joined:
    Jun 13, 2017
    Posts:
    9
    Unity 5.6 with Vuforia 6.2.10 is the current recommended build, but it will be Unity 2017.2 and the native Vuforia 6.5 when they are out of beta. I would avoid 2017.1 for work with Vuforia 6.2.10 as you may encounter issues.
     
    dcordero-ptc likes this.