Search Unity

Question Unecpected delay occured, When camera cut in to Cinemachine blend list camera

Discussion in 'Cinemachine' started by amenonegames, Sep 25, 2023.

  1. amenonegames

    amenonegames

    Joined:
    Nov 10, 2021
    Posts:
    19
    I am using some virtual cameras in the scene.
    I set the priority of one camera to 100, and others to 0 on game start.
    And when text start, Script change the another camera priority set to100, And others to 0 (include the first live camera).

    If second camera is blend list camera, Blend start is delay from when camera cut in. In spite of Brain's Default blend is Cut, Custom Blend is none, and Blend list camera's child hold setting is all 0.
    I want to immidiatly blend start on camera cut in.

    Shold I run some method, like update cameara?

    *virtual camera gameobject is deactive normaly.
    Just before priority set 100, script set gameobject active.
    this is to reduce cinemachine processing load.

    _my environment _
    Unity 2022.3.4f1
    Cinemachine 2.9.7

    _Screenshot_
    upload_2023-9-26_5-11-42.png

    upload_2023-9-26_5-14-4.png
     
    Last edited: Sep 25, 2023
  2. amenonegames

    amenonegames

    Joined:
    Nov 10, 2021
    Posts:
    19
    It was a simple matter; I solved it by simply setting the EaseTime of the first camera in ChildCamera to 0.

    I had misunderstood that it was an item that only applied the first time it return in the loop ,I thought.
    Because it apear when I checked Loop.

    It was a value that was also applied when you first cut in.

    Thank you.
     
    antoinecharton likes this.