Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Bug Unable to run project in play mode or build on iMac w/ Bootcamp

Discussion in 'Editor & General Support' started by infinitejess, Nov 29, 2023.

  1. infinitejess

    infinitejess

    Joined:
    Jan 29, 2019
    Posts:
    13
    Been wrestling with this problem for a couple days now. I recently bought four 2015 iMacs to make an installation for an art fair. My plan is to run a build of the game on each computer. My team is more comfortable with Windows so we decided to bootcamp the iMacs to windows 10. They have Intel Pro Iris 6200 GPUs (worried this might be the issue). They aren't amazing computers but they run reasonably well until I get to Unity. The game is Unity version 2022.3.4f1 and uses HDRP.

    When I run a build of the game, I get through the initial main menu and a fairly long cutscene. But after that, when the gameplay is supposed to initiate, the screen goes black and eventually times out/crashes. Similarly, I can open the project in the Unity editor and see everything in the scene view, although it takes several minutes to open the project each time. But when I try to enter play mode, or click on the Game view tab, Unity crashes. When the editor crashes, I get the familiar "Failed to present D3D11 swapchain due to device removed" error popup. I've researched all of this pretty extensively and tried several fixes:

    - checked graphics drivers, they're up to date
    - ran the project on 2022.3.14 (lts)
    - changed my TdrDelay value from 2 to 60
    - deleted about 75% of the entities in the scene
    - instructed windows antivirus not to run against unity.exe
    - applied High Performance graphics settings (in windows settings) to unity.exe
    - tried forcing directx 12 instead of 11

    and I keep hitting the same issue. I was reading some concerning old posts about the Intel Iris processors not being able to run HDRP, which would be disastrous for me as I already bought four computers and the art fair is in 4 days. I thought I did enough research about these models but never saw anything about this issue until digging much deeper.

    I'm going to try running a mac build to see if it works on the mac partition, will update with results. I'm also going to see if I can run an empty new project and one in HDRP to try to help localize the issue.

    Any help would be deeply appreciated!