Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug Unable to build to android when using the shader graph for Built-in render pipeline

Discussion in 'Editor & General Support' started by Jewonu, Aug 4, 2022.

  1. Jewonu

    Jewonu

    Joined:
    Aug 4, 2022
    Posts:
    3
    So I was using the shader graph in 2021.3.4f1 and it worked flawlessly in editor but when I started the build to android, first, the shader compilation was taking ages to complete and somehow i waited for it to complete after 50 mins and then it showed me some error. So, i made a new project and installed shader graph and made this very simple scene and my shader graph included only one "Color" property attached to albedo and when i started to build to android it gave me same error.

    now i have seriously no idea what to do, I am using Built in pipeline and shader graph was added to 2021.2 i guess and i am using 2021.3.4f1 so this should not be a problem.
    this is really frustrating i really need help, i literally rebuilt my project into built in pipeline as i came from URP because URP was so slow on android and gave me fps issues. and in built in pipeline there are no fps issues but this shader graph problem is really annoying. i have attached images for the more details.

    Steps to reproduce the error:
    1.) Create a new project with built in render pipeline (unity version must be higher than 2021.2)
    2.) install shader graph from package manager
    3.) create a new shader graph(lit)
    4.) Open shader graph and add a color property, and hook it up to Base color, Save Asset.
    5.) create a new material out of the newly created shader graph
    6.) assign a color to the material through the inspector window(any color other than white, not necessary either)
    7.) apply this material to 3d object(sphere or cube or anything)
    8.) build the project for android
    thats it.

    it should show the error
    Thanks Shader_graph.png Shader_error_console.png Shader_error_simple.png
     
    jkarlbauer likes this.
  2. edwon

    edwon

    Joined:
    Apr 24, 2011
    Posts:
    260
    exact same error for me
     
    jkarlbauer likes this.
  3. TeamSomebodyelse

    TeamSomebodyelse

    Joined:
    Sep 27, 2022
    Posts:
    1
    Hello, same here. The android build is working but the object is just pink (missing material). I'm working with VR.