Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Unable run the Editor without a desktop environment in batchmode with nographics

Discussion in 'Linux Editor' started by pegedi1525, Jan 7, 2019.

  1. pegedi1525

    pegedi1525

    Joined:
    Jun 1, 2018
    Posts:
    1
    Hi All!

    I'm trying to set up an automatic test and build system listening to repository changes similar to Unity cloud or Jenkins. I have managed to "install" the editor and figured out the dependencies I needed but when I try to run the project the lecense activation fails on me with the following message:

    Initiating legacy licensing moduleDisplayProgressbar: Unity license
    Cancelling DisplayDialog: Failed to activate/update license. Timeout occured while trying to update license. Please try again later or contact support@unity3d.com
    This should not be called in batch mode.
    (Filename: /home/builduser/buildslave/unity/build/Editor/Platform/Linux/EditorUtility.cpp Line: 257)

    as a result of:

    ./Unity -batchmode -nographics -logFile /tmp/unity.log -serial xxxx -username xxxx -password xxxx

    I tried with the last version 2018.3 and both with CentOS 7 and Ubuntu 18.04 Minimal with the same result. I also tried with personal activation, tried moving the CACerts.pem file with no luck as well.

    If I run the same command in my dev maching wich has ubuntu 18.04 with Gnome it works just fine, so maybe the fact that I dont have a desktop environment is making unity fail for some reason.

    Have anyone made it work?

    Thanks!!