Search Unity

  1. How can our website serve you better? Give us your feedback. Take our survey and let us know.
    Dismiss Notice

UMA Power Tools Support (v. 2.9)

Discussion in 'Assets and Asset Store' started by UnLogick, Jan 7, 2014.

  1. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    UMA Power Tools v. 2.10 Released!
    Asset store link: UMA Power Tools
    • Updated to match UMA 2.10
    • Fixed: Fixed the demo scene
    Known problems:
    • There seems to be a problem with blendshapes, for facial animation and salsa.
    Enjoy!
     
  2. natsims

    natsims

    Joined:
    May 21, 2018
    Posts:
    5
    Thank you much for the update! I briefly had a problem but a restart fixed it. I'll keep it here for posterity if it's a clue for later, but I'm currently very happy. Sorry for the freakout, I've been working on this for like 168 hours straight. (Oh and kids and another job.)

    Temporary bug: When I Save[d] Character Prefabs now, my happy little UMA completely disappear[ed], both in the Editor preview and when playing. The hierarchy looks good but no visuals (though the materials and textures are still there).

    A restart and a retry (on Save Character Prefabs) fixed it.

    PS I'm excited to see some Pipeline goodies in the extensions folders!

    [I'm in Unity 2018.4.20 (I have to be as I'm building avatars for VRChat for a peace summit).
    macOS 10.15. UMA 2.10.]
     
    Last edited: Jun 16, 2020
  3. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Edit: Glad to hear it was temporary.
     
    Last edited: Jun 16, 2020
  4. natsims

    natsims

    Joined:
    May 21, 2018
    Posts:
    5
    Sorry, I tried to catch you — I'm pretty sure the problem was on my end, the dread Human Error™.

    One legit follow-up question that I'm trying to figure out as I prep these avatars for VRC — when you build the prefabs, is there any way to be able to Configure the Avatar like you can with an FBX import? I can go item by item in the folder hierarchy for the prefabbed UMA, but I'm not sure I'm catching everything.

    Let me know if (1) you have thoughts or (2) it's a pretty noob question but you have a place to point me to. When you have time. Cheers!
     
  5. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Not sure I follow what you want exactly. Each prefab should have a copy of the avatar generated by uma. Working with custom avatars in uma is possible but far from trivial. Essentially you have to do this in the blinds prior to generating the uma.

    Alternately you can use my fbx exporter to get an fbx that you can then import and use the avatar configuration as normal.

    Not sure I really answered your question.
     
  6. natsims

    natsims

    Joined:
    May 21, 2018
    Posts:
    5
    I think that does answer my question — sounds like it's quite difficult to directly configure the avatar framework in UMA. I was pondering the FBX route; I will try it tonight. Thanks again for your help & hard work. ‍
     
  7. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    If you have the full uma atlas from power tools prefab baking, I would toggle texture export off on the fbx export. Since Power Tools is aimed at unity it respects the shaders and all texture channels. In contrast my fbx exporter gives you the deferred diffuse, normals and specular (pbr) which is more limited but work with most third party tools.
     
  8. Thorgrem

    Thorgrem

    Joined:
    Aug 19, 2015
    Posts:
    4
    When I make an Uma with "Save Character Prefabs", there is no Mesh created for the new Uma and the Character is Invisible. Restart and retry (on Save Character Prefabs) doesn´t helped for me.
    Unity 2019.4.0f1
     
  9. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    I have the same problem as Thorgrem. Prefabs don't work, also in 2019.4.0f1. Restart doesn't fix it.

    The problem is the mesh is None:

    upload_2020-6-19_1-30-31.png

    There are no errors in the console.
     
  10. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    That sounds serious, my schedule has filled up and I don't expect to find time the coming week. But this will be fixed!
     
  11. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    I look forward to it being fixed. I've heard of some problems in the V2 Asset Pipeline so I thought I'd revert to V1. I'm afraid it didn't help :-(
     
  12. Bantichai

    Bantichai

    Joined:
    Nov 6, 2016
    Posts:
    130
    @UnLogick Is the scene bone baking issue fixed now and also will it work with other UMA races like Will B's male/female base 2.0 or is it only the default UMA races?
     
  13. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    My mind is blank, could be fixed or could be forgotten, how do you reproduce this issue?
     
  14. draverik

    draverik

    Joined:
    Feb 17, 2019
    Posts:
    19
    Hello,

    I bought you package FBX exporter (we use URP with unity 2019.4) and we have two problems:

    1. It dosn't export textures at all.
    2. Scale of exported objects are 10x smaller.

    It was very expensive package so I hope to get this working or refund.

    Best Regards,
    Damian
     
  15. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Hi Damian

    1. That sounds quite severe, I was already investigating an issue with the FBX exporter not exporting material color and was just about to post that fix when I saw this message, I'll be testing my new fixed version against 2019.4 to see if there are any problems.

    2. Fbx Scale is a constant problem, I have fixed the scale to match what Unity expects so that when you do a round trip you get the same back. All importers I know can adjust for scale, I did not add the capability to control fbx file scale manually.

    Please note this is the Power Tools support thread, the proper Fbx Exporter support thread is located here:
    https://forum.unity.com/threads/uni...-skinned-meshes-terrains-and-textures.434348/

    Regards,
    Joen - UnLogick
     
  16. draverik

    draverik

    Joined:
    Feb 17, 2019
    Posts:
    19
    I will go to this link - Contact form get me here :)

    Ok I will be waiting for update. About scaling - I export fbx -> and without any changes take it to my scene and models are 10x smaller.
     
  17. Bantichai

    Bantichai

    Joined:
    Nov 6, 2016
    Posts:
    130
    I just tested the Scene Bone Baking and I can't seem to save prefabs properly at all, I don't get a prefab just the UMA recipe. My previous issue with Scene Bone Baking was that it was not being enabled in the scene during runtime.

    If you could just test if bone baking works on your side and results in a prefab, that would be appreciated. I tested this on Unity 2019.2.21. I haven't been able to use your tool properly for over a year, the latest stable version for me was 2.7.

    Or do prefabs behave differently now? In the editor mode I can't see the prefab model at all, but once I place it into the scene it appears during runtime, is that how it is supposed to work now? Would get tricky with level design though if I can't see the prefabs in the editor mode.
     
    Last edited: Jun 30, 2020
  18. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
  19. Bantichai

    Bantichai

    Joined:
    Nov 6, 2016
    Posts:
    130
  20. p_hergott

    p_hergott

    Joined:
    May 7, 2018
    Posts:
    407
    anything on the can't save prefab thing? no mesh
     
  21. Bantichai

    Bantichai

    Joined:
    Nov 6, 2016
    Posts:
    130
    @UnLogick I know you are busy and I appreciate the existence of this tool, hoping you can solve this issue soon. Right now I'm still using 2.7 just to get by.
     
  22. SickaGamer

    SickaGamer

    Joined:
    Jan 15, 2018
    Posts:
    1,105
    Yeah i had the same issue with exporting to prefabs the UMA lost the colors on its slots.
     
  23. LECLERE

    LECLERE

    Joined:
    Jul 3, 2020
    Posts:
    2


    Hello, when I create a prefab everything is going well except that UMAMESH disappears and makes the prefab unusable. How to do? Think's
     
  24. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    @LECLERE see every message prior to yours for the last few weeks. Most are about the same issue. No word from @UnLogick on an ETA for a fix. But they have acknowledged the problem.
     
    Last edited: Jul 7, 2020
  25. LECLERE

    LECLERE

    Joined:
    Jul 3, 2020
    Posts:
    2
    hi,
    yes I saw the messages on it but since they were several years old I thought the problem solved :/
     
  26. FGDone

    FGDone

    Joined:
    Oct 21, 2019
    Posts:
    2
    Not years but days. I think you saw the joined day. Just have to wait until issues is solved sadly
     
  27. FGDone

    FGDone

    Joined:
    Oct 21, 2019
    Posts:
    2
    Still no ETA ?
     
  28. myth1991

    myth1991

    Joined:
    Jun 2, 2020
    Posts:
    4
    Hello. I have a problem like the picture. How do you think I can solve it?
     
  29. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    @FGDone, @LECLERE, @fgardler, @Bantichai, @SickaGamer, @p_hergott, @Thorgrem
    Apologies for not responding earlier, yet again I've been caught up with RL... on top I got the forum notifications F***ed up yet again. Clicking the Alert and then for whatever reason not reading to the bottom of the thread makes the forum decide I'm just behind and not give me more alerts. Normally that's ok but on these support threads it's a disaster.

    I'm making this my top priority right now.

    Edit: I just opened my old Upload 2019.4 Project, opened the DCS Random character scene, picked a char, saved prefab and got a clean repro... when you got the repro everything is trivial.
     
    Last edited: Jul 25, 2020
  30. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    You're using an old version of the UMA Power Tools with a version of UMA it doesn't support. The UMA Power Tools has a hard dependency on the UMA framework so whenever the UMA framework changes it can easily break the UMA Power Tools.

    The latest version of UMA Power Tools 2.10, works with UMA 2.10 and does not have these using statements. In some rare cases when you update through the asset store it misses some files, so if you updated to 2.10 and have these files it's an asset store error. Just remove the power tools from your project and import it again.
     
  31. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Good news for @FGDone, @LECLERE, @fgardler, @Bantichai, @SickaGamer, @p_hergott, @Thorgrem

    As stated above I got the repro... so finding out what went wrong was trivial from there. The fix is safe for all versions of Unity. I'm a bit baffled about when/how this broke but I'm fairly certain this is a unity version thing.

    For a hotfix go change PowerToolsRuntime.cs: lines 97-98 should look like this.
    Code (CSharp):
    1. for (int i = 0; i < originalUMAData.rendererCount; i++)
    2.   AssetDatabase.AddObjectToAsset(originalUMAData.GetRenderer(i).sharedMesh, prefab);
     
    Marc-Saubion likes this.
  32. Thorgrem

    Thorgrem

    Joined:
    Aug 19, 2015
    Posts:
    4
    Thank you very much, all is now working.
     
    UnLogick likes this.
  33. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    I can confirm that the prefab fix works - thanks.

    However, the two characters have completely different skin tones and clothing colours - UMA Dynamic Avatar on the right and a prefab on the left
     
  34. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    upload_2020-7-31_23-6-49.png
    and with clothes:
    upload_2020-7-31_23-9-26.png
     
  35. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    Possibly related, this error is thrown when creating the prefab upload_2020-7-31_23-10-33.png
     
  36. hopeful

    hopeful

    Joined:
    Nov 20, 2013
    Posts:
    5,371
  37. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Yeah, that does look like a gamma vs linear problem. Going forward I'll try to do support every Tuesday, I'll try to run it in both Gamma and Linear to see if I can reproduce.
     
  38. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    Maybe. My project is in the Linear color space but the prefab was captured in Linear too (in the same scene in fact). I'm not sure if this is relevant to the issue you think you can see, but maybe the info will help you track down the problem (on a forthcoming Tuesday ;-)
     
  39. Silly_Rollo

    Silly_Rollo

    Joined:
    Dec 21, 2012
    Posts:
    499
    When trying to create a prefab I get this error message
    Code (CSharp):
    1. NullReferenceException: Object reference not set to an instance of an object
    2. UnityEngine.UIElements.UIR.TextureBlitter.BeginBlit (UnityEngine.RenderTexture dst) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    3. UnityEngine.UIElements.UIR.TextureBlitter.BlitOneNow (UnityEngine.RenderTexture dst, UnityEngine.Texture src, UnityEngine.RectInt srcRect, UnityEngine.Vector2Int dstPos, System.Boolean addBorder, UnityEngine.Color tint) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    4. UnityEngine.UIElements.UIRAtlasManager.UpdateAtlasTexture () (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    5. UnityEngine.UIElements.UIRAtlasManager.Commit () (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    6. UnityEngine.UIElements.UIR.RenderChain.ProcessChanges () (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    7. UnityEngine.UIElements.UIRRepaintUpdater.Update () (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    8. UnityEngine.UIElements.VisualTreeUpdater.UpdateVisualTreePhase (UnityEngine.UIElements.VisualTreeUpdatePhase phase) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    9. UnityEngine.UIElements.Panel.UpdateForRepaint () (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    10. UnityEngine.UIElements.Panel.Repaint (UnityEngine.Event e) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    11. UnityEngine.UIElements.UIElementsUtility.DoDispatch (UnityEngine.UIElements.BaseVisualElementPanel panel) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    12. UnityEngine.UIElements.UIElementsUtility.UnityEngine.UIElements.IUIElementsUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr, System.Boolean& eventHandled) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    13. UnityEngine.UIElements.UIEventRegistration.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    14. UnityEngine.UIElements.UIEventRegistration+<>c.<.cctor>b__1_2 (System.Int32 i, System.IntPtr ptr) (at <cdec8475f3524a2780f0322b5e8bd8da>:0)
    15. UnityEngine.GUIUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr, System.Boolean& result) (at <2500dd078a544a69b6c923861af6cd15>:0)
    I'm not familiar enough with UMA to really know what is going on here. I was actually hoping to use power tools to be able to largely ignore UMA since I don't need much of UMA's runtime features. This is on 2020.1 and using URP

    The prefab is saved but it has no mesh. I might be doing something wrong since I couldn't find updated docs
     
  40. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Right, the callstack is a side effect so that wont help us. Luckily the primary symptom of prefab not having a mesh... well I solved that around two weeks ago.
    Please apply this hotfix and you should be good to go.
     
  41. Silly_Rollo

    Silly_Rollo

    Joined:
    Dec 21, 2012
    Posts:
    499
    Ooops I thought I had added that above code but must've forgot. Thanks!

    I do get that weirdness like the poster above with prefabs darker than they should be.
    upload_2020-8-11_16-48-54.png

    The mesh is created fine but I also get the same console error

    However, the created texture actually seems to be proper. I didn't know if there could be any weirdness with vertex colors but I'm running a custom shader there with no vertex colors and it's still off. Normals seem fine so I dunno.
     
  42. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    Hmm, that is very weird, but I think you're right it's the same issue as @fgardler. If either of you could send me clear repro steps (or a project) that would help. If not I'll try to investigate when I find time.
     
  43. fgardler

    fgardler

    Joined:
    Jun 11, 2016
    Posts:
    62
    Repro steps:

    * New Scene
    * Add plane
    * Standard DCS Avatar (no recipes, no changes in parameters)
    * Play
    * Save as Prefab

    For me this has been done in an existing project that is set to Linear. If you cannot repro then maybe there is something in my project that is unique and I can try in a new project for you.

    Also, do note the error after my post above. I have no idea if this is related or not, but it seems like it might be.
     
  44. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    ok, I followed your steps and got a repro.

    After verifying my texture export I realized the problem isn't the capture... but rather the import... a part of my code intentionally sets the importer to sRGB, I can't remember why I specifically added that, but reverting that solves the problem.

    Please apply this hotfix to PowerToolsRuntime.cs: line 127 should look like this.
    Code (CSharp):
    1. ti.sRGBTexture = false;
    As mentioned I put the other line there on purpose, so this might produce other artifacts, please keep a lookout for secondary channels like emission, ambient occlusion, subsurface scattering or what not. However I think the hotfix is more correct and was probably me trying to compare prefabs made with Linear vs Gamma results, which probably isn't the best idea anyway.

    Edit: Ping @Silly_Rollo
     
    fgardler likes this.
  45. Simon-R

    Simon-R

    Joined:
    Mar 29, 2014
    Posts:
    11
    I appear to be getting the same issue other folks have reported - the prefab that's saved does not render. I have the latest version of UMA and Power Tools, on a clean project. Suggestions?
     
  46. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    There is a hotfix for the issue.
    I plan to release the fix properly "soon(tm)"
     
  47. Simon-R

    Simon-R

    Joined:
    Mar 29, 2014
    Posts:
    11
    You'll be a rich man if you can patent that ;)
     
  48. UnLogick

    UnLogick

    Joined:
    Jun 11, 2011
    Posts:
    1,740
    UMA Power Tools v. 2.10.1 Released!
    Asset store link: UMA Power Tools
    • Compatible with UMA 2.10 and UMA 2.10.1
    • Fixed: Prefabs Missing Mesh
    • Fixed: Prefabs in Linear Color Space
    Known problems:
    • Salsa's UMA support requires UMA and so it doesn't work for prefabs!
     
    fgardler likes this.
  49. Bantichai

    Bantichai

    Joined:
    Nov 6, 2016
    Posts:
    130
    @UnLogick Just wanted to ask, is cloth material supported now? For things like capes etc.
     
  50. bashmuttons

    bashmuttons

    Joined:
    Dec 7, 2011
    Posts:
    4
    I'm having some issues when trying to export using the FBX Exporter tool. So far I've been able to successfully bring some FBXs into Maya and they work great, but a lot of objects in my scene are throwing NullReferenceExceptions. This has been happening both with Export Full Scene as well as selecting a handful of objects and choosing Export Selected Object(s) as a Single FBX. I just purchased this today so I'm not sure if I'm using it incorrectly. Hope someone can help!

    I'm working in version 2020.1.4f1.4412 Personal
    Revision: 2020.1/staging fa717bb873ec
    If I should roll back let me know and I can try that.

    Here is the console readout:


    NullReferenceException: Object reference not set to an instance of an object
    UnLogickFactory.FbxLODScheme._GetRenderers (UnityEngine.LODGroup lodGroup, UnLogickFactory.FbxExportCollection result, UnLogickFactory.FbxExportSettings settings) (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/FbxLODScheme.cs:125)
    UnLogickFactory.FbxLODScheme.GetRenderers (UnityEngine.LODGroup lodGroup, UnLogickFactory.FbxExportCollection result, UnLogickFactory.FbxExportSettings settings) (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/FbxLODScheme.cs:50)
    UnLogickFactory.UnityFbxExporterBinding.RecursiveAddTransforms (UnityEngine.Transform bone, System.IntPtr fbxBone, UnLogickFactory.FbxExportCollection result, System.Boolean rootLevel, UnLogickFactory.FbxExportSettings settings, System.Boolean belowLODGroup) (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/UnityFbxExporterBinding.cs:883)
    UnLogickFactory.UnityFbxExporterBinding.RecursiveAddTransforms (UnityEngine.Transform bone, System.IntPtr fbxBone, UnLogickFactory.FbxExportCollection result, System.Boolean rootLevel, UnLogickFactory.FbxExportSettings settings, System.Boolean belowLODGroup) (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/UnityFbxExporterBinding.cs:949)
    UnLogickFactory.UnityFbxExporterBinding.ScanHierarchy (UnityEngine.Transform rootBone, System.Boolean createRoot, UnLogickFactory.FbxExportSettings settings) (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/UnityFbxExporterBinding.cs:864)
    UnLogickFactory.FbxExporter.Export (System.String filename, UnLogickFactory.FbxExportSettings settings, UnityEngine.Transform[] roots) (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/FbxExporter.cs:150)
    UnLogickFactory.FbxExporterWindow.OnGUI () (at Assets/Plugins/UnLogickFactory/FbxExporter/Scripts/Editor/FbxExporterWindow.cs:220)
    UnityEditor.HostView.InvokeOnGUI (UnityEngine.Rect onGUIPosition, UnityEngine.Rect viewRect) (at <3b1af5075b0340cfb428dfcef292b2ea>:0)
    UnityEditor.DockArea.DrawView (UnityEngine.Rect viewRect, UnityEngine.Rect dockAreaRect) (at <3b1af5075b0340cfb428dfcef292b2ea>:0)
    UnityEditor.DockArea.OldOnGUI () (at <3b1af5075b0340cfb428dfcef292b2ea>:0)
    UnityEngine.UIElements.IMGUIContainer.DoOnGUI (UnityEngine.Event evt, UnityEngine.Matrix4x4 parentTransform, UnityEngine.Rect clippingRect, System.Boolean isComputingLayout, UnityEngine.Rect layoutSize, System.Action onGUIHandler, System.Boolean canAffectFocus) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, UnityEngine.Matrix4x4 worldTransform, UnityEngine.Rect clippingRect, System.Action onGUIHandler, System.Boolean canAffectFocus) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, System.Action onGUIHandler, System.Boolean canAffectFocus) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.IMGUIContainer.HandleIMGUIEvent (UnityEngine.Event e, System.Boolean canAffectFocus) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.IMGUIContainer.SendEventToIMGUIRaw (UnityEngine.UIElements.EventBase evt, System.Boolean canAffectFocus, System.Boolean verifyBounds) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.IMGUIContainer.SendEventToIMGUI (UnityEngine.UIElements.EventBase evt, System.Boolean canAffectFocus, System.Boolean verifyBounds) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.IMGUIContainer.HandleEvent (UnityEngine.UIElements.EventBase evt) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.CallbackEventHandler.HandleEventAtTargetPhase (UnityEngine.UIElements.EventBase evt) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.MouseCaptureDispatchingStrategy.DispatchEvent (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcher.ApplyDispatchingStrategies (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel, System.Boolean imguiEventIsInitiallyUsed) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcher.ProcessEvent (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcher.ProcessEventQueue () (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcher.OpenGate () (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcherGate.Dispose () (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcher.ProcessEvent (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.EventDispatcher.Dispatch (UnityEngine.UIElements.EventBase evt, UnityEngine.UIElements.IPanel panel, UnityEngine.UIElements.DispatchMode dispatchMode) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.BaseVisualElementPanel.SendEvent (UnityEngine.UIElements.EventBase e, UnityEngine.UIElements.DispatchMode dispatchMode) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.UIElementsUtility.DoDispatch (UnityEngine.UIElements.BaseVisualElementPanel panel) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.UIElementsUtility.UnityEngine.UIElements.IUIElementsUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr, System.Boolean& eventHandled) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.UIEventRegistration.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.UIElements.UIEventRegistration+<>c.<.cctor>b__1_2 (System.Int32 i, System.IntPtr ptr) (at <e11cddb636f444f68eec62123764f018>:0)
    UnityEngine.GUIUtility.ProcessEvent (System.Int32 instanceID, System.IntPtr nativeEventPtr, System.Boolean& result) (at <2500dd078a544a69b6c923861af6cd15>:0)
     
unityunity