Search Unity

Bug UI Element shows up in Editor, iOS build but not Windows

Discussion in 'UGUI & TextMesh Pro' started by asaste0610, Jan 18, 2024.

  1. asaste0610

    asaste0610

    Joined:
    Jul 14, 2021
    Posts:
    3
    Unity Version: 2019.4.35

    I'm running into a frustrating issue where a specific UI element (small control panel with two buttons) refuses to show up in the Windows build, despite functioning perfectly fine in both the Game view and iOS build. Some additional details about my scene:
    • A prefab is loaded through a script and it contains more UI elements, but the sort order should place it behind the Canvas that contains the problematic UI.
    • There are other UI elements on the Canvas with the problematic UI that show up just fine.
    • The problematic UI element has its anchors properly set up.
    • The two canvases in the scene are set up as Screen Space - Overlay, Scale With Screen Size, Match Width or Height (Match 0).
    I've tried a lot of different potential fixes to no avail. The one thing I haven't tried yet is changing the reference resolution, though I'm not sure that would fix the problem and would require me to re-scale a lot of the UI elements (worked with 2048x1536 for iOS, now attempting 1221x916 for Windows). Anyone run into a similar issue or have any suggestions for a fix? Happy to provide more details if necessary.

    Thanks :)