Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

UI 4.6 mask not working in old project

Discussion in 'UGUI & TextMesh Pro' started by imandic, Dec 15, 2014.

  1. imandic

    imandic

    Joined:
    Mar 6, 2014
    Posts:
    31
    I have old project started in earlier version of Unity and I need to create mask which will hide part of panel.
    I'm creating new panel and canvas and panel is created. I create another panel as child of previous which is bigger then parent.
    After adding Mask script on parent panel, nothing happens.
    I have tried on existing scene but also tried to add new scene in this project but without success.

    But, if I create new project, everything working as expected.
    Also, everything is working just fine if I add those two panels and mask in example project (angry bots), so, something is wrong in my project.
    When I create canvas with two panels and mask and save scene in new project (which is working fine), and if I copy this scene to my existing project, mask stop working. Enabling or disabling mask has no effect.

    Can you advise me how to debug what is causing problem with mask only in old project.

    Thanks in advance, Ivan
     
  2. Tim-C

    Tim-C

    Unity Technologies

    Joined:
    Feb 6, 2010
    Posts:
    2,165
    Is your existing project set to iOS / Android mode? if so make sure the depth buffer is configured for 24 bit in the player settings. This is the most obvious think I can think of.
     
  3. imandic

    imandic

    Joined:
    Mar 6, 2014
    Posts:
    31
    Yes...
    Setting 24 bits and restarting Unity fix all issues...

    Thank you...