Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Our response to Improbable’s blog post (and why you can keep working on your SpatialOS game). Read more here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Ugly line on 360 stereo skybox

Discussion in 'AR/VR (XR) Discussion' started by Hunubul, Jan 9, 2019.

  1. Hunubul

    Hunubul

    Joined:
    Dec 17, 2018
    Posts:
    18
    Hey!
    --------------------------------
    EDIT: I made progression with this, but it's still not solved. See my post for the update, the short version is the line is still there, and I realized that it's texture bleed and still have no idea how to solve it completely. Still ugly in VR.
    --------------------------------
    I'm using the skybox panoramic shader that you need for 360 videos, but instead I use them for pictures.
    I mean it sounds pretty dope to get a 360 image as the skybox, and it looks pretty cool. The only problem is, at the edge of the picture where they meet there is an ugly line, and at the corners (top and bottom points) the picture is a bit blurry, and there is an ugly point as well at both locations.

    Color of it is blue, except where the image is blue itself, there the line is black.

    I tried the basics, like changing the picture wrap mode to clamp instead of repeat, but no change.

    There is an image of how it looks like. I tried changing everything here, and have no idea what else could I do.
     

    Attached Files:

    Last edited: Jan 10, 2019 at 3:50 PM
  2. Hunubul

    Hunubul

    Joined:
    Dec 17, 2018
    Posts:
    18
    So I tweaked a lot, and I still couldn't solve the issue, but made it less ugly by changing 2 settings:
    aniso Level
    Wrap mode -> clamp
    In script:
    texture.anisoLevel = 16;
    texture.wrapMode = TextureWrapMode.Clamp;


    There is a picture as well. The corner isn't blurry anymore, and the texture bleeding is much less.

    Can someone help me remove the remainder of the line?

    EDIT: It's still ugly in VR tho. Plz help.
     

    Attached Files: