Search Unity

Bug Ubuntu 14.04 crash on opening projects

Discussion in 'Linux Editor' started by mastermax001, Oct 7, 2015.

  1. mastermax001

    mastermax001

    Joined:
    Aug 9, 2012
    Posts:
    9
    Hi guys, i've used without any problem the linux experimental build until some days ago, but now, when i try to open a project, i directly get the bug reporter. I also tried to create a new project, both 3d and 2d, but this crash still happen.

    I've used the .deb package and reinstalled the latest version in the topic sticked in this section (and, of course, i've sent everything via bug reporter), but i was wondering that maybe could be some updates from ubuntu that conflict with unity.

    Anyone can give me any suggestion?
     
  2. mastermax001

    mastermax001

    Joined:
    Aug 9, 2012
    Posts:
    9
    Sorry again, anyone can explain me how to remove completely unity from ubuntu (not the project maybe)? So i can try with a fresh installation
     
  3. hipnotickid_12

    hipnotickid_12

    Joined:
    Jun 25, 2015
    Posts:
    12
    sudo apt-get remove unity-editor
    or
    sudo apt-get purge unity-editor

    usually some stuff dont need to be in your computer any longer so you can use sudo apt-get autoremove after you remove the editor
     
  4. mastermax001

    mastermax001

    Joined:
    Aug 9, 2012
    Posts:
    9
    Thanks for your reply, seems that unity conflict with some nvidia-driver (for me nvidia-current simply does not work).

    UPDATE:

    My editor log says:

    Any suggestions?
     
    Last edited: Oct 10, 2015
  5. hipnotickid_12

    hipnotickid_12

    Joined:
    Jun 25, 2015
    Posts:
    12
    Is Unity still installed? Are your drivers ok?
     
  6. Sabun

    Sabun

    Joined:
    Nov 13, 2012
    Posts:
    12
    I'm running the Nvidia 355.11 drivers since the beginning of the Linux build release until now and it's been working fine, so you're welcome to try this driver version as it seems stable (if it's not the one you're already using).

    Just out of curiosity, is your card a discrete graphics card (desktop), or an M card (laptop) or a hybrid card (iGPU + Nvidia)?
    It would also help to let us know what driver version you're using.

    You can check by opening the Nvidia X Server Settings program, and under X Server Information page it will show you the driver version number. Since you're on Ubuntu, just open the Ubuntu dash with the Windows key on your keyboard and search for 'Nvidia' if you're not sure where to find this program.
     
  7. mastermax001

    mastermax001

    Joined:
    Aug 9, 2012
    Posts:
    9
    Hi Sabun, thanks for your reply.

    I'm on a laptop (GTX 860M) and i've tried different drivers. Nice that you told me what are you successful using, since i was going to ask it! :)

    I'll try to use the driver that you told me and let you know if it works, many thanks!

    Edit:
    Just tried to use the 355.11 driver, still no luck for me

    Edit2:
    I just checked the editor log and now it says:
    gpu_process_transport_factory.cc(402)] Failed to establish GPU channel. I've already checked the permission on my .config folder, the drivers seems installed right (still the 355.11)
     
    Last edited: Oct 13, 2015
  8. IdleEchoes

    IdleEchoes

    Joined:
    Nov 2, 2014
    Posts:
    1
    Is it an optimus system? Are you using nVidia prime? Check that you're actually using the nVidia drivers as Ubuntu will default to Xorg.

    Windows key - Additional Drivers - ensure the NVIDIA binary driver is being used (you'll usualy have 2, use opensource)

    I'm using driver version 358.09 and it's also fine here =] hope that helps!

    As a side note - I had a weird issue with the licence throwing up that error. do a search and delete all .ulf files associated with Unity. you'll need to re-activate your licence, but everything else should work..
     
    Last edited: Nov 8, 2015
unityunity