Search Unity

Troubleshooting the Editor companion thread.

Discussion in 'Editor & General Support' started by Aurore, Aug 13, 2015.

  1. giantkilleroverunity3d

    giantkilleroverunity3d

    Joined:
    Feb 28, 2014
    Posts:
    84
    Aye lad. Tis an unfair tote of dinkum to belay the trifles of the enemy. I too have spent efforts and times to get to my project. Don't complain any further. You'll just catch a sh!t storm from the snowflake trolls. Submit a trouble ticket and hope for the best. I did and Unity support responded with an acknowledgement that the failure in my case was theirs. Now I wait. I have a lot of skin in game too. The new agenda is 'It's a social grace to help others make their product the best.' https://www.cbsnews.com/news/toyota-unintended-acceleration-has-killed-89/ . Tell these poor souls that... Morgue report states: Victim died due unintended acceleration. Are ya kiddin me? Yep. The perpetrator was buggy software.
     
    Last edited: Nov 20, 2017
  2. giantkilleroverunity3d

    giantkilleroverunity3d

    Joined:
    Feb 28, 2014
    Posts:
    84
    Performed update. Still no tools menu button.
    But I get this:
    upload_2017-11-21_20-5-53.png
     
  3. TenKHoursDev

    TenKHoursDev

    Joined:
    Nov 9, 2014
    Posts:
    1,089
    I'm having a problem with the editor.

    Specifically when I try to drag & drop or use the picker to assign references to my script fields they don't stay after the game has started.

    If I use the picker for an object in the assets folder I can't see the "scene" objects tab. If I try to drag and drop between them it just disappears and throws a null reference when used in game.

    Its really frustrating and strange. Will post video some time if anyone needs it.

    I am using Unity 2017.1.0p4 personal on Windows 10.
     
  4. Kleinmergi

    Kleinmergi

    Joined:
    Jan 1, 2018
    Posts:
    1
    Vuforia fatal error, Size overflow in allocator, Unity 2017.3.0f3

    Hello,
    I have an annoying problem with my Unity Editor.
    Every time I activate the Vuforia Augmented Reality support in the PlayerSettings, the editor crashes by starting the game mode and show a fatal error.
    I´ve already tried to reinstall the program and delete the cache files, without success.
    Also, the previous version 2017.2.0f3 behaves the same way.


    Thanks and a happy new year :)7


    I've solved the problem. It must correlated with my Webcam-Driver. I just have reinstalled it and all works fine again.
     
    Last edited: Feb 7, 2018
  5. TenKHoursDev

    TenKHoursDev

    Joined:
    Nov 9, 2014
    Posts:
    1,089
    Turns out the reason was that Unity separates assignable object reference between scene and assets. Ie. you can't assign a field a reference to something within the scene on a custom script. This is so because you would need some kind of instantiate or objectpooler to actually spawn an instance of the assigned value. I wish this were spelled out in tutorials more explicitly. But all is well!
     
  6. esteban16108

    esteban16108

    Joined:
    Jan 23, 2014
    Posts:
    77
    Hi, After installing Unity Hub my Unity instance doesn't load and eats all the memory and starts trashing to disk and then crashes, I have 16Gb ram, wasn't happening before installing Unity Hub :(

    I uninstalled Unity and Unity Hub and Re Installed Unity but still doing this, Can't open it can't work.

    Any clue on what can I do?

    Thanks.
     
  7. vertexx

    vertexx

    Joined:
    Mar 18, 2014
    Posts:
    39
    Is this thread for questions only?
    Is there anybody out there/here that actually answers these or what?
    Where does one go for an answer after posting a question? Or does one simply give up?
    Is there a "too hard" forum that we should visit?
    Is there another Forum on the Unity software that might be more helpful?
    I mean one NOT run by Unity?
     
  8. ST4H

    ST4H

    Joined:
    Mar 3, 2018
    Posts:
    1
    Please help ;__;
    upload_2018-3-3_1-12-31.png
     
  9. musicartslao

    musicartslao

    Joined:
    Nov 9, 2013
    Posts:
    13
    Hi! I am on 2017 3 version.
    After animating a crane carrying a container(with a RigidBody Component) along a track, and letting it drop after some frames, I got this error:
    "Non-convex MeshCollider with non-kinematic Rigidbody is no longer supported in Unity 5. If you want to use a non-convex mesh either make the Rigidbody kinematic or remove the Rigidbody component. Scene hierarchy path "craneTrack/crane/container/container 1", Mesh asset path "Assets/Models/Environment/container.FBX" Mesh name "container"
    But the animation works.
    what to do ? This is a RED warning.
    Thanks for any help!
     
  10. heroft23

    heroft23

    Joined:
    Nov 10, 2017
    Posts:
    1


    I have .net framework problem

    ".NET Framework Not Installed: Download and install .NET Framework 4.5 Developer Pack"

    But its installed, sometimes it works sometimes it doesn't. Do you have any idea?
    When I delete the "meta" files in assets. It fixes the problem. But later on it does the same thing. I couldn't really solve the problem fully.
    And when I try to open big projects from other people, deleting metas don't work either. If you have any idea please help.

    I don't really know if this is the right thread for it but sorry if its not
     
  11. TenKHoursDev

    TenKHoursDev

    Joined:
    Nov 9, 2014
    Posts:
    1,089
    I have a pretty good rig running Unity on Debian 9 right now but performance in the editor is terrible. Does anyone have any suggestions about how to improve/fix this? I have an AMD Ryzen processor, 16 GB RAM, and an AMD Radeon r7 370 GPU.
     
  12. costatroy44

    costatroy44

    Joined:
    Sep 9, 2015
    Posts:
    1
    help me please
     

    Attached Files:

  13. LSDv5

    LSDv5

    Joined:
    May 16, 2018
    Posts:
    1