Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

Troubles with Skeleton Tracking SDK for Intel Realsense from Cubemos

Discussion in 'Asset Bundles' started by chrispi_, May 26, 2020.

  1. chrispi_

    chrispi_

    Joined:
    Feb 20, 2019
    Posts:
    4
    At the moment i have got a trial version of the Skeleton Tracking SDK to figure out if its working as expected. I have ordered the realsense D435 camera and tried to get the Skeleton Tracking SDK running in Unity3D (2018.4.11f1). But i always get two error messages
    1. "DllNotFoundException: realsense2"
    2. "RealSense pipeline not initialized!"

    I tried the troubleshooting as explained in the added pdf.
    -> Rebooted System ... Nothing changed
    -> CUBEMOS_SKEL_SDK with the Path C:\Program Files\Cubemos\SkeletonTracking was already inserted to the systempaths so i additionally added CUBEMOS_SKEL_SDK\bin with the corresponding Path C:\Program Files\Cubemos\SkeletonTracking\bin
    This did not change anything, too.

    I have to mention, that the unity wrapper examples from realsense work. The exe files in the Cubemos Skeleton Tracking SDK bin directory are working too (when i start dem from the explorer). The realsenseviewer from INTEL is also working without any problems as far as i have tested it. I followed the installation instructions in the Cubemos Skeleton Tracking SDK Getting Started PDF, run post_installation.bat and followed the step with the result of "success".

    I really do not know what to do next.
    Can you please help me out and give me any advice to just get into testing this camera?

    Thanks in advance,
    Christine

    P.S. i am on win10 64
     
  2. abens

    abens

    Joined:
    Jul 15, 2020
    Posts:
    1
    Hi Christine,

    I had similar problems.
    I have Win 10 64, unity 2018.4.24, realsense D435 camera

    Unity Error:
    1. "DllNotFoundException: cubemos_engine"
    2. "RealSense pipeline not initialized!"

    I tried with unity 2018.4.11 - But that didnt solve anything

    Solution for me was:
    I found out from the link: https://software.intel.com/es-es/comment/1461574
    that I didnt have C:\\Program Files (x86)\\Common Files\\Intel\\Shared Libraries\\redist\\intel64\\compiler - in my environment variables.
    I also added CUBEMOS_SKEL_SDK\bin to the path

    So now I had next problem.

    Unity Error:
    1. [SkeletonTracker] Unable to load model from path C:\Users\poc\AppData\Local\Cubemos\SkeletonTracking\models\fp16\skeleton-tracking.cubemos Exception: cubemos Error"


    I found from link: https://support.intelrealsense.com/...Tracker-Loading-model-Exception-cubemos-Error

    that Skeletel tracker v 2.3.1 has this problem if you have external graphics card. Then i downloaded v 2.2.1 and installed it as specified in the link.

    Then I had the following problem.

    1. After installing v 2.2.1, post_intall.bat failed because plugin.xml was not found in the bin directory

    I copied the plugin.xml from bin folder of v 2.3.1 into bin folder of v.2.2.1

    Then post-installation was successful for the license part, but failed to generate visualstudio files.

    But that was ok for me. The exe applications in bin folder is not working. But atleast unity console is giving out values for the sample program from v.2.2.1

    I think Intel/Cubemos should find a way to get the sdk working in most hardware combinations. Anyhow, May be you might be having some other problems. I hope this gives some info.

    Cheers,
    Aben
     
  3. Rob-Clouth

    Rob-Clouth

    Joined:
    Jun 19, 2013
    Posts:
    3
    Hey,
    So the only way to get it working if you have an external GPU is use 2.2.1? Seems like a kind of crappy product.
     
unityunity