Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Trouble connecting to Accelerator

Discussion in 'Unity Accelerator' started by antifuzz, Jan 21, 2020.

  1. antifuzz

    antifuzz

    Joined:
    Feb 22, 2013
    Posts:
    99
    We have installed Accelerator installed on a Linux server, and the service appears to be running, but we can't seem to connect to it from Unity.

    Our development machines are Macs, and we can access the health page of the Accelerator in browser, and get this:
    {"version":"v0.1.595+g1be135e","up":"1h37m34.893435304s","load":0}

    .. so all looks good, but when we put the ip address (plus the ":80" port) into the asset pipeline v2 box in the Unity cache server preferences, Unity just begins beachballing and never comes back to life. If we don't include the port number, it simply says it can't connect.

    This is with Unity 2019.3.0f5.

    Any ideas how to diagnose the issue?
     
  2. hiepu3d

    hiepu3d

    Unity Technologies

    Joined:
    Jul 1, 2017
    Posts:
    64
    Hi @antifuzz , I'm sorry that the Unity Editor stopped working for you.

    From what you mentioned, port 80 is usually used for HTTP connection and it's the value of field LastUsedHTTPPort in the configuration file unity-accelerator.cfg . The port number that should be used for Asset Database Pipeline V2 is the value of field LastUsedProtobufPort in the configuration. Could you check if LastUsedProtobufPort is 80 as well? If not, please use that new port number to connect and let us know how it goes.
     
  3. antifuzz

    antifuzz

    Joined:
    Feb 22, 2013
    Posts:
    99
    Aha!
    LastUsedProtobufPort was set to 0
    ProtobufPort was set to 10080

    So we just set LastUsedProtobufPort to also be 10080 and now we can connect!

    Thanks @hiepu3d