Search Unity

Question Transparency Sort Mode not working properly with Tilemap

Discussion in 'Getting Started' started by walele993, Aug 9, 2023.

  1. walele993

    walele993

    Joined:
    Aug 9, 2023
    Posts:
    1
    Hey people,

    I hope you're all doing great! I'm reaching out to the community today because I've run into a bit of a snag with setting up the Transparency Sort Mode in Unity, and I'm hoping someone here might be able to lend me a hand.

    I've been working on a project where I need to manage transparency sorting for different layers, and despite my efforts, I've hit a roadblock. I've set the Transparency Sort Mode to "Custom Axis" and carefully organized all the layers as instructed, but I'm still facing an issue.

    To provide a bit more context, the sorting seems to be working smoothly between the "Main" character and the "Chest" object. However, I'm encountering problems when it comes to the "Tilemap" layer. The sorting doesn't seem to function as expected between the "Main" character and the elements within the "Tilemap".

    I've reviewed my settings and code multiple times, trying to figure out where I might have gone wrong. I've verified that the sorting layers are correctly configured, and the sorting order values seem appropriate. It's puzzling to me why the sorting works for some objects but not for the "Tilemap".

    I've done my due diligence in researching Unity's documentation and various forums, but I haven't been able to find a solution that addresses this specific issue. Since this community seems to be incredibly supportive, I thought it might be a good idea to seek advice or insights here.

    If anyone has faced a similar situation or has some experience with transparency sorting intricacies, I would greatly appreciate your input. It's possible that there's a small detail I've overlooked or a configuration step that I've misunderstood. Your assistance could help me move forward with my project and gain a better understanding of Unity's rendering pipeline.

    Thank you all so much for taking the time to read this post. I'm looking forward to any suggestions, tips, or solutions you might have to offer.

    P.S. Feel free to share any insights here or reach out to me directly if you prefer. Your help means a lot to me!

    Here you can find some screenshot:
    https://imgur.com/a/3bWehzB

    Transparency Sort Mode settings:
    MnpA3cM.png (1920×1080) (imgur.com)
    Main settings:
    JPQvGpP.png (1920×1080) (imgur.com)
    Tilemap settings:
    jLGH9RK.png (1920×1080) (imgur.com)
    Chest settings:
    cqI07J4.png (1920×1080) (imgur.com)
    Tilemap behaviour:
    VAcjCXE.png (1920×1080) (imgur.com)
    Chest behaviour:
    9MSRMjE.png (1920×1080) (imgur.com)
     
  2. cubhead

    cubhead

    Joined:
    Jul 11, 2021
    Posts:
    25
    Just chipping in to add that I'm having the exact same problem, and hopefully boosting the visibility of this thread. I checked all the pivots and layers, and everything is set up correctly, yet my player character still renders above the tilemap. Furthermore, up until a while ago the renderering was working completely as intended so either I changed something important by accident, or this is caused by updating to version 2023.1.8f1, wich I did just yesterday.
     
  3. cubhead

    cubhead

    Joined:
    Jul 11, 2021
    Posts:
    25
    Ok I figured it out. On the Tilemap you need to change the TilemapRenderer's Mode to individual. The update probably changed the default setting to chunk.