Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Bug "Too many additional punctual lights shadows to look good..." warning

Discussion in 'Universal Render Pipeline' started by JustinKlasnic, Sep 4, 2022.

  1. JustinKlasnic

    JustinKlasnic

    Joined:
    Jul 1, 2020
    Posts:
    18
    Hello, I have a relatively large number of lights in a scene and I get these warnings and debug logs. Is this bad? Is it possible to fix this?


     
  2. Sky77

    Sky77

    Joined:
    Jan 30, 2014
    Posts:
    172
    Reduce the numbers of real-time shadow casting lights. Real-time shadows are incredibly expensive, you should enable them on very few lights and only when necessary.
     
  3. JustinKlasnic

    JustinKlasnic

    Joined:
    Jul 1, 2020
    Posts:
    18
    All my lights in the scene are baked. If I had realtime lights i would have -20fps, I tested it
     
  4. Sky77

    Sky77

    Joined:
    Jan 30, 2014
    Posts:
    172
    I don’t know what to say, that message means that there are too many real-time casting point lights in the scene. If it’s not a bug Unity side, the only way to solve it is by reducing the number of real-time casting lights or up the shadow map resolution (but you’re already at 4096).
    You can find more informations in the URP documentation, but probably going over 3 or 4 real-time shadow point lights is enough to trigger the message.
     
  5. JustinKlasnic

    JustinKlasnic

    Joined:
    Jul 1, 2020
    Posts:
    18
    Hmm, I think its a unity bug? I only have 1 real-time light and that light is disabled. I will just ignore the message then...- Anyways thank you!
     
    Last edited: Sep 5, 2022