Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Tiny Build Without Lighting

Discussion in 'Project Tiny' started by vpsubz, Jan 22, 2022.

  1. vpsubz

    vpsubz

    Joined:
    Jul 18, 2019
    Posts:
    5
    Hello!

    I built a simple project for web. I set up definitions and parameters from documentation ("Setting up a New Project" chapter).

    Directional light did not work. (See screenshot below).

    What did I set wrong ? Where is error ? Can you explain?


    Tiny last version
    Unity 2020.1.17f1
    Windows 10
     

    Attached Files:

  2. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    676
    Any debug log/error? Light is working perfectly on my projects.
     
  3. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    676
    To have such result you must have black Ambient Color in Environment Lighting and have no directional light (or with a direction perpendicular to the camera)
     
  4. vpsubz

    vpsubz

    Joined:
    Jul 18, 2019
    Posts:
    5
    Directional light position is correct.
    Environment Lighting - light blue.

    No issues in console...
     
  5. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    676
    The only thing i can think of is that the conversion was not proper.
    Try clearing entities cache (Menu DOTS -> Clear Entities Cache(s)) to force new conversion and create a new build.
    Does it happen in all target platforms?
     
  6. vpsubz

    vpsubz

    Joined:
    Jul 18, 2019
    Posts:
    5
    Web or win - no matter...

    After cleaning cache/folders and rebuilds I got this (see screenshot below).
    It looks like only ambient light (skybox) works.

    Directional light still does not work....
     

    Attached Files:

    • 2.PNG
      2.PNG
      File size:
      13.2 KB
      Views:
      266
  7. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    676
    Can you share a sample project with that?
     
  8. vpsubz

    vpsubz

    Joined:
    Jul 18, 2019
    Posts:
    5
  9. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    676
    Oh Wow!
    I didn't realize that I had "AutoMovingDirectionalLigth" attached to my directional light. So try to add that and it should work.
     
  10. vpsubz

    vpsubz

    Joined:
    Jul 18, 2019
    Posts:
    5
    Thank you very much!

    I firgured it out. I attached that script and... turn on/off it a few times =))))

    It's so weird. Also sometimes my code and objects in scene do not work. But I didn't change anything... =)

    Cache cleaning has no effect

    After manipulations like "Add/remove Debug.Log" it works again.