Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Dismiss Notice

Bug Timeline and visual scripting packages are broken after Upgrading Unity to newer version.

Discussion in 'Timeline' started by mst3kninja, Nov 13, 2022.

  1. mst3kninja


    Aug 22, 2018
    Earlier this week, my work upgraded unity from 2021.3.1f1 to 2021.3.13f1. My coworker did this first and I pulled the changes (we are using Plastic SCM) I got these errors:


    I thought that it might be due to being on the wrong version of Unity so I installed the 2021.3.13f1 version and the errors were still there. I have done many different things to try and fix this, but the problem still persists. Here are some of the things I have already tried:

    • Re-imported both my Assets and Packages folders
    • Deleted the whole project and re-downloaded it
    • Reinstalled the new version of Unity
    • Reset packages to defaults
    • Used a replace my package cache file with a co-worker's
    • Used a different workspace and branch in Plastic.
    • Tried using an entirely different project (the problem persisted in all projects)
    • Deleted the project and re-created it through cloud saves
    • Removed both of the packages from the project via the package manager and installed them again (this actually removed the visual scripting error when the package was removed, but the timeline errors persisted)
    • Using an older version of unity.
    This apparently has not affected any of my co-workers and is only happening on my computer. I thought fresh installing EVERYTHING would fix it, but no.

    Thanks for the help.

    Attached Files: