Search Unity

  1. We would like to hear your feedback about Unity and our products. Click here for more information.
    Dismiss Notice

Bug Tile palette - Tiles not showing up [2018.1.0f2]

Discussion in '2D Experimental Preview' started by febucci, May 5, 2018.

  1. febucci

    febucci

    Joined:
    Sep 3, 2015
    Posts:
    18
    Hello!
    Since unity 2018.1.0f2 the tile palette doesnt show the tiles in it's window.

    upload_2018-5-5_22-15-29.png

    If this could help
    What I tried to do:
    • Creating new tile palettes
    • Creating new tiles
    • Reimporting all assets
    • Removing tile maps in the scene and adding new ones
    • Disabling and enabling the tilemap render component
    • Changing the grid cell swizzle
    • Closing and opening the tile palette window
    The tiles are present in the tile palette (the inspector shows me that if I click on their cell), but there is no preview.

    (The tiles are showed in the scene and there is their preview in the project window)

    Any suggestion?
    Thank you and have a nice day!
     
    Last edited: May 6, 2018
  2. alwayssmile11a1_unity

    alwayssmile11a1_unity

    Joined:
    May 6, 2018
    Posts:
    1
    I have the same problem. Hope it will be fixed soon.
     
  3. Ankh_P

    Ankh_P

    Joined:
    Jan 8, 2013
    Posts:
    6
    I have the same issue in 2017.4.2f2 (LTS).
    I noticed that the TilemapRenderer component of the layer in the palette object gets disabled automatically.
    I suppose this is the source of the problem, though I couldn't find a way around it.
     
  4. flapje

    flapje

    Joined:
    Feb 21, 2016
    Posts:
    1
    I have the exact same problem. Did anyone find a solution?
     
  5. febucci

    febucci

    Joined:
    Sep 3, 2015
    Posts:
    18
    I saw on the forum that Unity is aware of this bug and that it’s fixed in the 2018.2.b03 (I don’t know if in .b1 or .b2 it’s fixed too)
    I guess I’ll keep working whit the beta for now, since the stable version has that bug.

    Have a nice day!
     
  6. mattouBatou

    mattouBatou

    Joined:
    Sep 2, 2016
    Posts:
    7
    Hmmm, I moved my project (backed up before hand luckily) to 2018.2.b03 and it does indeed fix the Tile Palette not displaying correctly, however, it is an unstable version and so cannot be relied on for any meaningful work. I tried converting back to 2018.1.0f2 and my sprite prefabs all broke. I guess I'll paint blind until the next stable release with this fix.
     
    maryloulou likes this.
  7. DanarKayfi

    DanarKayfi

    Joined:
    Aug 27, 2012
    Posts:
    69
    Same issue :'(
     
    maryloulou likes this.
  8. Uios-Theou

    Uios-Theou

    Joined:
    May 10, 2018
    Posts:
    1
    Same problem as well. :/
     
  9. mattouBatou

    mattouBatou

    Joined:
    Sep 2, 2016
    Posts:
    7
    In 2018.2.0b3, when painting tiles, performance begins to drop in the editor as I fill a play area of 1920x1080px with 16x16px tiles on a single layer, 1 tilemap on the grid. My tile palette has 1722 16x16px tiles. The editor locks up completely when I fill around a 2kx2k px area of 16x16 tiles. As soon as I close the Tile Palette window, editor performance goes back to being silky smooth again. Is this a known issue?
     
  10. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    This will be fixed in 2018.1.2. The fixed version for 2017.4 LTS is pending.

    @mattouBatou The slowdown with the Tile Palette window open is not known. Could you send a bug report with a reproduction case? Thanks!
     
  11. mattouBatou

    mattouBatou

    Joined:
    Sep 2, 2016
    Posts:
    7
    I have reported the bug complete with my project files through Unity bug reporter. Is there anything I can do to link it here?
     
    Last edited: May 11, 2018
  12. mattouBatou

    mattouBatou

    Joined:
    Sep 2, 2016
    Posts:
    7
    "This will be fixed in 2018.1.2. The fixed version for 2017.4 LTS is pending."

    Any idea when to expect these updates?

    Edit:
    After seeing this issue https://issuetracker.unity3d.com/issues/editor-performance-degradation-when-working-with-big-tilemap (only has 6 votes so far).

    A comment mentions having your tilemap game object not be a prefab. I took my project with poor performance and broke the prefab instance of my tilemap object and performance is great now with the tilemap palette open.

    This should still be looked at as a bug since you should be able to have your tilemaps be prefabs right? For reuse etc. Perhaps it's not that big a deal, still learning Unity so maybe some more experienced devs can chime in on this.
     
    Last edited: May 12, 2018
  13. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    For the Tile Palette issue, an estimate for 2018.1.2 would be the end of next week (week of 21st May). 2017.4 is still pending, but hopefully will follow the estimate for 2018.1.2.
     
  14. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    Thanks! There should be a case number associated with the bug report, please do share that.

    If it is similar to the issue link you posted above, you could try temporarily breaking the prefab instance of the Tilemap prefab while you need to edit the Tilemap and relink it after edits?
     
  15. roseportalgames

    roseportalgames

    Joined:
    Aug 9, 2017
    Posts:
    111
    Any news?? I can't work like this....
     
  16. BartNT

    BartNT

    Joined:
    Sep 12, 2013
    Posts:
    12
    DanarKayfi, maryloulou and SuperNeon like this.
  17. arvzg

    arvzg

    Joined:
    Jun 28, 2009
    Posts:
    570
    It looks like it's mostly fixed in 2018.1.2, but I've seen the tiles in the palette disappear after a recompile. The only way to get them back again is to restart Unity. It's happened twice now. No way to reliably replicate the issue
     
    DanarKayfi likes this.
  18. Ho-seong

    Ho-seong

    Joined:
    Jun 21, 2018
    Posts:
    1
    I have the same problem.
    But this has not been resolved yet.
    Can I know when the problem can be solved?
    This is really important.
     
  19. DanarKayfi

    DanarKayfi

    Joined:
    Aug 27, 2012
    Posts:
    69
    It is fixed ... im using Unity 2018.1.5
     
  20. mlawal

    mlawal

    Joined:
    Aug 16, 2017
    Posts:
    1
    2D: Fixed Tiles not showing up visually on the Tile palette - Unity 2018.1.5. Disappeared after a few days of use.
     
  21. xrhstos3000

    xrhstos3000

    Joined:
    Feb 25, 2018
    Posts:
    2
    Hey I had just 1min before a similar problem. My TileMap was not refreshing properly even with Tilemap.RefreshAllTiles()
    What I did was instead of dragging and dropping the TileMap to inspector, I made the TileMap variable private and then did this on start up: Base_Tile_Map = GameObject.Find("Tilemap").GetComponent<Tilemap>();
    Now TileMap generates properly!

    I hope that helps some!

    EDIT: You can also do:

    Set Values:
    [SerializeField] GameObject Object_Tilemap;
    Tilemap Base_Tile_Map;

    Void Start
    Base_Tile_Map = Object_Tilemap.GetComponent<Tilemap>();
     
    Last edited: Jul 15, 2018
  22. jgeyer0000

    jgeyer0000

    Joined:
    May 7, 2018
    Posts:
    1
    I'm on 2018.1.0f2 and this is still broken.
    This is the first time I attempted to use tiles. Followed the tutorial on unity's site using their example project.

    If this feature doesn't work, it should be removed.
     
  23. Ellye

    Ellye

    Joined:
    Feb 13, 2014
    Posts:
    5
    2018.1.1f1

    Not working here, tiles doesn't show up in the palette window. Quite disappointing.
     
  24. Gigagrand-Dev

    Gigagrand-Dev

    Joined:
    Dec 8, 2014
    Posts:
    1
    I contacted Unity support and they told me to download the beta. It seems to be working in Unity 2018.2.0b2
     
  25. KhenaB

    KhenaB

    Joined:
    Aug 21, 2014
    Posts:
    267
    Can confirm that this still happens in 2018.1.6f1 and an editor restart seems to fix it.
     
  26. sarah22

    sarah22

    Joined:
    Aug 6, 2017
    Posts:
    7
    This happens to me in 2018.2.4f1 when I'm not using the sprite directly like, getting the sprite from the sprite atlas at runtime then press play, tile palette will not show.

    Any fix for this?

    Reproduction steps:
    1. Create a tile that fetches the sprite at runtime in UpdateTile method.
    2. Drag the tile on the palette.
    3. Press play, all your tiles in palette are not showing.

    Are the any plans on releasing the tilemap code?
     
  27. unity_U_rMttBfCZWmxA

    unity_U_rMttBfCZWmxA

    Joined:
    Sep 17, 2018
    Posts:
    1
    I'm seeing this issue now in 2018.3.0b1 when using Hex tiles.

    The tiles are there as (if I guess approximately where they are on the tile palette) I can use the brush to draw them on the tilemap. It's just that they're invisible for some reason.

    Restarting the client does nothing.
     
  28. lyoshiiro

    lyoshiiro

    Joined:
    Mar 2, 2019
    Posts:
    3
    Even in 2019 on 2018.1.0f2, this is still broken. any form of fixtures?
     
  29. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    If this still happens, could you file a bug using the Unity bug reporter with the reproduction Unity project and post the bug case here? That would be very helpful! Thanks!
     
  30. lyoshiiro

    lyoshiiro

    Joined:
    Mar 2, 2019
    Posts:
    3
    Yeap, filed a bug report, but what do you mean by post the bug case here? Sorry not used to seeing bugs from unity so i dont really know the usual procedures...
     
  31. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
  32. lyoshiiro

    lyoshiiro

    Joined:
    Mar 2, 2019
    Posts:
    3
  33. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    Thanks, we have access to the case and will check it out!
     
  34. jaded5505

    jaded5505

    Joined:
    May 10, 2019
    Posts:
    2
    Tileset (Tile Palette) not showing up in 2019.1.1f1 in Macbook Pro High Sierra

    I'm new to unity trying to learn through the tutorials but the tileset is not showin/ displaying at all. The character is clearly standing on something at the startup but it's not showing up. I have an iMac desktop with macOS El Capitan same year and it works perfectly. So I've done everything restarted, re-imported, deleted the tech mesh pro(whatever that is), re-installed unity hub, downloaded 2108 and 2017 versions, downloaded the 2d kit, imported the 2d kit and nothing is working for my Macbook Pro...Plz help!!!
     
  35. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    Could you please file a bug using the Unity bug reporter with the reproduction Unity project and post the bug case here? That would be very helpful!

    In the meantime, if you have screenshots of this, please do share them here as well!
     
  36. Beibei007

    Beibei007

    Joined:
    May 12, 2019
    Posts:
    3
    Thanks for your post. Unity 2019.1.1f1 Personal doesn't even have Tile Palette to choose.
    I am a newbie to this. Just started to watch the tutorial and have this issue. Not fun :(
    Since I just start, can anyone suggest me if I should download older version or wait for it to be fixed?
    Any advice will be appreciated. Thanks.
     
  37. Beibei007

    Beibei007

    Joined:
    May 12, 2019
    Posts:
    3
    oh I just saw this post, I am using Window 10 and it is not showing up on my too if that makes you feel better, you are not alone LOL :p
     
    jaded5505 likes this.
  38. Beibei007

    Beibei007

    Joined:
    May 12, 2019
    Posts:
    3
    OMG all....I found it!!! I am sorry to say, including this post, I posted 3 in a roll but I had not idea I found this and I have to shared! Again I have Unity 2019.1.1f1 Personal and running on window 10. Guess what... it is under
    Window => 2D => Tile Palette …. bomb is right there LOL :D
     
  39. jaded5505

    jaded5505

    Joined:
    May 10, 2019
    Posts:
    2
    I attached a screenshot of what I see when I import the 2d kit. The Tileset Gamekit does not display in the scene, game window or the tile pallette and I just upgrade to 2019.1.4. As you can see, the player is clearly standing on the platform. If someone can figure this out, I can complete the tutorial and learn how to use this software!!

    Note: The Tileset Rock Water Blockers are present and account for...very weird!!



     

    Attached Files:

  40. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    We will check this out!
     
  41. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    This seems fine for me. Could you share the inspector images for the following Tile assets:
    Assets\2DGamekit\Art\TileMapPalettes\Tileset\TilesetAlienRules.asset
    Assets\2DGamekit\Art\TileMapPalettes\Tileset\TilesetRockRules.asset
     
  42. KazYamof

    KazYamof

    Joined:
    Jun 26, 2015
    Posts:
    52
    2019.1.2
    Not showing, and some weird tris and pink squares when I'm painting.
    upload_2019-6-6_8-38-30.png
     
  43. pradocaetano

    pradocaetano

    Joined:
    Oct 4, 2012
    Posts:
    2
    Same problem here. Tile Palette not showing to me.
    Unity 2019.3.0a5
     
  44. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    The weird triangles could possibly from the addition of the 2D Animation package to your project. This has been fixed in 2019.1.3. The pink Tiles you see are TileAssets that do not exist anymore in your project, possibly check if they have been deleted?

    Could you elaborate more on this? If you do not have the Tile Palette window option anymore, you may need to import the Tilemap Editor package from the Package Manager.
     
  45. DavidNLN

    DavidNLN

    Joined:
    Sep 27, 2018
    Posts:
    48
    @ChuanXin
    Same for me on unity 2019.1.3a
    Works fine with default brush, but when using a custom brush that does nothing (just inherits from default brush is enough) brush wont show preview but will draw fine.
     
  46. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    249
    Just to check, does your custom brush have an Editor that inherits from GridBrushEditor just like the brush inherits from GridBrush?
     
  47. PhyNXT

    PhyNXT

    Joined:
    Apr 7, 2015
    Posts:
    4
    Had the same issue while using Unity 2019.2.05b, tried upgrading to 2019.2.0b6, then to 2019.3.0a6, the issue persists.

    Interestingly enough, I have one tile palette which I've been using for a couple Unity versions now that does properly display tiles and I can add tiles to it, no problem, but if I try making any new tile palettes, invisible tiles abounds. invisible tiles.gif
     
  48. Eleocraft

    Eleocraft

    Joined:
    Jun 19, 2019
    Posts:
    2
    Help me, I'cannot find the tile palette in unity 2019, not even in window 2d! The palette was there yesterday, but now the palette is gone.
     
  49. GiMiTiUs

    GiMiTiUs

    Joined:
    Jul 6, 2013
    Posts:
    6
    I had the exact same issue but i was using Unity 2019.3.0a5, then tried to fix it by upgrading unity to 2019.3.0a6. And like you said i also tried an older Tile Palette from my projects previous backup (version 2019.3.0a3) when there were no issues and it works, all the tiles were visible in the Tile Palette tab. I mean the tile assets from the backup Tile Palette are visible, other (not backup) palettes are still broken.