Search Unity

  1. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  2. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Participate with students all over the world and build projects to teach people. Join now!
    Dismiss Notice
  5. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

The Problem of Player passes through walls

Discussion in 'Physics' started by michaeltung, Jun 10, 2018.

  1. michaeltung

    michaeltung

    Joined:
    Aug 9, 2017
    Posts:
    6
    Last edited: Jun 10, 2018
  2. AlanMattano

    AlanMattano

    Joined:
    Aug 22, 2013
    Posts:
    905
    You are moving so fast that the wall is not detected. So you need to make the static wall thicker. If this is not possible, you have several more options but keep in mind that includes a performance cost. You can increase the physics update time step. Another option is to change the collision type to Continues Dynamic and the Interpolation to Extrapolate. Look into the Rigidbody Documentation.
    Go to your avatar game object, search for the rigid body component and in the inspector look for the variables "interpolation" and Collision Detection.
    For the timestep go to Edite> Player setting> Time> Fixed TimeStep and make it smaller.