Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Question The LOD group not working in terraint pain tree

Discussion in 'Getting Started' started by thinhnb, May 31, 2022.

  1. thinhnb

    thinhnb

    Joined:
    May 18, 2022
    Posts:
    2
    I have an warning in terrain when adding an tree Prefab with full Lod to the paint tree: "The selected tree does not have an LOD group, but has a hierarchy of Mesh renderers, only MeshRenderer on root GameObject in the trees hierarchy will be used. Use a tree with LOD group if you want a tree with hierarchy of MeshRenderers"
    Cant understand this, because my tree prefab already have and LOD group component.

    Have some image below, thanks for reading.
     

    Attached Files:

    • 3.jpg
      3.jpg
      File size:
      151.7 KB
      Views:
      288
    • 4.jpg
      4.jpg
      File size:
      80.3 KB
      Views:
      276
    ehudroge_unity likes this.
  2. CreepyLamppost

    CreepyLamppost

    Joined:
    Jun 26, 2017
    Posts:
    21
    Running into the same issue, I seem to have set up the tree with an LOD in the prefab asset and assigned all the mesh renderers, but still Terrain gives me the same error as the above screenshot. I'm in URP in 2020.3.13f1 if that helps.