Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question The image appears pixelated in the game view, although it is not pixelated in the original scene

Discussion in '2D' started by umen, Jun 5, 2023.

  1. umen

    umen

    Joined:
    Oct 2, 2012
    Posts:
    49
    Hello all

    I followed the tutorials on the internet, but it seems that nothing has helped. The image looks just fine when not playing, but when playing, it appears pixelated.:

    Pixlted :
    upload_2023-6-5_14-36-36.png

    Scene view:

    upload_2023-6-5_14-35-49.png
     
  2. MelvMay

    MelvMay

    Unity Technologies

    Joined:
    May 24, 2013
    Posts:
    11,657
    Because you're scaling the Game View in the editor. It's 1.8x
     
  3. umen

    umen

    Joined:
    Oct 2, 2012
    Posts:
    49
    even when im not scalling ? see :
    upload_2023-6-5_14-54-25.png
     
  4. MelvMay

    MelvMay

    Unity Technologies

    Joined:
    May 24, 2013
    Posts:
    11,657
    Your camera view area then?
     
  5. umen

    umen

    Joined:
    Oct 2, 2012
    Posts:
    49
    upload_2023-6-5_15-14-10.png
    This is my configuration
     
  6. karderos

    karderos

    Joined:
    Mar 28, 2023
    Posts:
    376
    low resolution = pixels

    switch filter mode to bilinear
     
  7. umen

    umen

    Joined:
    Oct 2, 2012
    Posts:
    49
    Tnx but where , i can't find it in the inspector while clicking on the image
     
  8. umen

    umen

    Joined:
    Oct 2, 2012
    Posts:
    49
    also maybe this is wrong my view configuration :
    upload_2023-6-5_16-31-16.png
     
  9. karderos

    karderos

    Joined:
    Mar 28, 2023
    Posts:
    376
    click on your sprites import settings and change filter mode to bilinear

    and yes thats very bad, put 900x1600 at least

    or 1080x1920
     
  10. umen

    umen

    Joined:
    Oct 2, 2012
    Posts:
    49
    i dont have this "sprites import settings" in the inspactor , where is it ?
    clicking on the image i can't see the option

    Set up to fixed resolution didn't help
     
    Last edited: Jun 6, 2023